CarPlay problems

smithrd65

Well-Known Member
First Name
David
Joined
May 11, 2018
Messages
809
Reaction score
676
Location
San Antonio
Vehicle(s)
2018 Jeep Wrangler Rubicon Unlimited JL. BMW Z4 35is, Tesla Model X90D, Chevy 2500 LTZ
It's not the Uconnect its Apple
Advertisement

 

MSchir1

Well-Known Member
First Name
Michael
Joined
Jun 9, 2018
Messages
88
Reaction score
145
Location
Cherry Hill, NJ
Vehicle(s)
Wrangler JL Sport
Update: Just brought mine in to the dealership for the uConnect update to fix the echo during phone calls and haven’t had the CarPlay issue since. Will keep you updated if it resurfaces.
 

stoowie

Well-Known Member
Joined
Dec 16, 2017
Messages
459
Reaction score
382
Location
Florida
Vehicle(s)
2018 Jeep Wrangler JL
Update: Just brought mine in to the dealership for the uConnect update to fix the echo during phone calls and haven’t had the CarPlay issue since. Will keep you updated if it resurfaces.
Do u know what they did? And are u getting that speaker issue from the front speaker below the steering wheel?
 

Tungsten308

Member
First Name
Adhemar
Joined
Sep 26, 2018
Messages
7
Reaction score
1
Location
Tampa, Florida
Vehicle(s)
Jeep JL sport S 2018
Have this issue since the first week I bought my JLU sport, I have already 2 month driving with this issue. It works whenever it want, I try original usb cables where I went to the apple store I got it myself but did not fix the issue, I tried aftermarket ones but same behavior, sometimes work 3 times in a row and the next day nothing. Sometimes by rebooting the phone and shutting the Jeep off works but 1 out of 5 try I would say. I even try to call Uconnect and they told it was not there issue, customer service just said we would let know the dealership, and nothing more hahahaha, I have look for software updates but it says that my version is the latest. Honestly I don’t know what to do, I laugh cuz I don’t wanna cry, is frustrating wanted to use feature and not be able to use it properly.
 

Sgt Beavis

Well-Known Member
First Name
Rick and Miyako
Joined
Apr 16, 2018
Messages
1,050
Reaction score
1,290
Location
Colorado
Vehicle(s)
Wrangler JL Unlimited Sport S
Occupation
The Man, The Myth, The Legend. In my own mind.
Vehicle Showcase
4
My latest problem with the uConnect and CarPlay is that the steering wheel’s left rocker switch no longer functions to advance or reverse the music track I’m listening to. I can only control it through the uConnect screen or my Apple Watch.

It will work on for a while after a uConnect reboot but eventually stops..

Navigation however, has continued to work flawlessly. It appears that issue is resolved for me.
 

Stingrey

Well-Known Member
First Name
Paul
Joined
Aug 28, 2018
Messages
200
Reaction score
240
Location
Waterloo ON
Vehicle(s)
2020 Jeep JTR & 2015 RR
Occupation
Civil Eng.
I haven't been able to get AA to work much at all for the past 3 weeks.
I have a Samsung Galaxy Note 8 with Android ver 8.0.0
I have factory reset the phone 2 times to no avail.
The dealer has reset the head unit. That fixed the problem for half a day.
edit: also have tried 3 usb-c to usb 3 cables. The cables work fine for data transfer and charging with wall adapters and computers.

Today I had a coworker plug in his Samsung Galaxy S8+. AA started up instantly.
Right away I thought the problem must be my phones usb port. So then I plugged in my Note 8 and it started to work...for about 30 seconds.
Then we plugged in my coworkers S8+ again and it didnt work either.

Frustrating system. Can't get good help troubleshooting.
 
Last edited:

MSchir1

Well-Known Member
First Name
Michael
Joined
Jun 9, 2018
Messages
88
Reaction score
145
Location
Cherry Hill, NJ
Vehicle(s)
Wrangler JL Sport
Do u know what they did? And are u getting that speaker issue from the front speaker below the steering wheel?
Sorry for the delayed response. They completed the bulletin that addressed the phone echo, I don’t remember it off the top of my head but it’s in this forum somewhere. Basically they download some update online and plug in a usb stick to update. I haven’t noticed a speaker issue up front.
 

jeep2019jz

New Member
First Name
Jaime
Joined
Sep 11, 2018
Messages
3
Reaction score
0
Location
Virginia
Vehicle(s)
2019 Jeep Cherokee Trailhawk
@Vandy23 have you had the issue come up again or is it permanently fixed ? What do you mean by having the Media Hub replaced ? Thanks
 

jeep2019jz

New Member
First Name
Jaime
Joined
Sep 11, 2018
Messages
3
Reaction score
0
Location
Virginia
Vehicle(s)
2019 Jeep Cherokee Trailhawk
Just had my Media Hub replaced and that fixed the issue. I believe this is a common problem!
have you had the issue come up again or is it permanently fixed ? What do you mean by having the Media Hub replaced ? Thanks
 

Vandy23

Well-Known Member
First Name
Craig
Joined
Jun 6, 2018
Messages
96
Reaction score
40
Location
Jersey
Vehicle(s)
18 JlU Sahara
No issues since the media hub was replaced. However it did mess up my Sirius Guardian account! The new hub requires me to bring it back to the dealer so I can set up a new account!
 

jeep2019jz

New Member
First Name
Jaime
Joined
Sep 11, 2018
Messages
3
Reaction score
0
Location
Virginia
Vehicle(s)
2019 Jeep Cherokee Trailhawk
No issues since the media hub was replaced. However it did mess up my Sirius Guardian account! The new hub requires me to bring it back to the dealer so I can set up a new account!
It's good news that the issue never came back for you, sorry to hear about the Guardian account. So I had the same CarPlay issue with my 2019 Cherokee Trailhawk. They replaced the media hub and I haven't noticed the issue come up yet.
Question for you.... do you have your phone paired up via Bluetooth as well or only USB... I was afraid that having it both was causing Carplay (when connected via USB) to fail
 

Vandy23

Well-Known Member
First Name
Craig
Joined
Jun 6, 2018
Messages
96
Reaction score
40
Location
Jersey
Vehicle(s)
18 JlU Sahara
I have connected to both and no issues!
 

hallry

New Member
First Name
Ryan
Joined
Oct 23, 2018
Messages
3
Reaction score
8
Location
Mountain View, CA
Website
www.goose-gear.com
Vehicle(s)
Bright White 2018 Jeep JL Unlimited Rubicon
Occupation
Marketing & Creative Director @ Goose Gear
Vehicle Showcase
1
I just purchased my 2018 JLU Rubicon and after three days of using CarPlay this morning it stopped recognizing the device via USB. It will charge and Uconnect will still remain connected via Bluetooth. Tried the following:

Hard Rest in IPhone.
Turned vehicle off and opened door
Erased Personal Settings on Uconnect
Reset to Default on Uconnect
Deleted IPhone from Bluetooth Uconnect
Forgot device in iPhone Bluetooth settings
Forgot device in CarPlay Settings on IPhone

Also I tried to connect with Guardian Assist and it called but said the Uconnect was in test mode and needed a pin. And nothing happened but silence. I couldn’t even hang up.

I’ll try again when I get back to the Jeep after work. Should be in about 8 hours or so.
 

JNPMusic

New Member
First Name
John
Joined
Sep 10, 2018
Messages
2
Reaction score
0
Location
PA
Vehicle(s)
Jeep Wrangler JL
I tried the airplane mode and it worked, but kind of time consuming... I also toggle the mute button up and down (reconnect cable) and seems to work a little faster. I also noticed if I'm in the mute position is when I have the most problems with it connecting to CarPlay mode.....
 
Advertisement

Done Right LED
 
Advertisement
Top