CarPlay problems

Djmatt85

Well-Known Member
First Name
Daniel
Joined
Aug 14, 2018
Messages
233
Reaction score
330
Location
Sacramento, CA
Vehicle(s)
18 JL Sahara
Vehicle Showcase
1
I just purchased my 2018 JLU Rubicon and after three days of using CarPlay this morning it stopped recognizing the device via USB. It will charge and Uconnect will still remain connected via Bluetooth. Tried the following:

Hard Rest in IPhone.
Turned vehicle off and opened door
Erased Personal Settings on Uconnect
Reset to Default on Uconnect
Deleted IPhone from Bluetooth Uconnect
Forgot device in iPhone Bluetooth settings
Forgot device in CarPlay Settings on IPhone

Also I tried to connect with Guardian Assist and it called but said the Uconnect was in test mode and needed a pin. And nothing happened but silence. I couldn’t even hang up.

I’ll try again when I get back to the Jeep after work. Should be in about 8 hours or so.
I had that happen to me also (a few days after picking up from dealer). Was working fine after work that day. Maybe a glitch. I’ve had similar issues with the audio not working. Letting it sit for a few hours fixed it. 3 times in 6 months... not to big of a deal for me.





Advertisement

 

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,478
Reaction score
2,189
Location
Auburn Hills, MI
Vehicle(s)
JL
I just purchased my 2018 JLU Rubicon and after three days of using CarPlay this morning it stopped recognizing the device via USB. It will charge and Uconnect will still remain connected via Bluetooth. Tried the following:

Hard Rest in IPhone.
Turned vehicle off and opened door
Erased Personal Settings on Uconnect
Reset to Default on Uconnect
Deleted IPhone from Bluetooth Uconnect
Forgot device in iPhone Bluetooth settings
Forgot device in CarPlay Settings on IPhone

Also I tried to connect with Guardian Assist and it called but said the Uconnect was in test mode and needed a pin. And nothing happened but silence. I couldn’t even hang up.

I’ll try again when I get back to the Jeep after work. Should be in about 8 hours or so.
Hi hallry,
Congrats on your Jeep purchase! Send us a private message and let us know if this continues to happen so we can have this looked into further for you.
Lydia
Jeep Social Care Specialist
 

31R

Active Member
First Name
Darrell
Joined
Sep 24, 2018
Messages
43
Reaction score
17
Location
Dublin, CA
Vehicle(s)
2018 JL Wrangler Unlimited Rubicon
Vehicle Showcase
1
Happened to me too. I happened to have an extra cable, tried it and it worked.



I just purchased my 2018 JLU Rubicon and after three days of using CarPlay this morning it stopped recognizing the device via USB. It will charge and Uconnect will still remain connected via Bluetooth. Tried the following:

Hard Rest in IPhone.
Turned vehicle off and opened door
Erased Personal Settings on Uconnect
Reset to Default on Uconnect
Deleted IPhone from Bluetooth Uconnect
Forgot device in iPhone Bluetooth settings
Forgot device in CarPlay Settings on IPhone

Also I tried to connect with Guardian Assist and it called but said the Uconnect was in test mode and needed a pin. And nothing happened but silence. I couldn’t even hang up.

I’ll try again when I get back to the Jeep after work. Should be in about 8 hours or so.
 

omargg9

Member
First Name
Frank
Joined
Jul 3, 2018
Messages
6
Reaction score
1
Location
San Diego, CA
Vehicle(s)
2018 Jeep Wrangler Unlimited Sport S JL
Does anyone has found a fix for this? This is really frustrating! =\
 

Ppita02

Well-Known Member
First Name
Paul
Joined
Oct 21, 2018
Messages
112
Reaction score
69
Location
Dallas, TX
Vehicle(s)
2018 JLU Rubicon
I just purchased my 2018 JLU Rubicon and after three days of using CarPlay this morning it stopped recognizing the device via USB. It will charge and Uconnect will still remain connected via Bluetooth. Tried the following:

Hard Rest in IPhone.
Turned vehicle off and opened door
Erased Personal Settings on Uconnect
Reset to Default on Uconnect
Deleted IPhone from Bluetooth Uconnect
Forgot device in iPhone Bluetooth settings
Forgot device in CarPlay Settings on IPhone

Also I tried to connect with Guardian Assist and it called but said the Uconnect was in test mode and needed a pin. And nothing happened but silence. I couldn’t even hang up.

I’ll try again when I get back to the Jeep after work. Should be in about 8 hours or so.
I am having the same issues. Seems the Apple car play works every other day. Frustrating. At least it charges my phone but I want my maps and music!
 

Patinito

Well-Known Member
First Name
Michael
Joined
Oct 30, 2018
Messages
278
Reaction score
972
Location
Miami, Florida
Vehicle(s)
2018 MOAB "Saharacon"
Occupation
SysAdmin
Vehicle Showcase
1
Having the same intermittent CarPlay problems. It mostly happens from the center Console USB port. Tried removing the phone from the projector and the bluetooth settings and rebooting the phone. It doesn't seem like its iOS because when the center Console USB cuts out (it still charges but you cannot use CarPlay or USB reading) and I plug it into the media USB carpal then works. 6 days with the jeep.
 

Patinito

Well-Known Member
First Name
Michael
Joined
Oct 30, 2018
Messages
278
Reaction score
972
Location
Miami, Florida
Vehicle(s)
2018 MOAB "Saharacon"
Occupation
SysAdmin
Vehicle Showcase
1
Hi everyone,

I came across some internal information that might help. With recent iOS updates, iPhones may have had the USB accessibility option turned off. To verify this, go under Settings > Touch ID & Passcode > USB Accessories. If turning this on doesn't fix the issue, I would recommend checking in with your dealership to schedule an inspection. DM us if you have any questions or need further assistance!

Jennifer
Jeep Social Care Specialist
From another post.
 

aug0211

Well-Known Member
Joined
Feb 19, 2018
Messages
1,643
Reaction score
1,325
Location
Ohio
Vehicle(s)
JLUR Turbo, JLUR 4xe
Here's something interesting - possibly related to the posts mentioning that Airplane Mode helps relieve the issue:

I have horrible cell service in my neighborhood. I exit from a pretty major highway directly into the entrance to my neighborhood and as I turn in to the 'hood, my cell service drops significantly - enough so that my calls normally drop out when I enter the neighborhood and I cannot get data services to work until I am out of the neighborhood.

On my way home from work (about a 40 minute drive), CarPlay generally works with no problems - but it regularly disconnects as I get to my neighborhood. Once I started noticing that it happens at almost the exact same spot in the road, I wondered if it was a matter of how long the phone had been connected - but then I stopped a few times to go through a car wash (extending my drive time) and my phone still disconnected at the same exact spot.

I'm thinking there is something related to the phone searching for cell service that is somehow tied in to Uconnect rejecting the device.
 

Ppita02

Well-Known Member
First Name
Paul
Joined
Oct 21, 2018
Messages
112
Reaction score
69
Location
Dallas, TX
Vehicle(s)
2018 JLU Rubicon
Having the same intermittent CarPlay problems. It mostly happens from the center Console USB port. Tried removing the phone from the projector and the bluetooth settings and rebooting the phone. It doesn't seem like its iOS because when the center Console USB cuts out (it still charges but you cannot use CarPlay or USB reading) and I plug it into the media USB carpal then works. 6 days with the jeep.
Today tried out a few things. Wife has iPhone 6s Plus and I have iPhone 7 Plus. Tried both our phones, 3 different cables and and all combinations of usb plugs on the Jeep. The. Checked settings on each phone. Nothing worked. At this point I ruled out the phones being the issue. I then started messing with settings/options on the Jeep. Honestly I just pressed butttons to see if anything would work.

Note: I have JL Unlimited Rubicon with the Infotainment Group (8.4” display).

Try this:
1. Settings
2. Scroll down to Phone/Bluetooth

From this menu I just went through all the settings. Made sure it was actually connected (see photo). For both “Paired Phones” and “Paired Audio Sources” options. Next menu option is Smartphone Projection Manager (See photo). Then pressed on “Paul's...” phone and pressed on “Enable Apple CarPlay” if it wasn’t already not sure. (See Photo).

Then I plugged in my phone to each USB (1, 2, 3).
Notification on my phone said to unlock. So I did...and voila it worked!!!

Not sure what made it work exactly, mind you I just pressed buttons...

Let me know if this works for anyone!

Good luck!

image.jpg


image.jpg


image.jpg


image.jpg
 

JFGL

New Member
First Name
John
Joined
Nov 4, 2018
Messages
1
Reaction score
0
Location
La Mesa
Vehicle(s)
2018 Wrangler JL Unlimited
Wow, still no update or fix for this issue? Just picked up our JL and after a couple days, same issue as several others on this post. Read the posts and seems to be an ongoing problem.

I guess we will have to take it back to the dealer to see if somebody can fix our issue. Maybe get the media hub replaced?
 

Godzilla

Well-Known Member
Joined
Apr 14, 2018
Messages
94
Reaction score
32
Location
Wyoming
Vehicle(s)
Ram 2500
I have an '18 JLUR with 8.4" system. Up until recently, I used CarPlay with my old iPhone 6s plugged into the dash, and my very old iPod touch plugged into the center console. The CarPlay for the phone worked great for everything it should - I never played music off it because I had no music loaded on to it. The iPod worked great through the media app on uConnect - could access all my music and it had a good interface.

I just upgraded my phone to iPhone XS Max and loaded all my music to it. When using CarPlay, driving down the road, I try to access the menu to choose an artist/album/song and I get a limited list (Recent Downloads, Most Listened To - I think that's what they were). There is a message at the bottom that says something like 'limited access while driving, ask Siri to get more.' Of the music that is listed/available - when I click on "Artist" and then make a selection, it automatically starts playing a random song for that person - I don't get to choose an album or individual tracks.

I can access all music by picking up the phone and using it... which obviously negates the purpose of CarPlay. Does anyone else have this issue and has it been addressed? I have done google searches on it and found very little on it at all - which leads me to believe that I haven't done something correctly.
 

Godzilla

Well-Known Member
Joined
Apr 14, 2018
Messages
94
Reaction score
32
Location
Wyoming
Vehicle(s)
Ram 2500
Interestingly, went outside a while ago and re-tried it after going into the phone's restriction settings, making sure the restrictions box was set to on - then went through every item and set them to "Allow" except for 'Do Not Disturb While Driving,' I turned that one off.
 

Lyleb80

Active Member
First Name
Lyle
Joined
Apr 23, 2018
Messages
29
Reaction score
13
Location
Mesa AZ
Vehicle(s)
2018 Wrangler JL
Occupation
Aircraft mechanic
I have an issue with my usb plugs, they kill the stereo power and it resets the clock to 1200, I have trride new cords and different plugins and it cotinues to kill the stereo power i,ve also dealeted device on phone and stereo and repaired but I still have the issue. It works great as long as I don't plug it in.
 

Ppita02

Well-Known Member
First Name
Paul
Joined
Oct 21, 2018
Messages
112
Reaction score
69
Location
Dallas, TX
Vehicle(s)
2018 JLU Rubicon
So after what I thought fixed the issue apparently did not. Now when I first get in the Jeep and plug in, Apple Car Play works between a few minutes to an hour and then randomly decides to stop working while plugged in and driving...this is becoming very annoying...I can't show my friends because it will stop working and they will think Jeep is crap...anyone have a permanent fix for this issue? Thanks in advance.
 

Advertisement




D&C Designs
 



Advertisement
Top