Diode Dynamics LED Mod

Diode Dynamics

Well-Known Member
Summit Sponsor (Level 3)
First Name
John
Joined
Feb 28, 2017
Messages
659
Reaction score
173
Location
St. Louis, Missouri
Website
www.diodedynamics.com
Vehicle(s)
2018 Jeep Wrangler
The new ones don’t “clip” in on my Sahara, and therefore aren’t turning on...
I'm sorry you're having an issue with these! If possible, go ahead and give us a call at 314-205-3033 Monday-Friday 9 a.m.- 5 p.m. CST, or shoot us an email at [email protected], and my service team will be happy to troubleshoot that.

Jake H.
Diode Dynamics
 

butcho

Well-Known Member
Joined
Sep 2, 2018
Messages
227
Reaction score
212
Location
Charlotte, NC
Vehicle(s)
2018 Jeep Wrangler JLU
I have a JL Sport S, and have succeeded in turning on "always on" Daytime running lights via the Z-Automotive programming unit. using this programmer, I selected the turn signal lights/parking lights as the DRL. This programming tool lets you choose whether you are running standard lighting or LED bulbs, seperately for each individual set of exterior lights you have running on the jeep - so I set it to the Turn Signals as the DRL, selected LED type bulbs on, and inserted these Diode Dynamics bulbs - then turned the ignition on and the only thing I got was an 1 tone amber color! They blinked on and off when the turn signal lever was depressed left or right, and certainly are nice and bright, but there was no switch back functionality at all for some reason. They start as amber and stay amber - so I turned the lighting back to standard with the programmer and immediately got the hyper blink on the dash, but still - only had an amber color, with no white color showing at all. I then rotated the bulb in the socket 180* but it made no difference, so I am returning them (ebay seller, offerring Diode Dynamics Switchbacks). I did look closely at these bulbs and the LED row on them don't even appear to have any white LED squares at all - just yellow, and amber squares. You would think there would be 50% rows of white, but there are none. Any idea what is going on here with these or why they don't work for me? I'd like to use them, but maybe they are not compatible with the Z-Automotive programmer?
Able to get this fixed?
 
Advertisement

TopLift Pros
 
Advertisement
Top