Terrible Radio Reception

Rhinebeck01

Well-Known Member
Joined
May 9, 2018
Messages
6,150
Reaction score
7,353
Location
.
Vehicle(s)
2018 2dr. Rubi
Read the TSB...it addresses the static and cut outs that some are experiencing with UConnect.
As I said ... that update is not for the 8.4 Infotainment Center. It is for the 4 and 7 radio only.





Advertisement

 

W5MQS

Well-Known Member
First Name
Mitch
Joined
Mar 8, 2018
Messages
573
Reaction score
584
Location
Temple, Texas
Vehicle(s)
2018 Granite Wrangler Rubicon JLU; 2020 Mercedes GLB 250; 2013 Red Ford F-150 4x4
Build Thread
Link
Occupation
Interventional Cardiology
I stand corrected...I see what you're speaking about...my bad. Sorry. :headbang:
 

digger

Member
First Name
Bob
Joined
Mar 28, 2018
Messages
14
Reaction score
25
Location
Massachusetts
Vehicle(s)
2010 Challenger, 99 Fat Boy, 2017 Camaro convertable,2 f350 trucks,2011 Grand Cherokee, 2009 Patriot
@digger

Just so your understand the setup...

The satellite receiver on the JL and the AM/FM radio antenna are two different animals.

You have a mast antenna that is solely for AM/FM reception.

As far as Sirius/XM satellite radio, the "satellite radio receiver" is what is used for SiriusXM reception.

DO KNOW that MANY JL/JLU owner's here have posted that SiriusXM reception is very poor in regard to their vehicle.

On the Wrangler JK and JL, the "satellite radio receiver" for use with SiriusXM resides up on top of the sound bar/roll bar, just above and behind the passenger.


.
Thanks for the info. Dealer said they would have to start taking it apart to diagnose. The fm radio either works or it doesn't, when it doesn't, it seeks through the entire radio range as if there is not antenna then lands on the one station where the tower is 1/4 mile behind my house. sometimes after several minutes it gets reception and then I get every station. The sat radio spins looking for signal.
 

smithrd65

Well-Known Member
First Name
David
Joined
May 11, 2018
Messages
808
Reaction score
661
Location
San Antonio
Vehicle(s)
2018 Jeep Wrangler Rubicon Unlimited JL. BMW Z4 35is, Tesla Model X90D, Chevy 2500 LTZ
No issue here
 

jmgrant41

Well-Known Member
Joined
Jul 18, 2018
Messages
50
Reaction score
19
Location
Fairfax, VA
Vehicle(s)
2018 Wrangler Sahara JLU
I've had my JLU for a little over a week and just noticed the FM/AM radio was not coming in on any channel. I checked the lower passenger kick panel and sure enough, the antenna coming in through the fender well was disconnected from the cable running into the back of the UConnect. I reconnected and everything is working fine now.
 

SRQClementine

New Member
First Name
Tim
Joined
Sep 26, 2018
Messages
3
Reaction score
0
Location
Sarasota
Vehicle(s)
2018 JL Wranger
I've had my JLU for a little over a week and just noticed the FM/AM radio was not coming in on any channel. I checked the lower passenger kick panel and sure enough, the antenna coming in through the fender well was disconnected from the cable running into the back of the UConnect. I reconnected and everything is working fine now.
Can you share pictures of the spot you found the fix for? My AM/FM doesn’t work either. Thank you.
 

Bagwel

Member
First Name
Bagwell
Joined
Sep 21, 2018
Messages
19
Reaction score
6
Location
Madison
Vehicle(s)
2018 JLU Sahara; 2013 JKU Rubicon
There is an option on the screen for “HD” however I’ve not noticed a difference when turning it off and on.

It has to be a wiring issue, just today I tuned through all FM channels and was lucky to hear anything besides static. I will contact Jeep to see if anyone else has reported a similar issue.
I realize you posted this 6 months ago, but I'm having the same issue in my new JLU. For the first week, everything was fine. Now all of a sudden, I can't get jack sh!t for FM reception!

Did you ever find a fix for your issue??
 

SRQClementine

New Member
First Name
Tim
Joined
Sep 26, 2018
Messages
3
Reaction score
0
Location
Sarasota
Vehicle(s)
2018 JL Wranger
I realize you posted this 6 months ago, but I'm having the same issue in my new JLU. For the first week, everything was fine. Now all of a sudden, I can't get jack sh!t for FM reception!

Did you ever find a fix for your issue??
Same. And am too.
 
OP
themattparty

themattparty

Member
First Name
Matt
Joined
Mar 5, 2018
Messages
16
Reaction score
6
Location
Houston
Vehicle(s)
2018 JLU Rubicon
  • Thread starter
  • Thread Starter
  • #39
Unfortunately, I have yet to find a fix. The only solution Jeep offered me when I contacted them was to take it in to dealership and let them take it apart. The dealership quoted me a 5-7 days, which I wasn't going to do. So as of right now I am hoping a recall or something is issued. Luckily I hardly ever use my FM radio, but it is very annoying to say the least. Especially for how much we pay for these vehicles.
 
First Name
Houston
Joined
Sep 27, 2018
Messages
6
Reaction score
2
Location
Katy, TX
Vehicle(s)
2018 JL Wrangler Unlimited Sport S
Just wondering if this is a common occurrence or just an issue with my JLU, but ever since I have owned my new Rubicon I have had TERRIBLE radio reception. I realize that a large amount of people will just use Carplay or Bluetooth for music...but sometimes I take a quick trip and forget my phone or just want to listen to the radio. Extremely static/white noise/terrible reception for nearly every station. Also, I live in Houston, TX so its a major city, i'm not in the middle of the wilderness.

Anyone else? Potential fix?
I have had that same problem, went with an aftermarket stubby antenna........no help. Did you get a resolution?
 
First Name
Houston
Joined
Sep 27, 2018
Messages
6
Reaction score
2
Location
Katy, TX
Vehicle(s)
2018 JL Wrangler Unlimited Sport S
no I didn't think that, I liked the look of the stubby antenna.
but thanks for commenting, your insight was so helpful.
 

dave.j.fisher

Well-Known Member
First Name
Dave
Joined
Feb 16, 2018
Messages
182
Reaction score
217
Location
Macomb, Michigan
Vehicle(s)
JLUR
Has anyone found a solution to the FM radio reception issues? I've had enough, taking it in soon. I did my best to check the antenna connection under the glove box and kick plate. I don't see any bad connections. Has anyone had this fixed by the dealer?
 

Advertisement




Allmoparparts.com
 



Advertisement
Top