Terrible Radio Reception

themattparty

Member
First Name
Matt
Joined
Mar 5, 2018
Messages
16
Reaction score
6
Location
Houston
Vehicle(s)
2018 JLU Rubicon
Just wondering if this is a common occurrence or just an issue with my JLU, but ever since I have owned my new Rubicon I have had TERRIBLE radio reception. I realize that a large amount of people will just use Carplay or Bluetooth for music...but sometimes I take a quick trip and forget my phone or just want to listen to the radio. Extremely static/white noise/terrible reception for nearly every station. Also, I live in Houston, TX so its a major city, i'm not in the middle of the wilderness.

Anyone else? Potential fix?





Advertisement

 

obwahn

Well-Known Member
First Name
Mike
Joined
Feb 3, 2018
Messages
25,632
Reaction score
140,983
Location
SoCal
Vehicle(s)
2018 JLR (Wrikki), 2018 Grand Sport (V)
Occupation
Retired puter dork
Vehicle Showcase
1
Just wondering if this is a common occurrence or just an issue with my JLU, but ever since I have owned my new Rubicon I have had TERRIBLE radio reception. I realize that a large amount of people will just use Carplay or Bluetooth for music...but sometimes I take a quick trip and forget my phone or just want to listen to the radio. Extremely static/white noise/terrible reception for nearly every station. Also, I live in Houston, TX so its a major city, i'm not in the middle of the wilderness.

Anyone else? Potential fix?
Assume you are not talking SXM?
 
OP
themattparty

themattparty

Member
First Name
Matt
Joined
Mar 5, 2018
Messages
16
Reaction score
6
Location
Houston
Vehicle(s)
2018 JLU Rubicon
  • Thread starter
  • Thread Starter
  • #3
Assume you are not talking SXM?
I meant FM/AM. Sorry, should have stated that in the post. Sat Radio works fine. Also have checked the antenna and its connected fine no problem. Wondering if there may be a wiring issue. Just wanted to see if anyone else had come across this issue yet.
 

jroman

Well-Known Member
First Name
Jorge
Joined
Jan 13, 2018
Messages
717
Reaction score
936
Location
Chicago, IL
Vehicle(s)
2018 Jeep Wrangler JLU Sahara (Granite)
Occupation
BCBA
Vehicle Showcase
1
I meant FM/AM. Sorry, should have stated that in the post. Sat Radio works fine. Also have checked the antenna and its connected fine no problem. Wondering if there may be a wiring issue. Just wanted to see if anyone else had come across this issue yet.
If this hasn't happened with your previous cars, then it must be the antenna or wiring. Mine has been crispy clear on all AM, FM, SXM. Maybe try getting one of those aftermarket antennas before looking into the wiring?
 

bjeep1983

Member
First Name
Brian
Joined
Feb 14, 2018
Messages
16
Reaction score
33
Location
Northampton, PA
Vehicle(s)
2018 Wrangler Unlimited JL Rubicon
I haven’t used AM/FM a lot but my Sirius cuts out. They sent me a link to refresh on my own but doesn’t seem to work.
 

Skippy

Well-Known Member
First Name
Aaron
Joined
Mar 21, 2018
Messages
96
Reaction score
53
Location
Minnesota
Vehicle(s)
2018 JLUR, 1996 Ford Bronco 351W
I actually got a shorter black antenna on mine and still never have the issues like you mentioned. I would probably bring it in since I rarely use satellite or bluetooth or carplay or anything else. I wish these had cd players...
 

W5MQS

Well-Known Member
First Name
Mitch
Joined
Mar 8, 2018
Messages
573
Reaction score
584
Location
Temple, Texas
Vehicle(s)
2018 Granite Wrangler Rubicon JLU; 2020 Mercedes GLB 250; 2013 Red Ford F-150 4x4
Build Thread
Link
Occupation
Interventional Cardiology
I believe the regular radio is an HD radio? Someone correct me if I'm wrong on that...or maybe that is only if you upgrade the package to the "infotainment package'.
 
OP
themattparty

themattparty

Member
First Name
Matt
Joined
Mar 5, 2018
Messages
16
Reaction score
6
Location
Houston
Vehicle(s)
2018 JLU Rubicon
  • Thread starter
  • Thread Starter
  • #8
I believe the regular radio is an HD radio? Someone correct me if I'm wrong on that...or maybe that is only if you upgrade the package to the "infotainment package'.
There is an option on the screen for “HD” however I’ve not noticed a difference when turning it off and on.

It has to be a wiring issue, just today I tuned through all FM channels and was lucky to hear anything besides static. I will contact Jeep to see if anyone else has reported a similar issue.
 

Scott1911

Well-Known Member
First Name
Scott
Joined
Dec 6, 2017
Messages
183
Reaction score
278
Location
Oklahoma
Vehicle(s)
JL 2 Door Unicorn
Check how tight your antenna is screwed into the mount. Might not have been tightened.
 

Grimm_E

Well-Known Member
Joined
Apr 7, 2018
Messages
86
Reaction score
100
Location
Maryland
Vehicle(s)
2018 Wrangler JL Unlimited Rubicon
I have not had any problems with the radio at all. But I agree with others on the thread, that you should check the antenna to make sure it is not loose.
 

Hootbro

Well-Known Member
First Name
Don
Joined
Mar 22, 2018
Messages
203
Reaction score
191
Location
Delaware
Vehicle(s)
2018 JLU Sport, 2020 JT Rubicon
I meant FM/AM. Sorry, should have stated that in the post. Sat Radio works fine. Also have checked the antenna and its connected fine no problem. Wondering if there may be a wiring issue. Just wanted to see if anyone else had come across this issue yet.
Mine was delivered with the antenna disconnected at the right lower kick panel were the antenna comes into the cab. Never noticed it for a couple of days as I almost use SXM exclusively. Also found some assembly trash with a plastic bag stuck behind the glove box when I was troubleshooting this.
 
OP
themattparty

themattparty

Member
First Name
Matt
Joined
Mar 5, 2018
Messages
16
Reaction score
6
Location
Houston
Vehicle(s)
2018 JLU Rubicon
  • Thread starter
  • Thread Starter
  • #13
Mine was delivered with the antenna disconnected at the right lower kick panel were the antenna comes into the cab. Never noticed it for a couple of days as I almost use SXM exclusively. Also found some assembly trash with a plastic bag stuck behind the glove box when I was troubleshooting this.
That would make sense for my issue. Thanks for the info! Will give it a look. Fingers crossed that solves my problem!
 

Newbiejeeperjl

Well-Known Member
Joined
Feb 10, 2018
Messages
89
Reaction score
73
Location
Texas
Vehicle(s)
Unlimited JL
Just wondering if this is a common occurrence or just an issue with my JLU, but ever since I have owned my new Rubicon I have had TERRIBLE radio reception. I realize that a large amount of people will just use Carplay or Bluetooth for music...but sometimes I take a quick trip and forget my phone or just want to listen to the radio. Extremely static/white noise/terrible reception for nearly every station. Also, I live in Houston, TX so its a major city, i'm not in the middle of the wilderness.

Anyone else? Potential fix?
I totally agree with you. I live 30 min from downtown Dallas and I can barely get reception on my radio. If you fix the issue. Please let me know.
 

Hootbro

Well-Known Member
First Name
Don
Joined
Mar 22, 2018
Messages
203
Reaction score
191
Location
Delaware
Vehicle(s)
2018 JLU Sport, 2020 JT Rubicon
That would make sense for my issue. Thanks for the info! Will give it a look. Fingers crossed that solves my problem!
My advice is to drop the glove box down and out. Reach inside and feel for where the antenna base come through the right fender into the cab and feel for the pig tail and follow it down for about 12" or so and it should have a connection point right below the glove box by the kick panel and that goes to the back of your radio from there.

In my case, that antenna cable between the back of the radio to the antenna pigtail connection is wrapped into a wire harness and is somewhat banjo'd at that first connection point off the antenna pigtail. It was a pain to get back connected.
 
Last edited:

Advertisement




Diode Dynamics
 



Advertisement
Top