START/STOP & ELECTRONIC STABILITY CONTROL SERVICE MESSAGE

Rico1111

Well-Known Member
First Name
Rico
Joined
Oct 6, 2019
Messages
979
Reaction score
1,087
Location
RI
Vehicle(s)
2018 Rubicon 2 door JL
Okay So I have this issue as well and have had it for about 6 months. Lights go on (ESC and Auto stopStart needs to be serviced)like everyone else it comes on for me after about 20 minutes on the highway and then after I shut it down at home and get in it in the morning it is gone. I made an appointment at the dealer and while pulling into their parking lot the light came on ...left it running and I made the service guy come out and see it. I thought maybe batteries? Jeep was at 34 or 35000 so i wanted it fixed (I also have extended warranty but did not want to pay the 100 deductible if I waited) they do a load test...not batteries but the guy had shut it down and now no lights on so as i sit there 2 hours the mechanic comes out and says he can't duplicate it?
K....you saw it on the screen and I also have pics of it. He says if he can't duplicate it he can't know where to begin to fix it...he also said there were no codes thrown. I leave and of course still have it daily.
I really don't get why Dealerships don't want to address what is clearly an issue that many Jeeps are experiencing..all I know is when I need to bring it in again I sure as hell am not paying for it to be fixed. There was another thread about this issue and many posters said that it was wheel adjustment and that if you got under the front and adjusted the draglink it would center the wheel again and not set off the signals but it was if you lifted the vehicle which I have not...here is the link from another site claiming the same thing.
http://www.northridgenation.com/fix-the-esc-warning-in-your-jl-after-a-lift/
Advertisement

 

Dkretden

Well-Known Member
First Name
David
Joined
Jan 29, 2019
Messages
2,515
Reaction score
3,424
Location
Denver, CO
Vehicle(s)
2020 JLUR 3.6L
Okay So I have this issue as well and have had it for about 6 months. Lights go on (ESC and Auto stopStart needs to be serviced)like everyone else it comes on for me after about 20 minutes on the highway and then after I shut it down at home and get in it in the morning it is gone. I made an appointment at the dealer and while pulling into their parking lot the light came on ...left it running and I made the service guy come out and see it. I thought maybe batteries? Jeep was at 34 or 35000 so i wanted it fixed (I also have extended warranty but did not want to pay the 100 deductible if I waited) they do a load test...not batteries but the guy had shut it down and now no lights on so as i sit there 2 hours the mechanic comes out and says he can't duplicate it?
K....you saw it on the screen and I also have pics of it. He says if he can't duplicate it he can't know where to begin to fix it...he also said there were no codes thrown. I leave and of course still have it daily.
I really don't get why Dealerships don't want to address what is clearly an issue that many Jeeps are experiencing..all I know is when I need to bring it in again I sure as hell am not paying for it to be fixed. There was another thread about this issue and many posters said that it was wheel adjustment and that if you got under the front and adjusted the draglink it would center the wheel again and not set off the signals but it was if you lifted the vehicle which I have not...here is the link from another site claiming the same thing.
http://www.northridgenation.com/fix-the-esc-warning-in-your-jl-after-a-lift/
Post #4 in this thread was what my dealership just diagnosed on mine (Last week). I had ESC faults and Auto stop start faults.

there is a star case out there that describes the vacuum pump issue (mine was, hopefully just a loose connection that the dealership has fixed). they said that I had a fault code of P258B and that lead them to star case s1805000006.

they also determined that I needed a PCM Flash.

so far, so good.

maybe this will work for you.
 

Rico1111

Well-Known Member
First Name
Rico
Joined
Oct 6, 2019
Messages
979
Reaction score
1,087
Location
RI
Vehicle(s)
2018 Rubicon 2 door JL
Post #4 in this thread was what my dealership just diagnosed on mine (Last week). I had ESC faults and Auto stop start faults.

there is a star case out there that describes the vacuum pump issue (mine was, hopefully just a loose connection that the dealership has fixed). they said that I had a fault code of P258B and that lead them to star case s1805000006.

they also determined that I needed a PCM Flash.

so far, so good.

maybe this will work for you.
Thanks so much for the info you provided!! I haven't taken it back yet and will def use this info when I do. Glad you got yours fixed ...Ironically even though the lights come on I have no other problems with the rig ...still drives normal. Just not to keen on having the lights appear knowing there is something causing it. Again Thanks!!
 

AC7880

New Member
First Name
DAN
Joined
Nov 7, 2021
Messages
4
Reaction score
3
Location
TX
Vehicle(s)
2021 Grand Cherokee
Do you tow your jeep behind a motorhome 4 wheels down and have a demco air force one brake system installed?

I do, and on mine it was a vacum problem. I cleared the one way check valves on the demco brake system and pulled the breakaway switch for a couple of minutes. One or the other cleared both start stop and traction control/ESC dash displays.

Before I tried that, dealer tested primary and aux battery, replaced main battery, changed vacum pump and vacumm sensor. No help, but I think they were on the right track with a vacum issue.
 

AC7880

New Member
First Name
DAN
Joined
Nov 7, 2021
Messages
4
Reaction score
3
Location
TX
Vehicle(s)
2021 Grand Cherokee
I get the Start-Stop not working along with the Traction control or anti-skid warning light in stop and go traffic. I also had to add a charge line from my RV as the battery in the Jeep died after being towed about 700 miles. The lights are powered from the RV and the brake draws zero power unless the breakaway is activated being an AIr-Brake system. Sort of wishing I might have bought a 4x4 Pick-up. Jeep was SUPPOSED to be and always used to be the go to vehicle for flat towing behind our RVs.
Check any and all one way check valves in your tow brake wiring. If one is sticking or has debris in what you describe will happen.
 

mikelectic

Member
First Name
Mike
Joined
Feb 26, 2020
Messages
6
Reaction score
3
Location
NYC/NJ
Vehicle(s)
JLU Sahara, Porsche Panamera GTS, Triumph Bobber
I know there's multiple threads on this issue but leaving my mark on this one since it seems to have the most activity as well as the most recent activity.

I had the service ESC first pop up about a year ago. Eventually went away after a restart and didn't really pop up again until recently. Perhaps the cold weather has something to do with it - just a hunch since I remember it starting first popping up going into the winter season last year too.

When the service light is on the dash I hear the vacuum kick in for a few seconds, stop, and going to cycle like this. Would that mean that the vacuum pump or hose needs to be replaced? I read a lot of people mentioning that being the culprit. Would rather not have the dealer waste my time replacing a bunch of other things before getting to the root of the issue.

And if so anyone have an idea of what it cost to replace at the dealer out of warranty? Mines a 2018 so a good 6 months out of the basic warranty window.
 
Advertisement

Freeland Jeep
 
Advertisement
Top