Weird uConnect/Radio issues/fix

bem1

Well-Known Member
First Name
Blake
Joined
Sep 6, 2018
Messages
199
Reaction score
315
Location
Texas
Website
lantanapcguy.com
Vehicle(s)
2018 JL
@JeepCares

So new Jeep JL owner here and have experienced the following items in the past month with my 8.4 inch radio. I'm sure others have the same problems, and wondering if/when they will get fixed.

Issue 1. No sound from Radio.
Fix: Click FM, AM, then it starts working.

Issue 2. Green screen when backing up.
Fix: Resolved on its own after coming out of Reverse, which cycled the camera off/on.

Issue 3. Radio/Controls completely useless with Radio/uconnect stuck on one station and volume. Mute button did not work, neither did anything else. The Screen Off button worked though.
Fix: After about 15 minutes, radio/uconnect went back to normal.

Issue 4. Sound volume very low. Turning up to the max of 30 was similar to around 15 when working. Sub had no sound. Bluetooth call was very low. Button click sounds were quite loud though.
Fix: Powered car off, went and had dinner. Came back in about 1 hour and it was back to normal.

-Blake





Advertisement

 

Gregodav

Well-Known Member
First Name
Dave
Joined
Dec 3, 2017
Messages
940
Reaction score
961
Location
Wichita, KS
Vehicle(s)
Rubicon 2014, Solstice 2007, 1993 GMC Pick-up
Occupation
I. T. Director and Video Director
Wow. This seems pretty simple and very major. It seems like you probably need a new infotainment unit.
It is actually an Android based device at it heart. It does not sound like faulty wiring or faulty connections to me.
Definitely time for a service appointment.
 

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,362
Reaction score
2,098
Location
Auburn Hills, MI
Vehicle(s)
JL
@JeepCares

So new Jeep JL owner here and have experienced the following items in the past month with my 8.4 inch radio. I'm sure others have the same problems, and wondering if/when they will get fixed.

Issue 1. No sound from Radio.
Fix: Click FM, AM, then it starts working.

Issue 2. Green screen when backing up.
Fix: Resolved on its own after coming out of Reverse, which cycled the camera off/on.

Issue 3. Radio/Controls completely useless with Radio/uconnect stuck on one station and volume. Mute button did not work, neither did anything else. The Screen Off button worked though.
Fix: After about 15 minutes, radio/uconnect went back to normal.

Issue 4. Sound volume very low. Turning up to the max of 30 was similar to around 15 when working. Sub had no sound. Bluetooth call was very low. Button click sounds were quite loud though.
Fix: Powered car off, went and had dinner. Came back in about 1 hour and it was back to normal.

-Blake
Hi Blake,
I'm very sorry that you have been experiencing all of these concerns with your brand new Jeep. Please let us know if any of these concerns continue to occur so we can have this looked into a bit further for you.
Lydia
Jeep Social Care Specialist
 

MacombRoger

Well-Known Member
First Name
Roger
Joined
Jan 29, 2018
Messages
483
Reaction score
559
Location
SE Michigan
Vehicle(s)
2018 JLUR Ocean Blue
Occupation
Solutions Architect
@JeepCares

Issue 1. No sound from Radio.
Fix: Click FM, AM, then it starts working.
I have had this issue twice so far. And that fix doesn't work for me. The 1st time, no audio from any audio producing source, tried turning on and off the Jeep a couple times, no luck. After an extended "Jeep Off period", came back, and the radio was back to normal.

The 2nd time just happened today. No matter how many key off/on cycles, no fix would work. Turned off radio, and would turn it on once in a while to see if it was working, after about 20 minutes, and 5 cycles of the the radio, it was back to working normally.

Do I think its a problem, hell yes. But how do you take it to the Dealership when its happened twice over 10k miles?
 

kculp

Well-Known Member
First Name
KEN
Joined
Mar 11, 2018
Messages
121
Reaction score
90
Location
Iowa
Vehicle(s)
2018 Sahara JLU
Occupation
Professor in the health sciences
Vehicle Showcase
1
I think it is just a loose video connector.... It will be checked by the service tech, don't worry.
 

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,362
Reaction score
2,098
Location
Auburn Hills, MI
Vehicle(s)
JL
I have had this issue twice so far. And that fix doesn't work for me. The 1st time, no audio from any audio producing source, tried turning on and off the Jeep a couple times, no luck. After an extended "Jeep Off period", came back, and the radio was back to normal.

The 2nd time just happened today. No matter how many key off/on cycles, no fix would work. Turned off radio, and would turn it on once in a while to see if it was working, after about 20 minutes, and 5 cycles of the the radio, it was back to working normally.

Do I think its a problem, hell yes. But how do you take it to the Dealership when its happened twice over 10k miles?
Hey Roger,

I understand your concerns with this, and intermittent issues are often tricky to duplicate at the dealer. If this continues to happen, please PM us so we can work with you and your dealer to ensure it's addressed.

Jennifer
Jeep Social Care Specialist
 

NathanG

Well-Known Member
First Name
Nathan
Joined
May 25, 2018
Messages
285
Reaction score
310
Location
Tucson AZ
Vehicle(s)
2018 JLU Rubicon
Vehicle Showcase
1
Check your fuses for being loose/ half seated in the engine compartment.
 

Smokie

Active Member
First Name
Steve
Joined
Sep 17, 2018
Messages
37
Reaction score
76
Location
Smoky Mountains, NC
Vehicle(s)
2018 JL Rubicon Mojito!
Occupation
Retired, part-time bartender
Thanks for posting!

My audio quit working this morning as well. I tried powering the radio on/off several times, along with leaving the Jeep rest for a few hours.

Came in and did a search on the forum, found this thread, went out and hit the FM then AM buttons and BOOM-BA! Sound returned!

Again, thanks for helping out. I just wish I knew what caused the problem in the first place??
 

Smokie

Active Member
First Name
Steve
Joined
Sep 17, 2018
Messages
37
Reaction score
76
Location
Smoky Mountains, NC
Vehicle(s)
2018 JL Rubicon Mojito!
Occupation
Retired, part-time bartender
Ok - went out and started the Jeep and had no audio again today. Hit the FM and AM buttons again and got my audio back.

What is causing this? Grrr
 

crgabel

Member
First Name
Craig
Joined
Nov 19, 2018
Messages
13
Reaction score
3
Location
York, Pa
Vehicle(s)
2019, Wrangler Sport S Unlimited
Mine is a week old and tonight the screen started to spaz out completely. It was like someone was pushing the buttons randomly and beeping like crazy I was at least 16" from it.

I tried hitting AM/FM to no avail. tried going into the climate but it kept changing to radio and bouncing around.

Going to the dealer tomorrow about the radio and 2 spots on the hood where dirt was painted over during the painting operation.

2019 JLU

Craig
 

MeepMeepJeep

Well-Known Member
First Name
Julia
Joined
May 18, 2018
Messages
103
Reaction score
89
Location
Kingston, MA
Vehicle(s)
2018 JLU, 2015 Wrangler
Has anyone had intermittent sound? My radio sound cuts in and out during any type of input, doesn't matter if I have the Iphone plugged in to the USB port, or I'm listening to AM/FM/XM, it's all the same. Some times there's no sound at all, then others it rhymically cuts in and out every 4 seconds or so. The electrical/software issues just never end in this Jeep!!! This is the fourth thing I've had happen, I'm going BACK to my dealer in a couple days. Tired of it. Plus, they said they have NO loaner. WHAT? The whole point of JeepCares and one of the reasons I bought a brand new JLU was that they offered service just like Infiniti-where they put you in a comparable loaner. I work two jobs. I don't have the patience for this-and why should I be paying for a rental?
 

orey22

Well-Known Member
Joined
May 26, 2016
Messages
164
Reaction score
318
Location
Midwest
Vehicle(s)
2012 JK Jeep Wrangler 2dr / 2019 JL 2dr
Has anyone had intermittent sound? My radio sound cuts in and out during any type of input, doesn't matter if I have the Iphone plugged in to the USB port, or I'm listening to AM/FM/XM, it's all the same. Some times there's no sound at all, then others it rhymically cuts in and out every 4 seconds or so. The electrical/software issues just never end in this Jeep!!! This is the fourth thing I've had happen, I'm going BACK to my dealer in a couple days. Tired of it. Plus, they said they have NO loaner. WHAT? The whole point of JeepCares and one of the reasons I bought a brand new JLU was that they offered service just like Infiniti-where they put you in a comparable loaner. I work two jobs. I don't have the patience for this-and why should I be paying for a rental?
You aren't alone, I'm in knee deep in the process of getting my 18 Wrangler fixed with Chrysler... once I get a remedy I'll let you know. It's been the biggest hassle I've ever had with a new car, and I've owned two wranglers previous to this current one.

Very sad Jeep appears to have released a Wrangler with inferior radios.
 

Joeymon1

Well-Known Member
First Name
Joe
Joined
Aug 17, 2018
Messages
149
Reaction score
91
Location
Southern Tier, NYS
Vehicle(s)
2019 Sahara
Mine is a week old and tonight the screen started to spaz out completely. It was like someone was pushing the buttons randomly and beeping like crazy I was at least 16" from it.

I tried hitting AM/FM to no avail. tried going into the climate but it kept changing to radio and bouncing around.

Going to the dealer tomorrow about the radio and 2 spots on the hood where dirt was painted over during the painting operation.

2019 JLU

Craig
Mine has done this twice so far. It happens about 2 hours after dash cluster crashes.
Were they able to determine the problem?
 

DrT

New Member
Joined
Feb 7, 2019
Messages
2
Reaction score
1
Location
Lebanon, MO
Vehicle(s)
2018 Jeep Wrangler Unlimited Rubicon
Has anyone had intermittent sound? My radio sound cuts in and out during any type of input, doesn't matter if I have the Iphone plugged in to the USB port, or I'm listening to AM/FM/XM, it's all the same. Some times there's no sound at all, then others it rhymically cuts in and out every 4 seconds or so. The electrical/software issues just never end in this Jeep!!! This is the fourth thing I've had happen, I'm going BACK to my dealer in a couple days. Tired of it. Plus, they said they have NO loaner. WHAT? The whole point of JeepCares and one of the reasons I bought a brand new JLU was that they offered service just like Infiniti-where they put you in a comparable loaner. I work two jobs. I don't have the patience for this-and why should I be paying for a rental?
You are not alone! My JL Rubicon just sat at the dealer for 2 weeks and they couldn't reproduce the intermittent audio pausing that my jeep is having. I just picked it up today and geewhiz there's the problem again, imagine that. I heard that the official line right now is to tell customers that if there is no error code, then there is no error. I researched this on YouTube from others that are having the same problem and they said their dealers didn't help them either. Dealers were replacing radios only to have the problem happen again. It is a software issue. My jeep didn't do this until the November update. Additionally, it seems to be only occurring cold weather. It also doesn't do it in accessory mode, engine off. I'm fed up. I'm trading mine off soon.
 

Advertisement




Northridge4x4
 



Advertisement
Top