Under 10K Miles - P0390 - PCM - Camshaft Position Sensor

ToPar9

Well-Known Member
Joined
Mar 16, 2020
Messages
289
Reaction score
112
Location
North Texas
Vehicle(s)
'19 JLU Altitude
9800'ish miles
Dropped off Friday, Most likely Tuesday before they can look at it.
Auto Start/Stop Service Required
Check Engine Light on/off/on/off
Cam Sensor Failure (code pulled by service dept)
Tons of steering wheel play
and when turning my radio down 2-3, it will continue to zero when let go. The same applies to turn it up a few, it will continue until you dial it back.
Looking over the dudes shoulder, there looked to be two other codes. (I'm calling Monday to find out the rest)
He didn't tell me, ushered me to the rental car lady to give me a loaner, and disappeared like a damn magician.
(and they gave me a Compass...)
Cam Sensor Failure? Who has had this luxurious fault pop on them?
I've read about a few that had a mess with this.

I felt bad for jumping into others thread, so I thought I would start my own disastrous pre-10k story.

@JeepCares, message sent your way.





Advertisement

 
OP
OP
ToPar9

ToPar9

Well-Known Member
Joined
Mar 16, 2020
Messages
289
Reaction score
112
Location
North Texas
Vehicle(s)
'19 JLU Altitude
Reached out to receive all codes that were pulled.
Hopefully I find something out soon.

Has anyone run into the Cam Sensor Failure with this resulting in something serious?
Thanks.
 
OP
OP
ToPar9

ToPar9

Well-Known Member
Joined
Mar 16, 2020
Messages
289
Reaction score
112
Location
North Texas
Vehicle(s)
'19 JLU Altitude
I also have a VERY noticeable vibration when idling.
 
OP
OP
ToPar9

ToPar9

Well-Known Member
Joined
Mar 16, 2020
Messages
289
Reaction score
112
Location
North Texas
Vehicle(s)
'19 JLU Altitude
P0390 - PCM - Camshaft Position Sensor
The search feature on this site came up with nothing.
Has anyone run into this code?
 

mwilk012

Well-Known Member
Joined
Mar 10, 2018
Messages
3,802
Reaction score
3,231
Location
Oklahoma
Vehicle(s)
2018 Ocean Blue JLU Rubicon
Is this your first bad cam sensor on any vehicle? It's super common, they'll run like crap and sometimes won't even start. However, your radio issues are hella weird.
 
OP
OP
ToPar9

ToPar9

Well-Known Member
Joined
Mar 16, 2020
Messages
289
Reaction score
112
Location
North Texas
Vehicle(s)
'19 JLU Altitude
Is this your first bad cam sensor on any vehicle? It's super common, they'll run like crap and sometimes won't even start. However, your radio issues are hella weird.
Yessir, first time I’ve ever had this code. They upgraded software for the radio. Hope that’s all that was needed.
 
OP
OP
ToPar9

ToPar9

Well-Known Member
Joined
Mar 16, 2020
Messages
289
Reaction score
112
Location
North Texas
Vehicle(s)
'19 JLU Altitude
That dirty little ESS is back again.
7-10 days out of it being “fixed”, and I’m cruising along and receive, Start Stop disabled, service required.
Guess we start checking Labor Day Sales Events.
 

mwilk012

Well-Known Member
Joined
Mar 10, 2018
Messages
3,802
Reaction score
3,231
Location
Oklahoma
Vehicle(s)
2018 Ocean Blue JLU Rubicon
Is the cam sensor code a circuit failure or performance code? They could be chasing rainbows here. May have timing issues.
 
OP
OP
ToPar9

ToPar9

Well-Known Member
Joined
Mar 16, 2020
Messages
289
Reaction score
112
Location
North Texas
Vehicle(s)
'19 JLU Altitude
Is the cam sensor code a circuit failure or performance code? They could be chasing rainbows here. May have timing issues.
I have no idea to be honest.
I only know the code that was pulled.
 

Kratos

Member
First Name
Wes
Joined
Dec 22, 2020
Messages
5
Reaction score
0
Location
jacksonvile, Florida
Vehicle(s)
2018 JLUR
I have no idea to be honest.
I only know the code that was pulled.
I realize this is an old thread, but I'm having the exact same issue; have the P0390 code for the camshaft position sensor as well as the service auto start/stop system. What was the fix for this? my dealer is at a loss on this issue.
 
OP
OP
ToPar9

ToPar9

Well-Known Member
Joined
Mar 16, 2020
Messages
289
Reaction score
112
Location
North Texas
Vehicle(s)
'19 JLU Altitude
I realize this is an old thread, but I'm having the exact same issue; have the P0390 code for the camshaft position sensor as well as the service auto start/stop system. What was the fix for this? my dealer is at a loss on this issue.
Honestly, I have no idea. I traded the Jeep in shortly after I posted this. Way too many issues with a brand new vehicle. Good Luck ... Hopefully someone here can help answer your question.
 

Advertisement




Clayton Offroad
 



Advertisement
Top