Uconnect screen issue

will1111

Well-Known Member
First Name
Will
Joined
Jan 6, 2018
Messages
413
Reaction score
270
Location
Los Angeles
Vehicle(s)
2018 JLUS
Hi guys,

I did a quick search but couldn't find the specific problem I was having.

Does anybody have problems with the 7" uconnect screen turning different color? I was running Waze at night and noticed little by little the map turned a shade of purple and the bottom onscreen buttons were also half black half purple. I changed to google play and the same issue was happening. Same in all the apps but Waze was the worse and it was progressive until sections weren't visible. I turned off the screen but it was still there when I turned it back on. I had lowered the brightness on the dial just the amount needed for the screen not to be super bright kind of in night mode if I may. When I have it full brightness I dont notice this issue.

My USB cable is only a couple months old if that and I only use it in the jeep. I'm also careful with it. I was thinking maybe uconnect was having problems keeping up with Waze and google play. Maybe my phone is at fault (Samsung S8+) but I never had that problem before.

This is the first time seeing this but I'll give it a shot at night today when I come to work again.
Advertisement

 

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,635
Reaction score
2,283
Location
Auburn Hills, MI
Vehicle(s)
JL
Hi guys,

I did a quick search but couldn't find the specific problem I was having.

Does anybody have problems with the 7" uconnect screen turning different color? I was running Waze at night and noticed little by little the map turned a shade of purple and the bottom onscreen buttons were also half black half purple. I changed to google play and the same issue was happening. Same in all the apps but Waze was the worse and it was progressive until sections weren't visible. I turned off the screen but it was still there when I turned it back on. I had lowered the brightness on the dial just the amount needed for the screen not to be super bright kind of in night mode if I may. When I have it full brightness I dont notice this issue.

My USB cable is only a couple months old if that and I only use it in the jeep. I'm also careful with it. I was thinking maybe uconnect was having problems keeping up with Waze and google play. Maybe my phone is at fault (Samsung S8+) but I never had that problem before.

This is the first time seeing this but I'll give it a shot at night today when I come to work again.
Hi will1111,

We're sorry to hear that you have this concern with your Uconnect screen. Have you brought this to the attention of your dealer? We would be happy to provide additional assistance while your vehicle is in service.

Darlene
Jeep Social Care Specialist
 

$uicide$hift

Well-Known Member
First Name
Jeff
Joined
Feb 21, 2018
Messages
1,593
Reaction score
2,639
Location
Masshole
Vehicle(s)
2018 Jeep Wrangler Unlimited Sahara
I know you said your USB cable is new but was it bought from the manufacturer of your phone? Sometimes these third party USB cables cause odd issues with phones of all makes. If this is a third party generic USB cable go buy one from your carrier and see if you still experience the issue.

I had different issues with a third party USB cable but after getting one from Verizon the issue went away and has not returned.
 
OP
OP

will1111

Well-Known Member
First Name
Will
Joined
Jan 6, 2018
Messages
413
Reaction score
270
Location
Los Angeles
Vehicle(s)
2018 JLUS
Hi will1111,

We're sorry to hear that you have this concern with your Uconnect screen. Have you brought this to the attention of your dealer? We would be happy to provide additional assistance while your vehicle is in service.

Darlene
Jeep Social Care Specialist
Hello,

I haven't yet...I will try different USB cables and see if that's the problem. Otherwise I will contact them
 
OP
OP

will1111

Well-Known Member
First Name
Will
Joined
Jan 6, 2018
Messages
413
Reaction score
270
Location
Los Angeles
Vehicle(s)
2018 JLUS
I know you said your USB cable is new but was it bought from the manufacturer of your phone? Sometimes these third party USB cables cause odd issues with phones of all makes. If this is a third party generic USB cable go buy one from your carrier and see if you still experience the issue.

I had different issues with a third party USB cable but after getting one from Verizon the issue went away and has not returned.
Yeah I was leaning towards the USB cable but I only buy from known quality brands...either oem or brands like Anker and belkin. Maybe it was damaged from use so I will buy an oem this week or use one of the new spare ones I have.

I know uconnect doesn't run the Waze app itself, (the android based auto afointment system isn't out yet I believe) it only relays the map to the screen but could also be the connections inside the uconnect need inspection.
 

NJWheeler

New Member
First Name
Thomas
Joined
May 29, 2018
Messages
4
Reaction score
0
Location
Hackettstown, NJ
Vehicle(s)
2018 JLU
My screen starts turning yellow while using Android Auto. If i switch to a screen that's not Android Auto then return the screen is fine again. I'm running a Pixel 2 with the factory USB C cable. Only does it for Android Auto screens.
 
Advertisement

WheelsASAP
 
Advertisement
Top