Uconnect® abolute POS!! Stay away from it...

gschones

Well-Known Member
First Name
Gary
Joined
Apr 15, 2018
Messages
54
Reaction score
26
Location
Oklahoma
Vehicle(s)
2018 Wrangler JL Unlimited
I had uconnect issues on my 2018. I took a video of it when it was malfunctioning. when I went to the dealer I sent the viseo to the service advisor. They replaced the unit and i had no further problems. You can also get Jeep Wave involved if you need to. My 2021 had the top of the line uconnect and no issues with it. I would say if you hate it that much then by all means replace it with something else to your liking if it is available. I have had uconnect in my last 4 jeeps and it works great.





Advertisement

 

me109stock

Well-Known Member
First Name
Martin
Joined
Sep 10, 2019
Messages
100
Reaction score
84
Location
Linden, CA
Vehicle(s)
2018 JLU Rubicon 6-Speed Manual; 2008 Ford F450; 2003 Porsche Boxster S
Vehicle Showcase
1
My 8.4" UConnect works properly about 90% of the time. Randomly when I start the vehicle and begin driving I will have no control over the unit. I used to pull over, shut off the engine, start back up and it would fix the problem. Sometimes I could put it in reverse at the first stop (.25 mile down the road) and that would trigger it to work. After getting tired of these quick fixes I stopped and found that after it runs through it's boot-up sequence it seems to self diagnose that it's F'ed up and it reboots on its own. Sometimes it needs two or three reboots before it operates properly. So, I've learned to just live with it. It has made me start to question if I would by a JL again or go with a low mileage JK when I'm done with this one (I put about 25k miles a year on it). The amount of electronics was one thing I was very hesitant about when I bout it in the first place.
Now on a side note (I don't think it's related to UConnect as much as Sirius XM is messed up)... I have a list of favorites in my system and the radio keeps flagging me that a favorite is playing, but when I go to browse my favorites it comes back empty saying no favorites are playing. This will happen even while I'm listening to a favorite. Sometimes I'll go to the list and it will show favorites, I'll select one and stay on the favorites page, and then all of a sudden they will all clear and it will say no favorites are currently playing. I already did the Sirius XM Reboot and Send a Signal think, but it didn't do anything. Sirius customer service was no service at all. Any fellow Jeepers experience this and have a solution?
 

midironman

Active Member
Joined
Dec 28, 2020
Messages
31
Reaction score
47
Location
SoCal
Vehicle(s)
2020 JT
Now on a side note (I don't think it's related to UConnect as much as Sirius XM is messed up)... I have a list of favorites in my system and the radio keeps flagging me that a favorite is playing, but when I go to browse my favorites it comes back empty saying no favorites are playing. This will happen even while I'm listening to a favorite. Sometimes I'll go to the list and it will show favorites, I'll select one and stay on the favorites page, and then all of a sudden they will all clear and it will say no favorites are currently playing. I already did the Sirius XM Reboot and Send a Signal think, but it didn't do anything. Sirius customer service was no service at all. Any fellow Jeepers experience this and have a solution?
Yep! There's a couple threads on this already. Uconnect says a major update in works scheduled for 1st quarter this year, but you'll have to go to the dealer to get it. :(
 

Thexr6

Member
First Name
Jason
Joined
Oct 4, 2019
Messages
19
Reaction score
15
Location
Mt
Vehicle(s)
2020 JL Rubicon, 2007 JK Rubicon
UConnect is recognized as one of the best systems, if not the best, in the industry for its user-friendly interface and connectivity.

I’ve had zero issues with Uconnect on my Chrysler vehicles for the past 10+ years. The system on my JL is the best to date.

Now, the Mazda infotainment system on my Fiat 124 Spider is a different story. That POS system won’t connect with anything in a 10-mile radius!
I concur -I have (or had )the best available Uconnect option on 4 jeeps in last 10 years. No issues. The 2007 and 2020 Rubicons which I still have - 0 problems.
 

Jinnjue

Well-Known Member
First Name
Jinn
Joined
Feb 7, 2019
Messages
78
Reaction score
99
Location
Indiana
Vehicle(s)
2018 Jeep Wrangler jl 2 door Mojito Green
Vehicle Showcase
1
This POS unit that came with my JL has been nothing but trouble and Uconnect doesn't give 2 bits about even trying to fix the issue. If I had to do it again, I would order my Jeep with the cheapest Uconnect unit and then just upgrade with an aftermarket several of which look pretty darn good!

So here is the story:

I have been having issues with my 8.4 Uconnect "Premium" stereo unit pretty much since day one. I have taken it to the dealer on many occasions and all they have done is to reset the unit or install a new software when it was available and pretty much all they arre telling me is that there is a new firrmware coming up in the first quarter of 2021 but it is not out yet and there is nothing else they can do.

Meanwhile, the unit randomly fails to recognize my phone, apps appear and disappear at random, the unit freezes and becomes non-responsive which forces me to remove the fuses and put it back to get the unit to respond... I have learned the reset procedure and have execute it countless times--I have stopped choosing any preferences since each time I have to reset the unit it loses all my choices and so there is no point is keep setting them... All is all, it is a POS.

So in a post I complained about how Uconnect is in fact a POS and @JeepCares responded and asked me if I wanted to start a case. I said sure--why not and they put me in touch with Uconnect to see what can be done about my complaints about the functionality of the unit in my Jeep. They even assisted me in getting a case number. So when I did not hear back from Uconnect, Jeepcares looked into it and I noticed that the email from Fredy went into my junk folder. I promptly "whitelisted" email from Connect so that this does not happen again. Fredy also said he had tried to call me... but I did not have an record of any calls. Puzzling but whatever...

I was able to talk to Fredy finally and he directed me to get the software information. I spoke with him on the phone and he sent me an email with directions on how to get that information. I followed the direction, got the software version information, took a screen shot with my phone and sent the screen shot along with an email containing the information requested. That was March 25, 2021.

Since then, I have been ghosted!

I have called and left Fredy several messages and I have sent email--all of which have gone unanswered.

Today, I finally decided to talk to a supervisor. So I call Uconnect and get a Customer (dis)Service on the phone and ask to speak with a supervisor. he first ignored me and tried to get me connected with Fredy--Fredy wasn't available. I then requested again to speak with a supervisor. I was told that he isn't going to let me speak with a supervisor because the only person from whom I can ask for a supervisor is Fredy and Fredy isn't available and isn't responding to me!!

So, looks like I will have to rip this Uconnect POS from my Jeep and go with either Insane Audio or another one... Sorry about the rant! But if I can prevent anyone to do the same mistake I did, I am happy! So F-ck Uconnect.

NOTE: I am using an apple cable. I have used nothing but Apple products to connect the phone. I connect it to the center console. I have used various Apple cables... In any event, the cable does not explain the other issues like disappearing/reappearing "off road pages", and other apps at random and radio freeze etc... :like:

NOTE 2: Folks have focused on CarPlay as the possible culprit. While, also my initial thought, the unit has frozen on me even without a phone attached. Last time it did that, none of the buttons worked, I was listening to XM and the radio kept on playing but none of the buttons for volume or changing the station worked. The unit was frozen. Even after I turned the vehicle on and off, the unit stayed frozen. I had to pull the fuse to get it back to working status. So it's not CarPlay! Good guess tho!
Funny that this topic would pop up? I have been experiencing the same issues with my 5 inch radio. Jeep cares has contacted me as well. I have taken it in for these updates and even got a radio replacement and STILL have the same issues. Thought it was just the 5 inch radio but I recently rented a 2020 Jeep Cherokee that had the 7 inch premium system. And that POS reset itself every 20/30 min for a 12 hr drive from Virginia to Indiana 🤬 So it was then that I realized that it’s NOT just my radio but the UCONNECT system. There is NO doubt that this issue will continue. It sucks to hear that I am NOT alone on this radio issue 😕😔
 

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,478
Reaction score
2,187
Location
Auburn Hills, MI
Vehicle(s)
JL
Hello everyone,

We're deeply sorry to hear about the experiences you've had with your Uconnect systems thus far. If anyone would like us to investigate their concerns or would like additional support while working with their dealers to get this addressed, please feel free to send us or our friends at @UconnectCares a private message! We'd be happy to help.

Thanks in advance,

Courtney
Jeep Cares
 

JGlanton

Member
Joined
Mar 11, 2021
Messages
18
Reaction score
14
Location
Orange County, CA
Vehicle(s)
Outback
Sounds like Jeep needs to replace the entire head unit in his JL.
I had a similar thing happen to my 2018 Subaru and it's top infotainment system, and a similar series of dealer attempts at resets and software updates and saying they tested it before it started hiccupping on the drive home from the dealer and I couldn't even call them while driving. On the 3rd visit they gave up and installed a new head unit. That fixed it.
 
OP
Onward4x4

Onward4x4

Well-Known Member
First Name
Nima
Joined
Sep 17, 2018
Messages
368
Reaction score
340
Location
Chicago, Illinois
Website
www.onward4x4.com
Vehicle(s)
2018 Jeep Wrangler JLU
Occupation
Traveler
Vehicle Showcase
1
  • Thread starter
  • Thread Starter
  • #98
Hello everyone,

We're deeply sorry to hear about the experiences you've had with your Uconnect systems thus far. If anyone would like us to investigate their concerns or would like additional support while working with their dealers to get this addressed, please feel free to send us or our friends at @UconnectCares a private message! We'd be happy to help.

Thanks in advance,

Courtney
Jeep Cares
Hi Courtney-

Thanks but I have already reached out to you guys and you reached out to @uconnectcares (not much) and I have a case number... but Uconnect isn't calling me or responding to my communication beyond the first conversation in which they asked for info about my radio--which I then provided. Since then, I have been ghosted! So thank you but at this point, I maintain that Uconnect is a POS both in terms of company and unreliable product they put in my Jeep.. 🤷‍♂️
 

Jsmeltz

Member
First Name
Joe
Joined
Mar 10, 2021
Messages
17
Reaction score
6
Location
Clinton, NJ
Vehicle(s)
Jeep
This POS unit that came with my JL has been nothing but trouble and Uconnect doesn't give 2 bits about even trying to fix the issue. If I had to do it again, I would order my Jeep with the cheapest Uconnect unit and then just upgrade with an aftermarket several of which look pretty darn good!

So here is the story:

I have been having issues with my 8.4 Uconnect "Premium" stereo unit pretty much since day one. I have taken it to the dealer on many occasions and all they have done is to reset the unit or install a new software when it was available and pretty much all they arre telling me is that there is a new firrmware coming up in the first quarter of 2021 but it is not out yet and there is nothing else they can do.

Meanwhile, the unit randomly fails to recognize my phone, apps appear and disappear at random, the unit freezes and becomes non-responsive which forces me to remove the fuses and put it back to get the unit to respond... I have learned the reset procedure and have execute it countless times--I have stopped choosing any preferences since each time I have to reset the unit it loses all my choices and so there is no point is keep setting them... All is all, it is a POS.

So in a post I complained about how Uconnect is in fact a POS and @JeepCares responded and asked me if I wanted to start a case. I said sure--why not and they put me in touch with Uconnect to see what can be done about my complaints about the functionality of the unit in my Jeep. They even assisted me in getting a case number. So when I did not hear back from Uconnect, Jeepcares looked into it and I noticed that the email from Fredy went into my junk folder. I promptly "whitelisted" email from Connect so that this does not happen again. Fredy also said he had tried to call me... but I did not have an record of any calls. Puzzling but whatever...

I was able to talk to Fredy finally and he directed me to get the software information. I spoke with him on the phone and he sent me an email with directions on how to get that information. I followed the direction, got the software version information, took a screen shot with my phone and sent the screen shot along with an email containing the information requested. That was March 25, 2021.

Since then, I have been ghosted!

I have called and left Fredy several messages and I have sent email--all of which have gone unanswered.

Today, I finally decided to talk to a supervisor. So I call Uconnect and get a Customer (dis)Service on the phone and ask to speak with a supervisor. he first ignored me and tried to get me connected with Fredy--Fredy wasn't available. I then requested again to speak with a supervisor. I was told that he isn't going to let me speak with a supervisor because the only person from whom I can ask for a supervisor is Fredy and Fredy isn't available and isn't responding to me!!

So, looks like I will have to rip this Uconnect POS from my Jeep and go with either Insane Audio or another one... Sorry about the rant! But if I can prevent anyone to do the same mistake I did, I am happy! So F-ck Uconnect.

NOTE: I am using an apple cable. I have used nothing but Apple products to connect the phone. I connect it to the center console. I have used various Apple cables... In any event, the cable does not explain the other issues like disappearing/reappearing "off road pages", and other apps at random and radio freeze etc... :like:

NOTE 2: Folks have focused on CarPlay as the possible culprit. While, also my initial thought, the unit has frozen on me even without a phone attached. Last time it did that, none of the buttons worked, I was listening to XM and the radio kept on playing but none of the buttons for volume or changing the station worked. The unit was frozen. Even after I turned the vehicle on and off, the unit stayed frozen. I had to pull the fuse to get it back to working status. So it's not CarPlay! Good guess tho!
I don't know how the lemon laws work by you, but in NJ, if the car has less than 20K miles on it and is less than a year old (Maybe even less than 3 years. I forgot after going through it in 2000), they have 3 chances to fix the problem. If they don't do it in 3, they must buy the vehicle back. Make sure you have documentation with recorded miles, date, and your complaint on each dealership invoice. If everything is in true order, go see a lawyer. Will cost $250 for the consultation, but if he decides you have a case, that money will be refunded to you.
 

Na Kalohe

Member
First Name
Michael
Joined
Jan 19, 2021
Messages
9
Reaction score
17
Location
Oahu, HI
Vehicle(s)
2021 Jeep Wrangler Unlimited JL Willys
Switch to Android. Android Auto works fine with no problems.
 

nanu

Member
First Name
Roger
Joined
May 5, 2019
Messages
13
Reaction score
0
Location
Nor Cal
Vehicle(s)
2019 Sting Grey Rubicon JLU, 1983 CJ7
Know how you feel. I’ve had my 8.4 replaced already by the dealer for non function of gps alt lg lat. The replacement has the same problem. POS. Checked with uconnect. I was told updates are out give it two or three weeks to get to my area?? If still have problem then take it back to the dealer. Thank god my airplane doesn’t have gps issues. Alt is pretty important. What are they using for programmers. Uconnect is not functional for prime time with hit and miss issues. If I still have the problem at the end of the month let’s see what the dealer says??
I am having same problem, my GPS/Nav has me in Colorado instead of Northern CA., tried all reboots etc. with no luck. Any more info on when updates are to arrive?
 

Gropax

Well-Known Member
First Name
Lee
Joined
Jan 31, 2019
Messages
195
Reaction score
106
Location
Pahrump, NV
Vehicle(s)
2018 Wrangler JLU Sport S Mojito Green
my radio came broken it worked but if anyone called you you couldn't hear them. all it took was the dealer replacing it and now mine works just fine 2 1/2 year later. just tell them to replace it no fireware just replace it. if you have been in that many times the jeep is now a Lemon and you can lemon law it all that law says is 3 repairs in less then a year that didn't fix the problem doesn't say only power train.
 

K-nuk

Well-Known Member
First Name
Scott
Joined
Jun 30, 2019
Messages
166
Reaction score
133
Location
Florida
Vehicle(s)
JLUR, CJ7
Hey @Onward4x4 I feel your pain. Really do. I’ve had my JLUR for 2 years and I’ve had similar issues since day 1...

I’ve changed phones (iPhone 8+, XS Max, 12 pro max)

Tried more than a dozen cables (OEM and aftermarket)

Ensured my phone and iOS are on the UConnect “compatible” list

Check my fuses, ...etc... Still have the intermittent radio freeze.

Ive had my UConnect case open for 2 years with “Deidre”. She’s done saying “you’ll have to wait for OTA software update”. What a HUGE waste of time.

My Jeep has now been at the dealership for 5 weeks. So far they’ve replaced the head unit, media hub, and they still experience crashes and freezes. They’ve got STAR technicians involved and they are replacing the head unit AGAIN!

Oh, btw, my Buddy has JLUR with the 8.4 as well and my phone and cable work FLAWLESSLY in his Jeep.

I will go to arbitration and if needed follow the lemon law process to resolve this.

I understand there can be production quality issues but it has taken me 2 years of documentation and multiple visits to get the dealer to finally have Chrysler take this seriously. That is indicative of poor customer service.
 

RFR JLR 2.0

Well-Known Member
First Name
Rudy
Joined
Feb 29, 2020
Messages
113
Reaction score
283
Location
Simi Valley, CA
Vehicle(s)
2019 Jeep JLU Rubicon 3.6L
Occupation
Geologist
I also have the 8.4 and it worked fine for about 18 months. Then the navigation system stopped working and had no idea where I was. Little Jeep just floating around in space. Brought it to the dealer and they said were going to upgrade the firmware. Halfway through the install the unit crashed. They said the only fix was to replace the entire unit. Took about 4 weeks to get the part. Installed last week and so far works fine.
 
OP
Onward4x4

Onward4x4

Well-Known Member
First Name
Nima
Joined
Sep 17, 2018
Messages
368
Reaction score
340
Location
Chicago, Illinois
Website
www.onward4x4.com
Vehicle(s)
2018 Jeep Wrangler JLU
Occupation
Traveler
Vehicle Showcase
1
  • Thread starter
  • Thread Starter
  • #105
Hey @Onward4x4 I feel your pain. Really do. I’ve had my JLUR for 2 years and I’ve had similar issues since day 1...

I’ve changed phones (iPhone 8+, XS Max, 12 pro max)

Tried more than a dozen cables (OEM and aftermarket)

Ensured my phone and iOS are on the UConnect “compatible” list

Check my fuses, ...etc... Still have the intermittent radio freeze.

Ive had my UConnect case open for 2 years with “Deidre”. She’s done saying “you’ll have to wait for OTA software update”. What a HUGE waste of time.

My Jeep has now been at the dealership for 5 weeks. So far they’ve replaced the head unit, media hub, and they still experience crashes and freezes. They’ve got STAR technicians involved and they are replacing the head unit AGAIN!

Oh, btw, my Buddy has JLUR with the 8.4 as well and my phone and cable work FLAWLESSLY in his Jeep.

I will go to arbitration and if needed follow the lemon law process to resolve this.

I understand there can be production quality issues but it has taken me 2 years of documentation and multiple visits to get the dealer to finally have Chrysler take this seriously. That is indicative of poor customer service.
Holy crap. Your story is the worst I have yet heard! Damn...
 

Advertisement




Stinger Off-Road
 



Advertisement
Top