Uconnect® abolute POS!! Stay away from it...

aldo98229

Well-Known Member
First Name
Aldo
Joined
Nov 16, 2019
Messages
5,521
Reaction score
12,064
Location
Bellingham, WA
Vehicle(s)
2018 Jeep Wrangler Unlimited Sahara, 2018 Fiat 124 Spider Abarth
Occupation
Market Research
Vehicle Showcase
2
I find that Bluetooth in 100% of all the vehicles I had diminishes the sound quality. It's like listening to music through a vacuum tube.
That’s still a lot better sound than Sirius XM!
Advertisement

 

McGilli

Well-Known Member
Joined
Sep 16, 2020
Messages
395
Reaction score
667
Location
Richmond BC Canada
Vehicle(s)
2020 Sahara Unlimited Altitude
Is anyone else a little surprised that Jeep is making the OP contact Uconnect directly?
I am waiting for U-Connect to tell him to contact Alpine...
 
OP
OP
Onward4x4

Onward4x4

Well-Known Member
First Name
Nima
Joined
Sep 17, 2018
Messages
370
Reaction score
352
Location
Chicago, Illinois
Website
www.onward4x4.com
Vehicle(s)
2018 Jeep Wrangler JLU
Occupation
Traveler
Vehicle Showcase
1
Is anyone else a little surprised that Jeep is making the OP contact Uconnect directly? He shouldn't have to, its an issue with an item inside the Jeep. That's nonsense on Jeeps part.

I know this because of Subaru and its terrible head unit issues from 2017-2020. Lots of them dying, acting terrible, etc. In no way did Subaru ever direct customers to the head unit manufacturer in any of the problems I read on the Subaru forums.

If I was the OP I would deal with Jeep directly and have them deal with it. As others have said ,keep logging problems and bringing it to them. They should really just replace the whole unit you would think. Its a PITA for the OP to keep having to go to a dealer, but hopefully once its solved you can enjoy your vehicle more.
Well, at the moment Uconnect isn't dealing with it either!!! Looks like I have to keep going to the dealer--but each time it is time and effort consuming. I'll keep trying...
 

WilhelmSR

Well-Known Member
First Name
Wilhelm
Joined
Nov 12, 2020
Messages
427
Reaction score
871
Location
Maryland
Vehicle(s)
2021 HellaYella JLUR
UConnect is recognized as one of the best systems, if not the best, in the industry for its user-friendly interface and connectivity.

I’ve had zero issues with Uconnect on my Chrysler vehicles for the past 10+ years. The system on my JL is the best to date.

Now, the Mazda infotainment system on my Fiat 124 Spider is a different story. That POS system won’t connect with anything in a 10-mile radius!
Same here, had it in my JK for 7 years and never had an issue and have it now in my JL (8.4) and no issues.
 

WilhelmSR

Well-Known Member
First Name
Wilhelm
Joined
Nov 12, 2020
Messages
427
Reaction score
871
Location
Maryland
Vehicle(s)
2021 HellaYella JLUR

BadWolf

Well-Known Member
First Name
John
Joined
Jul 21, 2020
Messages
68
Reaction score
64
Location
Northwest Arkansas
Vehicle(s)
2021 Jeep Wrangler Unlimited Rubicon (Sarge Green)
The only thing I miss from my F150 that I traded in on Jeep is the Sync 3 system. I miss having the navigation, media, and phone all on one screen at the same time. I also have about 2500 songs on mini flash drive that I would use in the truck with voice commands without a single problem. But in the Jeep it only recognizes 1312 songs and when I say "play song long black train" (or a bunch of other song titles I know are on the flash drive), it replies something like "POI not found"!
 

roaniecowpony

Well-Known Member
Joined
Dec 4, 2018
Messages
2,267
Reaction score
2,451
Location
90505
Vehicle(s)
2018 JLUR, 14 GMC 1500 CC All TERRAIN
Occupation
Retired Engineer
I'm sorry you're having so much trouble.

It seems we are buying as much a computer these days as we are buying transportation. I have mixed feelings about it. As vehicle life expectancy has increased, electronic entertainment systems have become more feature oriented and more integrated, and I would speculate that new car buyers are spending more on them as a group. Meanwhile, electronics are evolving as fast as ever and seem to have short lifespans.

We end up with an electronic entertainment system built by companies that have expertise in vehicles, but are always one or two steps behind the personal electronic industry, sometimes much further behind. Then we are expected to be satisfied with the capabilities for the life of the vehicle. The second highest capital purchase for most people has outdated electronics before it leaves the lot, then the owner is expected to live with it for the entire ownership life of the vehicle. It's backward thinking on at least a couple levels.

Vehicles need to be more "integrateable" with personal electronics. Critical vehicle systems can be isolated from entertainment and navigation.
 

OldGuyNewJeep

Well-Known Member
Joined
Sep 21, 2017
Messages
3,177
Reaction score
5,230
Location
CT
Vehicle(s)
2018 Wrangler JL, 2016 Yukon XL
The commonality between all the trouble is that they all go away once the vehicle sits overnight
Do you use a battery tender? Still on stock batteries? Shot in the dark, but when my (craptastic) stock batteries started to fail I saw lots of weird things happen.

Also, do you have a good cellular/gps connection? I’ve observed that when UConnect does a cold start it phones home... during that period I get unlabeled, generic app icons. After a few seconds they load. Sometime ORP takes a minute or two to appear.

Did your unit update itself last month? Mine did, which fixed Sirius/XM favorites from not working. Since they worked fine for two years, I attribute that regression to a change on the Sirius side for which UConnect had to make a fix. My UConnect update happened to coincide with replacing my main battery and bypassing my AUX... all I know is that it’s been rock solid.

Food for thought... check those batteries. They are cheap crap. AUX/ESS design is the worst. I put a tender on my batteries once a week.
 
OP
OP
Onward4x4

Onward4x4

Well-Known Member
First Name
Nima
Joined
Sep 17, 2018
Messages
370
Reaction score
352
Location
Chicago, Illinois
Website
www.onward4x4.com
Vehicle(s)
2018 Jeep Wrangler JLU
Occupation
Traveler
Vehicle Showcase
1
Do you use a battery tender? Still on stock batteries? Shot in the dark, but when my (craptastic) stock batteries started to fail I saw lots of weird things happen.

Also, do you have a good cellular/gps connection? I’ve observed that when UConnect does a cold start it phones home... during that period I get unlabeled, generic app icons. After a few seconds they load. Sometime ORP takes a minute or two to appear.

Did your unit update itself last month? Mine did, which fixed Sirius/XM favorites from not working. Since they worked fun for two years, I attribute that regression to a change on the Sirius side for which UConnect had to make a fix. My update happened to coincide with replacing my main battery and bypassing my AUX... all I know is that it’s been rock solid.

Food for thought... check those batteries. They are cheap crap. AUX/ESS design is the worst. I put a tender on my batteries once a week.
I use a dual system battery from Genesis running brand new AGM batteries. My issues pre-date and post date the conversion so, I have eliminated the dual battery as a source of an issue.

I generally have a good cell connection and generally I have not experienced apps not loading at the beginning. Troubles come generally at random times while using the radio-freezes or if I stop and stop the engine and go to a store and come back and then bam... chaos!!

I have reached the conclusion that my unit is faulty and so that's that. Obviouusly @JeepCares isn't going to do anything about it nor will evidently Uconnect...
 

Tyler88

Member
First Name
Tyler
Joined
Dec 16, 2020
Messages
9
Reaction score
7
Location
33406
Vehicle(s)
2018 Jeep Wrangler Unlimited Sahara
This POS unit that came with my JL has been nothing but trouble and Uconnect doesn't give 2 bits about even trying to fix the issue. If I had to do it again, I would order my Jeep with the cheapest Uconnect unit and then just upgrade with an aftermarket several of which look pretty darn good!

So here is the story:

I have been having issues with my 8.4 Uconnect "Premium" stereo unit pretty much since day one. I have taken it to the dealer on many occasions and all they have done is to reset the unit or install a new software when it was available and pretty much all they arre telling me is that there is a new firrmware coming up in the first quarter of 2021 but it is not out yet and there is nothing else they can do.

Meanwhile, the unit randomly fails to recognize my phone, apps appear and disappear at random, the unit freezes and becomes non-responsive which forces me to remove the fuses and put it back to get the unit to respond... I have learned the reset procedure and have execute it countless times--I have stopped choosing any preferences since each time I have to reset the unit it loses all my choices and so there is no point is keep setting them... All is all, it is a POS.

So in a post I complained about how Uconnect is in fact a POS and @JeepCares responded and asked me if I wanted to start a case. I said sure--why not and they put me in touch with Uconnect to see what can be done about my complaints about the functionality of the unit in my Jeep. They even assisted me in getting a case number. So when I did not hear back from Uconnect, Jeepcares looked into it and I noticed that the email from Fredy went into my junk folder. I promptly "whitelisted" email from Connect so that this does not happen again. Fredy also said he had tried to call me... but I did not have an record of any calls. Puzzling but whatever...

I was able to talk to Fredy finally and he directed me to get the software information. I spoke with him on the phone and he sent me an email with directions on how to get that information. I followed the direction, got the software version information, took a screen shot with my phone and sent the screen shot along with an email containing the information requested. That was March 25, 2021.

Since then, I have been ghosted!

I have called and left Fredy several messages and I have sent email--all of which have gone unanswered.

Today, I finally decided to talk to a supervisor. So I call Uconnect and get a Customer (dis)Service on the phone and ask to speak with a supervisor. he first ignored me and tried to get me connected with Fredy--Fredy wasn't available. I then requested again to speak with a supervisor. I was told that he isn't going to let me speak with a supervisor because the only person from whom I can ask for a supervisor is Fredy and Fredy isn't available and isn't responding to me!!

So, looks like I will have to rip this Uconnect POS from my Jeep and go with either Insane Audio or another one... Sorry about the rant! But if I can prevent anyone to do the same mistake I did, I am happy! So F-ck Uconnect.

NOTE: I am using an apple cable. I have used nothing but Apple products to connect the phone. I connect it to the center console. I have used various Apple cables... In any event, the cable does not explain the other issues like disappearing/reappearing "off road pages", and other apps at random and radio freeze etc... :like:
I got the 8.4 with the premium stereo but my Jeep is a 2018 JL I only have the issue of it not wanting to connect to my phone but it usually comes and goes so I couldn’t really show it to a dealer because it would work fine when I would try so I just live with it.
 

TravisRogers

Well-Known Member
First Name
Dan
Joined
Jun 19, 2018
Messages
209
Reaction score
363
Location
Annapolis, MD
Vehicle(s)
2018 Jeep Wrangler JL Sahara
Are you talking about Uconnect or Apple CarPlay? Because CarPlay lives on your device. I’d bet $500 that the issue is with your phone. My phone and my kids’ phones connect flawlessly almost every single time. My wife’s phone takes three tries to connect most times in both cars.
 

rickinAZ

Well-Known Member
First Name
Rick
Joined
Jan 2, 2020
Messages
1,904
Reaction score
1,996
Location
Phoenix
Vehicle(s)
2021 Rubicon Diesel
Occupation
Retired CFO. Mayo Clinic volunteer.
This is the kind of thread that potential Jeep buyers read and conclude that all Jeeps have UConnect problems. Even though the responses have been largely "mine works great", people tend to gravitate to the negative. I've already seen it over and over again regarding the EcoDiesel. Not to downplay the OP's situation. To him it's all too real.

OP: I hope that you ultimately get good customer care.
 
OP
OP
Onward4x4

Onward4x4

Well-Known Member
First Name
Nima
Joined
Sep 17, 2018
Messages
370
Reaction score
352
Location
Chicago, Illinois
Website
www.onward4x4.com
Vehicle(s)
2018 Jeep Wrangler JLU
Occupation
Traveler
Vehicle Showcase
1
Are you talking about Uconnect or Apple CarPlay? Because CarPlay lives on your device. I’d bet $500 that the issue is with your phone. My phone and my kids’ phones connect flawlessly almost every single time. My wife’s phone takes three tries to connect most times in both cars.
Ok I have you down for $500
Where do I collect?

It's not the phone. Off Road Pages disappearing can't have anything to do with CarPlay.
Backup camera not showing up when I go in reverse, has nothing to do with CarPlay.
Screen freezing even without a phone attached to the unit and none of the buttons working and unit remaining frozen even if I turn the vehicle off and then on... leaving me to have to remove the fuse to get the damn thing to reset has nothing to do with CarPlay.
Etc... etc...

So where do I collect? :rock:

I have used 3 different iphone thorugh the course of my ownbnership of this POS unit. The issue has persisted throughout. I have used both Apple and non-Apple cables. I have used USB and USB-C connections on various ports.... etc... etc...

I do take Zelle!!! lol
 
OP
OP
Onward4x4

Onward4x4

Well-Known Member
First Name
Nima
Joined
Sep 17, 2018
Messages
370
Reaction score
352
Location
Chicago, Illinois
Website
www.onward4x4.com
Vehicle(s)
2018 Jeep Wrangler JLU
Occupation
Traveler
Vehicle Showcase
1
A bad cable could cause these issues, your phone and the Uconnect need to communicate back and forth, if that communication is garbled all kinds of bad stuff can happen. Get a brand new Apple cable and give it a try. Could be a simple easy fix. This fixed my issues.

If that does not work, try deleting the carplay app on your phone and reinstall it.

If that doesn't work, test with a different phone.

ok
 
Advertisement

D&C Designs
 
Advertisement
Top