THE FIX FOR LOCKERS: Blinking lights, service axle locker system, lockers wont engage/disengage

MojitoJLUR

Well-Known Member
Joined
Jan 11, 2018
Messages
1,417
Reaction score
1,693
Location
Detroit, MI
Vehicle(s)
2018 JLUR Mojito
Hey @MojitoJLUR did you buy one or two harnesses?

I posted earlier in this thread how I narrowed down it was my front locker… so I only needed one.

Also that code you posted relates to losing contact to security gateway… id check your connection to taser and clear that cel.
I did basically the same. When I use my tazer to say rear lockers only, the issue is still there. So I'm hoping it's only the rear since there is no way to check the front only. I only bought one harness for now, put the harness on, and kept it at rear only, and still had the message.

I have had other electrical wiring issues where it threw codes, such as start stop not available where the dealer said it's a bad connection/loose wire. I'm hoping maybe that is it again, will be taking it to the dealer sooner or later.
Advertisement

 
  • Like
Reactions: TJP

eric.frederich

Well-Known Member
First Name
Eric
Joined
Oct 16, 2017
Messages
100
Reaction score
35
Location
Charlotte, NC
Vehicle(s)
2018 JLURubicon
Please help. Our light has come on for the rear locker 3 times now in the past 2 months. Because they're unable to reproduce the problem at the dealership they can't point to a faulty part. Without a faulty part they can't order anything under warranty.

Those of you that have had parts replaced (sensors, actuators, axles, etc)... was it done under warranty? How bad was your problem... constant or intermittent?

I've shown them video of it driving on the highway in 2High and dashboard showing that the rear is locked. I've also opened a case with Jeep Customer Care.
After speaking w/ Customer Care and the dealership, it's clear that even if I were to bring it in during the intermittent problem for a technician to witness it... when the problem goes away after 30 minutes or an hour they wouldn't be able to pinpoint the faulty part.
Jeep Customer Care says they can't just start replacing parts until it works... That blows my mind. That's literally how service works for every industry. When my dryer stopped working I replaced the fuse. When the fuse blew again I started replacing parts until it worked again. I started with the thermostat, fortunately that fixed it... but had it not, I would have moved on to the heating element.
There are only so many things in the chain that can make that light appear on my dash. I'm not asking them to replace my air conditioner, or my power windows. Why can't they start replacing stuff until it works?

How did you call get Jeep to lift a finger for you?
Should I go to another dealership?

I'm currently with Stateline Jeep in Fort Mill, SC.

Thanks,
~Eric
 
  • Like
Reactions: TJP

No Spark V6

Well-Known Member
Joined
Aug 1, 2020
Messages
122
Reaction score
132
Location
Chicago NW burbs
Vehicle(s)
2021 Rubi 3.0 GCM
That's literally how service works for every industry.
I'd have to disagree with you on this part. I dont think that's how it works(at least not in my industry) or how it should work. Definately don't want a doctor to take that approach on me. Diagnosing before throwing parts at it is a better solution.

That said, the axle locker has been a very common issue and I'm surprised it hasn't been solved yet. I would think they would have at the minimum, a procedure to test the sensor by now. You could always try to get them to pop the diff cover and check for oil in the sensor. Hopefully they're intelligent enough to know it shouldn't be there and then replace it under warranty.
 

TJP

Well-Known Member
Joined
Mar 30, 2020
Messages
138
Reaction score
109
Location
PA USA
Vehicle(s)
20 JLU Rubicon
Vehicle Showcase
1
Eric, One “fix” could be for you to install the zauto oem locker bypass. It removes the error, keeps lockers operational, but will cost you $170. I had to add one to my front at 6000 miles but havent had an issue since.

I know it sucks, but if that addresses it for you then so be it. Id go that way over an axle replacement (w a refurb). Heck I wouldnt even want the dealer replacing an axle.

Eventually the oem part will be sold separately (hopefully potted or redesigned).




Please help. Our light has come on for the rear locker 3 times now in the past 2 months. Because they're unable to reproduce the problem at the dealership they can't point to a faulty part. Without a faulty part they can't order anything under warranty.

Those of you that have had parts replaced (sensors, actuators, axles, etc)... was it done under warranty? How bad was your problem... constant or intermittent?

I've shown them video of it driving on the highway in 2High and dashboard showing that the rear is locked. I've also opened a case with Jeep Customer Care.
After speaking w/ Customer Care and the dealership, it's clear that even if I were to bring it in during the intermittent problem for a technician to witness it... when the problem goes away after 30 minutes or an hour they wouldn't be able to pinpoint the faulty part.
Jeep Customer Care says they can't just start replacing parts until it works... That blows my mind. That's literally how service works for every industry. When my dryer stopped working I replaced the fuse. When the fuse blew again I started replacing parts until it worked again. I started with the thermostat, fortunately that fixed it... but had it not, I would have moved on to the heating element.
There are only so many things in the chain that can make that light appear on my dash. I'm not asking them to replace my air conditioner, or my power windows. Why can't they start replacing stuff until it works?

How did you call get Jeep to lift a finger for you?
Should I go to another dealership?

I'm currently with Stateline Jeep in Fort Mill, SC.

Thanks,
~Eric
 

Mud2Sno

Well-Known Member
First Name
Mickey
Joined
Jan 4, 2018
Messages
163
Reaction score
246
Location
California
Vehicle(s)
2018 JLUR Rubicon
Mine was constant but I did film it when it happened and they did cover under warranty but took 3 month of them trying different parts, z-locker fix didnt work for me. ended up being harness but did get new axles front and rear and controller. I did the potting fix once I got my jeep back and have not had this happen again.
 
  • Like
Reactions: TJP

norm807

Active Member
First Name
Brent
Joined
Mar 26, 2018
Messages
42
Reaction score
40
Location
Iowa
Vehicle(s)
2018 JL Punk'n Rubi
I have this issue and just wanted to drop a comment in here for those looking for some warranty info I really couldn't find. I searched and couldn't find anyone that confirmed if this issue is covered under the power train warranty. I could only find people saying it was under warranty, but not which warranty. I was 2 weeks outside the 3yr warranty at only at 22k miles when it showed up. I was concerned if the power train warranty covered the issue as I was searching, I only found one reference and that person said the sensor wasn't covered. I just got my jeep back from the dealer after they diagnosed the issue and put a new axle on order (backorder until end of August) and covered under the Power Train warranty. I am going to order the z-locker cable for backup once the new axle is installed.
 
  • Like
Reactions: TJP

MojitoJLUR

Well-Known Member
Joined
Jan 11, 2018
Messages
1,417
Reaction score
1,693
Location
Detroit, MI
Vehicle(s)
2018 JLUR Mojito
I did basically the same. When I use my tazer to say rear lockers only, the issue is still there. So I'm hoping it's only the rear since there is no way to check the front only. I only bought one harness for now, put the harness on, and kept it at rear only, and still had the message.

I have had other electrical wiring issues where it threw codes, such as start stop not available where the dealer said it's a bad connection/loose wire. I'm hoping maybe that is it again, will be taking it to the dealer sooner or later.
Just a FYI in case anyone else runs across this....

I was about to take my jeep into the dealer because I thought the tazer harness didn't work for me. I put my tazer into rear only for lockers and still had the error so I was convinced it was the rear. Well, I thought for shits and giggles, I'd try to put it on the front before taking it in. It worked! So having the jeep think it only has a rear locker with the tazer does NOT remove the service 4wd message if it's the front still.
 
Advertisement

Jim Marsh Chrysler Jeep
 
Advertisement
Top