Stuck in park/service shifter

foxess

Member
Joined
Jul 7, 2020
Messages
14
Reaction score
13
Location
usa
Vehicle(s)
2020 wrangler sport 2 dr
Hey guys, i need help. My 3 month old wrangler is having weird issues. 4 days ago i got in it to go for an oil change, and when i started it up it wouldn't shift out of park. The shifter wouldn't move, the check engine light came on, the red lightning bolt in parentheses light came on, and it said service shifter on the combi meter info screen. I shut it off, restarted, same thing. I repeated two more times and it started and was able to be shifted. The check engine light stayed on.

Conveniently, i was on my way to the dealership for an oil change so i told them. They messed around with it for a while, said it was showing some codes, they couldn't seem to pinpoint the issue and gave it back to me basically saying it may or may not do it again.

This morning at 5 am as i was leaving my workplace, i started it and it did the same thing. I turned it off and restarted 14x before the "P" lit up on my shifter and blinked and it magically decided to work again, allowing me to shift into drive and go home.

The dealership is getting an earful later today when they open, and i have a feeling they won't solve anything since they didnt the other day either. Have any of you had this problem?
Advertisement

 

chevymitchell

Well-Known Member
First Name
Shawn
Joined
Feb 18, 2018
Messages
2,150
Reaction score
4,373
Location
K-Vegas, NC
Vehicle(s)
2019 JLUR (Pain Train), 2021 Charger Redeye
Occupation
Super Nerd
Hey guys, i need help. My 3 month old wrangler is having weird issues. 4 days ago i got in it to go for an oil change, and when i started it up it wouldn't shift out of park. The shifter wouldn't move, the check engine light came on, the red lightning bolt in parentheses light came on, and it said service shifter on the combi meter info screen. I shut it off, restarted, same thing. I repeated two more times and it started and was able to be shifted. The check engine light stayed on.

Conveniently, i was on my way to the dealership for an oil change so i told them. They messed around with it for a while, said it was showing some codes, they couldn't seem to pinpoint the issue and gave it back to me basically saying it may or may not do it again.

This morning at 5 am as i was leaving my workplace, i started it and it did the same thing. I turned it off and restarted 14x before the "P" lit up on my shifter and blinked and it magically decided to work again, allowing me to shift into drive and go home.

The dealership is getting an earful later today when they open, and i have a feeling they won't solve anything since they didnt the other day either. Have any of you had this problem?
This sounds like a pushed pin or something like that. Hopefully they track it down quick for you.

In case you should need to get it towed, you'll need this info:

 

5foot19

Well-Known Member
Joined
Sep 29, 2020
Messages
88
Reaction score
114
Location
Canada
Vehicle(s)
2020 JLUR
This sounds like a pushed pin or something like that. Hopefully they track it down quick for you.

In case you should need to get it towed, you'll need this info:

Why not just pop the transfer case in neutral? I feel like that would have less rolling resistance if you were manually pushing it, or towing it any distance.
 

Tellurian

Well-Known Member
First Name
Matt
Joined
Feb 2, 2020
Messages
195
Reaction score
522
Location
Vermont
Vehicle(s)
‘20 Wrangler JLUR Ocean Blue (MT); ‘20 Grand Cherokee White; ‘12 Volvo C30 (MT)
Occupation
Analyst

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,638
Reaction score
2,292
Location
Auburn Hills, MI
Vehicle(s)
JL
Hey guys, i need help. My 3 month old wrangler is having weird issues. 4 days ago i got in it to go for an oil change, and when i started it up it wouldn't shift out of park. The shifter wouldn't move, the check engine light came on, the red lightning bolt in parentheses light came on, and it said service shifter on the combi meter info screen. I shut it off, restarted, same thing. I repeated two more times and it started and was able to be shifted. The check engine light stayed on.

Conveniently, i was on my way to the dealership for an oil change so i told them. They messed around with it for a while, said it was showing some codes, they couldn't seem to pinpoint the issue and gave it back to me basically saying it may or may not do it again.

This morning at 5 am as i was leaving my workplace, i started it and it did the same thing. I turned it off and restarted 14x before the "P" lit up on my shifter and blinked and it magically decided to work again, allowing me to shift into drive and go home.

The dealership is getting an earful later today when they open, and i have a feeling they won't solve anything since they didnt the other day either. Have any of you had this problem?
Hi foxess,

We're sorry to hear about the concerns you're having with your Jeep Wrangler and are glad that you're currently working with a dealer to address this. If you'd like us to help further assist, please feel free to send us a private message with your VIN, current mileage, and dealer of choice. We'd be more than happy to help!

Thanks,

Jeep Cares
 
OP
OP
foxess

foxess

Member
Joined
Jul 7, 2020
Messages
14
Reaction score
13
Location
usa
Vehicle(s)
2020 wrangler sport 2 dr
This has come up a couple times and seems to be related to an incorrectly plugged connector in the bezel under the shifter. Have the dealership start there to see if everything is properly plugged in place.

https://www.jlwranglerforums.com/forum/threads/service-shifter-warning.19793/
Thank you all. They kept it a few days and tried to figure it out. They thought the radio system was maybe the culprit, as it stopped working when this shifter thing happened (just momentarily) they replaced it, and told my husband if it did it again it had to be the rf sensor. We looked it up and that seems to be tire related so i really don't know how that would relate. Ugh. I am so aggravated as it wouldn't shift again this morning as i was leaving work. Let it run 5 minutes and the problem stops, the parking "P" lights up and it magically works. **The ONLY clues we have are that this only seems to happen on very cold days, only at start up, and it goes away as soon as it gets warm. Definitely cold temp related then.** we are calling the dealer back today. I will relay the bezel under the shifter idea. Thank you all for your replies, I'll report back.
 
OP
OP
foxess

foxess

Member
Joined
Jul 7, 2020
Messages
14
Reaction score
13
Location
usa
Vehicle(s)
2020 wrangler sport 2 dr
It's back at the dealership. The day after my last post it did it again. I dropped it off on Thursday night, and it's next Thursday now. Ugh. The radio obviously wasn't the issue. The went through the wire harnesses and checked pins, among other things, some of which i read here in other threads. It sounds like they may replace the shift control module. They drove it briefly the other day and it didnt shift when they stopped to turn around, this was a new thing as it hadn't happened that way for me. They are working with someone from jeep, i hope they figure it out soon. I miss my jeep.
 
OP
OP
foxess

foxess

Member
Joined
Jul 7, 2020
Messages
14
Reaction score
13
Location
usa
Vehicle(s)
2020 wrangler sport 2 dr
I got my jeep back last week on Wed Dec 2. They were very confident that it was an unseated fuse. Fuse 25 to be specific. This was after nearly 3 weeks of them troubleshooting with Chrysler calling the shots. All was well until that following Saturday, the 5th. Even after being warmed up and it was not even cold that day, it would not shift out of park AGAIN. I was stranded at a gas station. After about 35 min it kicked in and I went home. It did it again later on at home, and tonight before I went to work. I called the dealership Sat and let them know it was an issue once again and I am going to take it in tomorrow for the 4th time. Ugh.
 

captainstabbins

Well-Known Member
Joined
Jun 10, 2019
Messages
238
Reaction score
341
Location
Doylestown
Vehicle(s)
2018 JL Sahara
Maybe try a different dealer if the current dealer can't figure it out. You are way more patient then I would be.
 

YippieKiYayMrFalcon

Well-Known Member
First Name
Rob
Joined
Oct 28, 2019
Messages
514
Reaction score
625
Location
Atlanta
Vehicle(s)
2021 JLU 80th Anniversary
Vehicle Showcase
1
Start getting together documentation on how many times it’s been to the dealer, and how many days it spent at each one in case you need to Lemon it. It’s easier to keep tabs along the way then try and figure out everything at the end.

hopefully it doesn’t get to that point, but better to have all the info together.
 

loiacki

Well-Known Member
First Name
Kim
Joined
May 18, 2018
Messages
136
Reaction score
205
Location
Phoenix, AZ
Vehicle(s)
2018 Rubicon JLU, 2005 Jeep Grand Cherokee
Occupation
IT
Vehicle Showcase
1
I’m having a similar issue that seems to be triggered by a dead six battery. I’ve been able to jump it as needed until today. While backing out of the driveway it threw itself into auto park and died. Horrible sounds came out of it since it was rolling. Doors were closed, seatbelt was on. This happened a couple more times and now the shifter is stuck in park but the dash says it’s stuck in drive. I can’t start it or move it so I did the emergency release. I disconnected the battery in the meantime. What was your final solution?
 
Advertisement

Motor City Aftermarket
 
Advertisement
Top