Static on Uconnect Media app and USB

Joined
Nov 8, 2018
Messages
14
Reaction score
2
Location
Denver
Vehicle(s)
2019 Rubicon Unlimited
Contacted Jeep about this issue and they want me to bring the Jeep to the dealer for analysis. Before I do, I wanted to see if this was a common problem...

I have a new 2019 Rubicon with the Alpine upgraded audio package. UConnect has the most recent update as of this post. I get static when playing music from my iPhone via USB and the UConnect Media app. However, the same song when played via Bluetooth or Apple Car Play (Car Play is connected by the same USB port and cable) has no static - the static is specific to USB and the UConnect Media app. The static can not be eliminated by turning down the volume (turning down the volume just turns down the static), and the standard UConnect equalizer does not reduce or isolate the static. It seems to be coming from all speakers in the higher or mid-high sonic ranges.

Jeep is guessing a loose wire or connection. I'm guessing a driver issue in the UConnect software. Any ideas?





Advertisement

 

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,280
Reaction score
2,056
Location
Auburn Hills, MI
Vehicle(s)
JL
Contacted Jeep about this issue and they want me to bring the Jeep to the dealer for analysis. Before I do, I wanted to see if this was a common problem...

I have a new 2019 Rubicon with the Alpine upgraded audio package. UConnect has the most recent update as of this post. I get static when playing music from my iPhone via USB and the UConnect Media app. However, the same song when played via Bluetooth or Apple Car Play (Car Play is connected by the same USB port and cable) has no static - the static is specific to USB and the UConnect Media app. The static can not be eliminated by turning down the volume (turning down the volume just turns down the static), and the standard UConnect equalizer does not reduce or isolate the static. It seems to be coming from all speakers in the higher or mid-high sonic ranges.

Jeep is guessing a loose wire or connection. I'm guessing a driver issue in the UConnect software. Any ideas?
Hi Alien Ant Farm,

We’re sorry to hear about this. We certainly understand how frustrating this may be. Please feel free to let us know if you decide to address this with your dealer and we will gladly assist you during that process.

Lydia
Jeep Social Care Specialist
 

LabNJeep

Member
First Name
Vinny
Joined
Aug 25, 2019
Messages
13
Reaction score
4
Location
Leesburg, VA
Vehicle(s)
Jeep JLR, BMW 530, Chevy Tahoe
Contacted Jeep about this issue and they want me to bring the Jeep to the dealer for analysis. Before I do, I wanted to see if this was a common problem...

I have a new 2019 Rubicon with the Alpine upgraded audio package. UConnect has the most recent update as of this post. I get static when playing music from my iPhone via USB and the UConnect Media app. However, the same song when played via Bluetooth or Apple Car Play (Car Play is connected by the same USB port and cable) has no static - the static is specific to USB and the UConnect Media app. The static can not be eliminated by turning down the volume (turning down the volume just turns down the static), and the standard UConnect equalizer does not reduce or isolate the static. It seems to be coming from all speakers in the higher or mid-high sonic ranges.

Jeep is guessing a loose wire or connection. I'm guessing a driver issue in the UConnect software. Any ideas?
Having the same issue on a 2020 JL. I’m my scenario, iPhone connected via USB has crackling/distortion when playing vie Apple a music. Same song on Bluetooth, no issue. BUT, the song quality is noticeably different being that via USB aside from the distortion/crackling, it’s much better quality. Are you able to get this addressed? Also, haven’t played with it enough but how did you configure top play via USB vs CarPlay?
 

rutiger

Well-Known Member
First Name
ryan
Joined
Apr 2, 2019
Messages
45
Reaction score
168
Location
seattle
Vehicle(s)
2019 rubicon, others
Same happens on our two ‘19 rubicons. Happened with my past iPhone X and still happens on my 11. I’ve tried all USB ports in the Jeep. My guess is uconnect software problem as it’s clearly not tied to a single phone or even Jeep in my testing. Only solution for me is use BT.
 

BobWBristolRI

Active Member
First Name
Bob
Joined
Apr 9, 2020
Messages
27
Reaction score
58
Location
Bristol RI
Vehicle(s)
2014 JGC, 2017 JGC, 2020 Wr JL
Occupation
Hard. It’s Work, isn’t it?
Vehicle Showcase
1
Fixed problem with high quality USB > Lightning cable. Read several threads and posts about this as I was experiencing same maddening issue (lousy audio quality via USB when Bluetooth was crystal) in my brandy new 2020 rolling boombox JL. Why an issue - just use BT? Except can’t BT when phone plugged in to charge etc. using USB. Went to Big Box store, explained issue to smart young car audio geek kid - immediately knew issue (not Jeep), pointed me to higher quality USB cord - fixed. Now loudly enjoying my subwoofer shaking Bob Wills and the Texas Playboys at every intersection stoplight.
 

Boogey

Well-Known Member
First Name
Rami
Joined
Oct 26, 2020
Messages
83
Reaction score
40
Location
Virginia
Vehicle(s)
JLU Sport S 2021
Fixed problem with high quality USB > Lightning cable. Read several threads and posts about this as I was experiencing same maddening issue (lousy audio quality via USB when Bluetooth was crystal) in my brandy new 2020 rolling boombox JL. Why an issue - just use BT? Except can’t BT when phone plugged in to charge etc. using USB. Went to Big Box store, explained issue to smart young car audio geek kid - immediately knew issue (not Jeep), pointed me to higher quality USB cord - fixed. Now loudly enjoying my subwoofer shaking Bob Wills and the Texas Playboys at every intersection stoplight.
I know this is old, but i have this issue as well and can't replicate it , so random , twice went to the dealership while the problem is there, parked the car, advisor came, NO PROBLEM...

I use the original Apple USB and USB -C to Lighting supplied cable ...that should be high enough quality right? If not can you point to the one you purchased or a link to some HQ cables?
 

BobWBristolRI

Active Member
First Name
Bob
Joined
Apr 9, 2020
Messages
27
Reaction score
58
Location
Bristol RI
Vehicle(s)
2014 JGC, 2017 JGC, 2020 Wr JL
Occupation
Hard. It’s Work, isn’t it?
Vehicle Showcase
1
I don't know the brand - ditched it already. But the kids at BestBuy were very familiar and carry a range of higher quality USB / phone cables because we're obviously not the only cars with this issue. Prices were $ to $$$. Think I paid $50, but it really only worked for a year or so - as the plug end into the phone jack wears, the static gradually returns (think it drops data packets as the connection quality slowly degrades over time.) Knew mine was done, when the UConnect started dropping sync with the phone periodically from vibrations/bumps while driving. Good luck (I've got to get another one also.) Regards, Bob W, Bristol RI
 

Boogey

Well-Known Member
First Name
Rami
Joined
Oct 26, 2020
Messages
83
Reaction score
40
Location
Virginia
Vehicle(s)
JLU Sport S 2021
Having the same issue on a 2020 JL. I’m my scenario, iPhone connected via USB has crackling/distortion when playing vie Apple a music. Same song on Bluetooth, no issue. BUT, the song quality is noticeably different being that via USB aside from the distortion/crackling, it’s much better quality. Are you able to get this addressed? Also, haven’t played with it enough but how did you configure top play via USB vs CarPlay?
Is it the same as in this video of mine?
 

Boogey

Well-Known Member
First Name
Rami
Joined
Oct 26, 2020
Messages
83
Reaction score
40
Location
Virginia
Vehicle(s)
JLU Sport S 2021
I don't know the brand - ditched it already. But the kids at BestBuy were very familiar and carry a range of higher quality USB / phone cables because we're obviously not the only cars with this issue. Prices were $ to $$$. Think I paid $50, but it really only worked for a year or so - as the plug end into the phone jack wears, the static gradually returns (think it drops data packets as the connection quality slowly degrades over time.) Knew mine was done, when the UConnect started dropping sync with the phone periodically from vibrations/bumps while driving. Good luck (I've got to get another one also.) Regards, Bob W, Bristol RI
Here is a video, is it the same problem?

 

BobWBristolRI

Active Member
First Name
Bob
Joined
Apr 9, 2020
Messages
27
Reaction score
58
Location
Bristol RI
Vehicle(s)
2014 JGC, 2017 JGC, 2020 Wr JL
Occupation
Hard. It’s Work, isn’t it?
Vehicle Showcase
1
Here is a video, is it the same problem?
Rami, Ya - same prob. I profess my elder ignorance about 'Car Play' as from day 1, I simply plug it in and select 'USB1' from source (or it just plays whatever I've got queued up or already playing on my Phone via Pandora or 'Music' app on iPhone.) After reading your most recent post, I went back and checked - mebbe it's my 'ear' or not playing music loud enough to detect the 'nuance' - but I don't really notice any diff in sound quality btwn USB and BT - except the staticky stuff from bumps, connection etc. I didn't buy a high quality replacement USB cord yet, still using cheap ones - which works 'mostly.' Looking for a high quality USB C to Lightning. Best of luck. Regards, Bob W, Bristol RI
 
Last edited:

Brian417

Member
First Name
Brian
Joined
Apr 4, 2021
Messages
6
Reaction score
1
Location
New jersey
Vehicle(s)
2021 Cherokee Limited
Here is a video, is it the same problem?

I’m having the same exact problem with my 2021 Cherokee. It drives me absolutely insane. Anyone find out the problem yet? Thanks
 

Boogey

Well-Known Member
First Name
Rami
Joined
Oct 26, 2020
Messages
83
Reaction score
40
Location
Virginia
Vehicle(s)
JLU Sport S 2021
I’m having the same exact problem with my 2021 Cherokee. It drives me absolutely insane. Anyone find out the problem yet? Thanks
Still nothing. Happened twice today randomly..... :(
 

Boogey

Well-Known Member
First Name
Rami
Joined
Oct 26, 2020
Messages
83
Reaction score
40
Location
Virginia
Vehicle(s)
JLU Sport S 2021
Dropped my Jeep off at the dealership to be looked at. I will report back with any information.
ok thanks! Please do! Did the dealer say anything about "can't replicate the issue" so there is nothing to do? cuz my dealer is stuck like a record on that phrase and will not touch it without seeing it!
 

Brian417

Member
First Name
Brian
Joined
Apr 4, 2021
Messages
6
Reaction score
1
Location
New jersey
Vehicle(s)
2021 Cherokee Limited
ok thanks! Please do! Did the dealer say anything about "can't replicate the issue" so there is nothing to do? cuz my dealer is stuck like a record on that phrase and will not touch it without seeing it!
Nah, so far they only said that they have a computer system where every mechanic reports in various problems for Jeep. So they’re gonna search it up on their system and see if anyone else had a similar issue and then see how to fix it. Also, I told them that it starts doing it about 20 minutes into my drive. I don’t know why. Only does it with CarPlay, not Sirius, not FM/AM or Bluetooth.

Hopefully I’ll hear back tomorrow. I’ll keep you posted
 

Advertisement




Bestop
 



Advertisement
Top