So what's the scoop? Have the Uconnect issues been resolved yet?

TheMachine

Member
First Name
Chris
Joined
Jan 8, 2018
Messages
9
Reaction score
0
Location
Arizona
Vehicle(s)
Ford F-150
The off road pages show all the screens that you can cycle through on the cluster screen all on the same screen on the 8.4 (We'll in theory anyway)
Screenshot_20180125-204839.jpg
How do you find these off road pages on the 8” screen?
Advertisement

 

sjappers

Well-Known Member
Joined
Jan 9, 2018
Messages
167
Reaction score
42
Location
oregon
Vehicle(s)
2018 JLUR, tacoma
So is this still an issue? my jeep is being inspected now, so I want to make sure I get everything correct. I have 8.4, should it be there? I assume yes, thats what I thought I was buying?
 

Truluc77

Member
First Name
Rob
Joined
Dec 2, 2017
Messages
14
Reaction score
23
Location
Houston
Vehicle(s)
Jeep Grand Cherokee and JL on order
So what's the scoop? Have the Uconnect issues been resolved yet?:like:
I’ve had my JL for a month now. Today the Uconnect system suddenly stopped working. It will play music, but the screen is completely unresponsive. When you touch on it anywhere, it will beep, but nothing will happen. You can’t switch apps, stations, favorites.....nothing. It just beeps and sits there. I’ve cycled through a number of engine on/off cycles hoping it would clear it, but no luck. Guess I’ll take it to the dealer Monday. I did have the blue screen glitch with the backup camera once, but that is the only other issue until now.
 
OP
OP
Tunesoul

Tunesoul

Well-Known Member
First Name
Kirk
Joined
Jan 28, 2018
Messages
488
Reaction score
614
Location
California
Vehicle(s)
1999 Jeep Wrangler Sport, 2012 Subaru Outback, 2018 Ocean Blue JLUR
Occupation
Owner of a Mobile Auto Paint Touch Up Co.
Well that sucks... SMH...
 

Blood Type J+

Well-Known Member
Joined
Feb 8, 2018
Messages
136
Reaction score
194
Location
Austin, TX
Vehicle(s)
99 TJ Sport 6-cyl
I’ve had my JL for a month now. Today the Uconnect system suddenly stopped working. It will play music, but the screen is completely unresponsive. When you touch on it anywhere, it will beep, but nothing will happen. You can’t switch apps, stations, favorites.....nothing. It just beeps and sits there. I’ve cycled through a number of engine on/off cycles hoping it would clear it, but no luck. Guess I’ll take it to the dealer Monday. I did have the blue screen glitch with the backup camera once, but that is the only other issue until now.
Maybe turn it off, pull the associated fuse(s), let it sit 5 minutes, reinstall fuses and power up? It may be there's a subsystem in the electronics that stays alive even when everything is powered down.

If they replace the unit, it will be interesting to see if you get offroad pages.
 

Truluc77

Member
First Name
Rob
Joined
Dec 2, 2017
Messages
14
Reaction score
23
Location
Houston
Vehicle(s)
Jeep Grand Cherokee and JL on order
I’ve had my JL for a month now. Today the Uconnect system suddenly stopped working. It will play music, but the screen is completely unresponsive. When you touch on it anywhere, it will beep, but nothing will happen. You can’t switch apps, stations, favorites.....nothing. It just beeps and sits there. I’ve cycled through a number of engine on/off cycles hoping it would clear it, but no luck. Guess I’ll take it to the dealer Monday. I did have the blue screen glitch with the backup camera once, but that is the only other issue until now.
@JeepCares So, I got back in the Rubi this evening and everything works perfectly fine. Like nothing was ever wrong. I read somewhere on the forum that there was an issue with the system shutting down if it exceeded temperature highs and lows because the system misread the real temp and went into a safety mode. I wonder if that is what happened here. This was the first time I had the top all the way off and the Jeep was in the driveway in the sun for maybe an hour in direct sunlight. I’m in Houston and it was in the 70s...but we get a whole lot hotter then this and I can’t imagine the system would overheat with what it was exposed to today.
 

Truluc77

Member
First Name
Rob
Joined
Dec 2, 2017
Messages
14
Reaction score
23
Location
Houston
Vehicle(s)
Jeep Grand Cherokee and JL on order
So, I got back in the Rubi this evening and everything works perfectly fine. Like nothing was ever wrong. I read somewhere on the forum that there was an issue with the system shutting down if it exceeded temperature highs and lows because the system misread the real temp and went into a safety mode. I wonder if that is what happened here. This was the first time I had the top all the way off and the Jeep was in the driveway in the sun for maybe an hour in direct sunlight. I’m in Houston and it was in the 70s...but we get a whole lot hotter then this and I can’t imagine the system would overheat with what it was exposed to today.
@JeepCares And just to be specific, the unit was unresponsive except for the “buttons” along the left side. It was locked in radio, so I could select the 1st programmed station as well as the first App shortcut (which happened to be the radio) as well as the back button if I used the dials to manually change the station. So it was as if only the farthest left edge of the unit was functioning. Touching it anywhere else had no response.
 

Levi8than

Well-Known Member
First Name
Joe
Joined
Oct 2, 2018
Messages
58
Reaction score
13
Location
California
Vehicle(s)
2018 JL Wrangler Rubicon
@Truluc77, thanks for posting this. I've got an 8.4 uconnect with weird intermittent issues. The other day I took a 3 hour drive with an unresponsive screen. The radio still worked because of the controls on the steering wheel, but the touch screen was completely unresponsive.

Even when the screen is responsive, often bluetooth disconnects silently (tried with 2 separate phones) and won't re-pair until I've turned the vehicle off and back on. This is especially annoying when I use android auto screen mirroring (AWESOME for maps and phone interface). I make a call from the screen only to discover that the audio for the call is coming out of my phone speaker, not the car's speakers. But there's nothing I can do because fumbling for my phone isn't safe while driving. So I hang up and give up. But later after restarting the vehicle of course everything works again. I can't reproduce any of this on demand.

I'm dreading going into the dealership about this because it's so intermittent. Some days everything works perfectly. Others I just wish cars came with real buttons and knobs rather than glitchy touch screen.

@JeepCares, got any advice for me?
 
  • Like
Reactions: JBS

GTOB521

Member
First Name
Garrett
Joined
Nov 6, 2018
Messages
19
Reaction score
7
Location
Leawood KS
Vehicle(s)
Wrangler JLU Rubicon
Just today after I wired my dashcam my UConnect screen completely shuts off and the audio stops with it. The only fix is for me to turn the car off and then back on. I hope the software update fixes this issue
 

Levi8than

Well-Known Member
First Name
Joe
Joined
Oct 2, 2018
Messages
58
Reaction score
13
Location
California
Vehicle(s)
2018 JL Wrangler Rubicon
@Truluc77, thanks for posting this. I've got an 8.4 uconnect with weird intermittent issues. The other day I took a 3 hour drive with an unresponsive screen. The radio still worked because of the controls on the steering wheel, but the touch screen was completely unresponsive.

...

@JeepCares, got any advice for me?
This is frustrating. I recorded repro videos of this happening today; maybe just to prove to others that I'm not crazy.
If anybody has advice or a work around, let me know.

Here is the unresponsive touch screen:
https://photos.app.goo.gl/uGPi8Z1Q5wuyrjZU8

And here, even better, is the screen being completely off. No radio. No back up camera. Nothing.

https://photos.app.goo.gl/NdjxZDtxj2cWJ4re7

It splashed the Jeep Logo about 5 minutes into the drive. Loose connection? Now that I have the two videos, I'll take it into a dealership and have them look at it.
 

JOKeefe

Active Member
First Name
Mount Pearl
Joined
Mar 22, 2018
Messages
26
Reaction score
15
Location
Newfoundland, Canada
Vehicle(s)
2009 Jeep Wrangler Unlimited
This is frustrating. I recorded repro videos of this happening today; maybe just to prove to others that I'm not crazy.
If anybody has advice or a work around, let me know.

Here is the unresponsive touch screen:
https://photos.app.goo.gl/uGPi8Z1Q5wuyrjZU8

And here, even better, is the screen being completely off. No radio. No back up camera. Nothing.

https://photos.app.goo.gl/NdjxZDtxj2cWJ4re7

It splashed the Jeep Logo about 5 minutes into the drive. Loose connection? Now that I have the two videos, I'll take it into a dealership and have them look at it.
Have been having the same issues since 3rd week of June. Picked up vehicle on June 1, so got a couple trouble free weeks. Was told multiple times to expect an update. Got 1 update, which gave me Offroad pages back in September, but never fixed the freezing, blue screen, or flat out black, non-working screen.
 

Levi8than

Well-Known Member
First Name
Joe
Joined
Oct 2, 2018
Messages
58
Reaction score
13
Location
California
Vehicle(s)
2018 JL Wrangler Rubicon
Sorry @JOKeefe, that's rediculous. You paid a lot of money for something that isn't working and hasn't been working for this long. They need to get their act in gear. I'd recommend you take our your phone and record every time it fails. Especially if the failure creates and unsafe driving condition.

I got an appointment at my local dealership for end of the month. They're going to take the vehicle for a day and see what they need to do to fix it. Fingers crossed.

I've also been doing some thinking.
As of May 2018 all new cars sold in the USA were required to have video backup cameras. So for my state (California) a faulty screen that prevents you from using the backup camera is enough to qualify for a Lemon Law return. Price is set based on the mileage when you first report the issue.
So if they can't fix the issue within a reasonable amount of time I could return it for (2k/120k) and be refunded my loan interest and all but 1.7% of the purchase price. So I'm going to keep driving the vehicle and enjoying it. I love the vehicle, so hopefully they can fix it. But if not, I still got a GREAT price on a lease.
 

JOKeefe

Active Member
First Name
Mount Pearl
Joined
Mar 22, 2018
Messages
26
Reaction score
15
Location
Newfoundland, Canada
Vehicle(s)
2009 Jeep Wrangler Unlimited
Sorry, I know I said I would update over the weekend, but the past week has been hectic. Issue was not resolved. Turns out I have the most up to date version of Uconnect already installed. With that being said, I have not had the system freeze on me in awhile. My SiriusXM favorites still won't work, but I've basically given up on that.
 

StrikeZ

Well-Known Member
First Name
TJ
Joined
Mar 26, 2018
Messages
247
Reaction score
241
Location
Maryland
Vehicle(s)
2018 Jeep Wrangler Rubicon Unlimited
This is the second time my Uconnect started acting up. The audio cuts out every 3 seconds. It does it for SXM, radio and Apple Play. I restarted my Jeep a couple of times and it did not work.
 
Advertisement

Icon Vehicle Dynamics
 
Advertisement
Top