S&B Cool Air Intake Issue

elispaulding

Member
First Name
Eli
Joined
May 27, 2020
Messages
21
Reaction score
17
Location
Salt Lake City, UT
Vehicle(s)
2020 Wrangler Unlimited Freedom
Occupation
Student at University of Utah
Hi everyone,
I have a 2020 Wrangler Unlimited with the 2.0L. My friend and I installed a S&B Intake into it about 3 weeks ago. A couple days ago the check engine light came on. I brought the car into Jeep and they said it was because Purge Line and the other line next to it were not connected. These lines will not reach the filter and there is only a place for one line, not two. The guy at Jeep said this is what is causing the light to come on because these lines provide boost and prevent turbo delay. I have attached a couple pictures so you can see what I am talking about. Has anyone else experienced this or have any advice that could help me out?
Thanks!

IMG_6653.JPG


IMG_0371.JPG
Advertisement

 

Arterius2

Well-Known Member
First Name
Jerry
Joined
Dec 29, 2018
Messages
3,485
Reaction score
4,571
Location
Vancouver, BC
Vehicle(s)
2018 JLU Sahara 2.0L
Hi everyone,
I have a 2020 Wrangler Unlimited with the 2.0L. My friend and I installed a S&B Intake into it about 3 weeks ago. A couple days ago the check engine light came on. I brought the car into Jeep and they said it was because Purge Line and the other line next to it were not connected. These lines will not reach the filter and there is only a place for one line, not two. The guy at Jeep said this is what is causing the light to come on because these lines provide boost and prevent turbo delay. I have attached a couple pictures so you can see what I am talking about. Has anyone else experienced this or have any advice that could help me out?
Thanks!

IMG_6653.JPG


IMG_0371.JPG
Looks like you bought the CAI for the 3.6 pentastar

The 2.0 is supposed to look like this.

86408C55-0CFE-4470-90ED-35845AA2A71E.jpeg
 
OP
OP
elispaulding

elispaulding

Member
First Name
Eli
Joined
May 27, 2020
Messages
21
Reaction score
17
Location
Salt Lake City, UT
Vehicle(s)
2020 Wrangler Unlimited Freedom
Occupation
Student at University of Utah
Looks like you bought the CAI for the 3.6 pentastar
you're right. Just checked and its for the 3.6L. That is no good. Guessing its probably best to put the factory one back in...
 

bpdunsta

Well-Known Member
Joined
Mar 16, 2019
Messages
226
Reaction score
165
Location
Chicagoland
Vehicle(s)
2019 JLU Moab
you're right. Just checked and its for the 3.6L. That is no good. Guessing its probably best to put the factory one back in...
But the one for the 2.0 Turbo and sell the one you have on here. You will take a little bit of a hit, but not as much as just scrapping it and going back to factory setup.
 

Moto_21

Well-Known Member
First Name
Erik
Joined
Jul 18, 2018
Messages
2,275
Reaction score
5,161
Location
Corona
Vehicle(s)
2018 JLU Sport
Occupation
Maintenance
Vehicle Showcase
1
What do you want to sell it to me for? Lol
 
OP
OP
elispaulding

elispaulding

Member
First Name
Eli
Joined
May 27, 2020
Messages
21
Reaction score
17
Location
Salt Lake City, UT
Vehicle(s)
2020 Wrangler Unlimited Freedom
Occupation
Student at University of Utah
What do you want to sell it to me for? Lol
Amazon accepted my return on it. If there are any issues I will let you know and sell it to you. I talked to S&B and even though some cold air intakes say backorder they said they should ship out in a couple days.
 

Aspaztikcolon

Well-Known Member
First Name
Doug
Joined
Jul 31, 2019
Messages
57
Reaction score
22
Location
Boise, ID
Vehicle(s)
2019 JLUR
Might just run it anyway. I have the correct CAI from S&B and still get codes
 
OP
OP
elispaulding

elispaulding

Member
First Name
Eli
Joined
May 27, 2020
Messages
21
Reaction score
17
Location
Salt Lake City, UT
Vehicle(s)
2020 Wrangler Unlimited Freedom
Occupation
Student at University of Utah
Might just run it anyway. I have the correct CAI from S&B and still get codes
I put the factory intake back in until my new correct one comes. I have driven about 200 miles with it and it is still running a code. Brought it to Jeep and they said it was a purge line and boost issue and might still be resetting. They also said my warranty on any issue related to the intake is now voided because I touched it. Does this sound correct that it could still be resetting? Also you mentioned you still run codes with the correct one in. How do you know that no new issues arise when the light stays on? Thanks for the help! Guidance and/or advice from anyone is welcomed!
 

Aspaztikcolon

Well-Known Member
First Name
Doug
Joined
Jul 31, 2019
Messages
57
Reaction score
22
Location
Boise, ID
Vehicle(s)
2019 JLUR
I put the factory intake back in until my new correct one comes. I have driven about 200 miles with it and it is still running a code. Brought it to Jeep and they said it was a purge line and boost issue and might still be resetting. They also said my warranty on any issue related to the intake is now voided because I touched it. Does this sound correct that it could still be resetting? Also you mentioned you still run codes with the correct one in. How do you know that no new issues arise when the light stays on? Thanks for the help! Guidance and/or advice from anyone is welcomed!
Sounds like they're just being a$$holes. If you're not using their intake, well yeah, there's no jeep warranty on it. Wouldn't worry about
 
Advertisement

Morris 4x4 Center
 
Advertisement
Top