Rear window defroster unsoldered?

OP
wolfdog

wolfdog

Well-Known Member
First Name
George
Joined
Apr 14, 2018
Messages
449
Reaction score
319
Location
Southern Massachusetts
Vehicle(s)
2006 Yamaha FJR1300, 2015 Cherokee TH, 2018 JLU Sahara
Occupation
Maritime Artisan, Mayflower II
  • Thread starter
  • Thread Starter
  • #332
Last post I said I wasn't sure it was working, felt warm?? Well if it did feel warm all it was doing was melting solder on one connection. Wire off new MoPar window installed by dealership! New window installed 5/26/2019 just tried finally last week! Sure wish I'd used it before winter. Now for 4 ahhh 5th time (lost count) since Feb. 2018 2 solder one epoxy tries by dealer no luck?? New complete window another failure?

Think they would have found a fix by now? The epoxt fix worked on my 2012 JKU lasted 30K, no good on JLU

Go Jeep!!!
 

SmallCheese

New Member
First Name
Cheesus
Joined
Jan 3, 2019
Messages
3
Reaction score
4
Location
Canada
Vehicle(s)
2 Door JL Rubicon
Possible simple fix if it is just a wire popped off, I just reattached rear passenger wire to window the other day.

I bought a cheap Permatex rear defogger repair kit locally ($25-30 cnd, probably cheaper if your across the pond )

I used whatever epoxy / activator that came within the kit, (possibly copper based epoxy, brownish color)

Ice rain today, window was covered, good practical test for it, worked great, I let her run for 30 min or so to see if the connection would melt and she held.

That being said I'll be grabbing some silver epoxy at a later date. But I'm interested to see how she holds.

If your issues are further than a wire popping off I feel for you, hoping it gets sorted ASAP!!!
 

Maverick909

Well-Known Member
First Name
Brian
Joined
Jan 15, 2019
Messages
1,495
Reaction score
1,499
Location
SoCal
Vehicle(s)
2018 JLU Sporticon, 1976 GMC K15 Lifted on 35's
add me to the list. was out in Sedona for the long weekend and is snowed on us through the night. got up and started the jeep and hit the rear defroster and within 15 mins the wire was dangling from the wire tie at the hard top. Kinda sad after one use its fallen off.. ill be calling the dealer tonight and seeing how they're going to fix it. really dont want the window replaced as i have a few stickers i dont wanna re-buy since they're only 2 months old.
 

Ed El Man

Well-Known Member
First Name
Edgar
Joined
Apr 11, 2018
Messages
137
Reaction score
261
Location
New York
Vehicle(s)
2018 Wrangler JLUR, 2016 Ducati XDiavel S, 2011 Ducati 848 Evo, 2008 Mazda CX-9 Grandtouring (the beater)
Vehicle Showcase
1
Anybody have this happen yet or am I just lucky? JLUS rear window defroster came unsoldered already, 4 months 2600 miles, very little off road? Rear window raised maybe dozen times at most, seems like a short life solder!!
censored.gif


Had it happen on my 2012 JKUS but at 50k and lots of off road!! Pain in the butt, dealer tried to re solder, crap job. Found a kit for repair with some kind of electrical epoxy compound, worked better but tricky.

Go Jeep!!!
Yes it happened to me and the part was leaning against the window and got very hot to the point it melted a decal I had on the outside. After I went to wipe it the window exploded.
 
OP
wolfdog

wolfdog

Well-Known Member
First Name
George
Joined
Apr 14, 2018
Messages
449
Reaction score
319
Location
Southern Massachusetts
Vehicle(s)
2006 Yamaha FJR1300, 2015 Cherokee TH, 2018 JLU Sahara
Occupation
Maritime Artisan, Mayflower II
  • Thread starter
  • Thread Starter
  • #336
Ed El Man,

Since my last post that you quoted I've had 4 failed fixes, both solder and MoPar epoxy, one new window and wire came off in a couple months, never got to use it, may not have worked at all?? New dealer now will replace complete rear wire harness. Parts on order one week already, no sign of part yet??

Rest of JLU fine rear window is a pain in the butt, loaners, rentals and especially time! Seems Jeep needs a new "tab' arrangement but seem not up to it??

Go Jeep!!!
 

CricketOfAk

Member
First Name
Tara
Joined
May 20, 2019
Messages
5
Reaction score
0
Location
Anchorage, Alaska
Vehicle(s)
Owe'n 2018 JLU SportS
Mine disconnected 3 months after purchase. Dealer epoxied it back on. It's connected now, but the defroster still doesn't work. Gonna have to take it back in again.
 

Ed El Man

Well-Known Member
First Name
Edgar
Joined
Apr 11, 2018
Messages
137
Reaction score
261
Location
New York
Vehicle(s)
2018 Wrangler JLUR, 2016 Ducati XDiavel S, 2011 Ducati 848 Evo, 2008 Mazda CX-9 Grandtouring (the beater)
Vehicle Showcase
1
Mine disconnected 3 months after purchase. Dealer epoxied it back on. It's connected now, but the defroster still doesn't work. Gonna have to take it back in again.
My window over heated and exploded on me after it was put back
8E85E563-F558-448D-9E5A-99272519A4F2.jpeg
56CE5C44-C6EF-4CF2-A501-093CEA0BE522.jpeg
02F4D6D1-9735-43C1-944A-DC6BD19F36EE.jpeg
0632A9F8-D900-498B-B0D2-AE7C8F2AEE15.jpeg
 
OP
wolfdog

wolfdog

Well-Known Member
First Name
George
Joined
Apr 14, 2018
Messages
449
Reaction score
319
Location
Southern Massachusetts
Vehicle(s)
2006 Yamaha FJR1300, 2015 Cherokee TH, 2018 JLU Sahara
Occupation
Maritime Artisan, Mayflower II
  • Thread starter
  • Thread Starter
  • #339
As said before, 5 "fixes" including new rear window complete, still no work?? New dealer service department found bad wire harness , parts just in, one week wait. New "fix" next Friday by the look of this last set of photos maybe leave it and use a scraper!!!!

Gonna try, wish me luck? This dealer I've bought 6 Jeeps from has better service than dealer my JLU came from...we'll see? They think there's been no "juice" since new window installed?? I think Jeep has to engineer a whole new defroster connection...Just sayin"!!

Go jeep!!!
 

JL wit da JLU

Member
First Name
Jeremy
Joined
May 10, 2019
Messages
9
Reaction score
5
Location
Belleville
Vehicle(s)
2018 Wrangler JLU Sahara
Add another to the list! JLU Sahara Year old in 2 weeks, 22500km.. went to use defroster today, nothing, seen something dangling through rear view, checked when I stopped at work, an sure enough! Another bad solder! That’s 2 out of 3 friends an myself that bought these new JLs and have had it fall off... guess I’ll be bookin it in tomorrow...

D6DF1B80-ABFC-471F-822E-B862796971FB.jpeg
 

HempelNet

Member
First Name
James
Joined
May 10, 2018
Messages
15
Reaction score
11
Location
Indianapolis, Indiana
Vehicle(s)
2018 Jeep JLU Sport
I had the epoxy fix from the dealer fail on my way home from the dealership :swear: . They then ordered me a complete replacement glass that took 2 months to come in. They installed this glass and a week later I see the cord dangling yet again. Keep in mind I did not have dogs, cargo, or even excessive use of opening the tail gate but yet I get blessed with this. I then called and scheduled then to order a new glass or epoxy kit (pending on the service tech) and waited. After 2 months pass with no notification from the dealership I called to check my order.

You guessed it, the order was not completed and was canceled due to a part number change? :whatsgoingon:

At this point I fixed it myself by soldering the button back on the glass, tested connectivity, and pushed the cable on the button. To make sure this does not happen again I then ran some fine SS wire under the plastic bracket holding the cable and twist-tied the cable in place.

Several months later and I still have a defroster!!
 

Patthe

Well-Known Member
First Name
Patrick
Joined
Mar 31, 2018
Messages
49
Reaction score
14
Location
Edmonton, Canada
Vehicle(s)
Jeep wrangler unlimited JL
I stop counting after 5 trial at fixing the problem. Lol, anyway. So my cable broke so many time that it burn the heating element on the windows so yet again need a new windows. This will be my second back windows. Interesting news they order a new back windows, they say no cure necessary as the wire is already attach to the cable. So hopefully this is windows 10.0 version that will stay one? Stay tune. Been install this weekend.
 

Baddjonez

Member
Joined
Jan 28, 2019
Messages
18
Reaction score
4
Location
New York
Vehicle(s)
2018 Wrangler Sport S
Sadly with 6k on my 2018 JLU the tab came off my defroster. The dealer reattached it and now it has failed again less than 500 miles later. Funniest thing is I didn't even open the hatch. Awaiting a call back to see when I can drop it off for them to look at. Dumb problem, now a hassle during the winter with no defroster.
 

rfm8os

Well-Known Member
First Name
Robert
Joined
Oct 3, 2018
Messages
128
Reaction score
154
Location
Groveland, MA
Vehicle(s)
2020 JLUR, Jeep Liberty, Toyota Highlander, Buick Enclave
Sadly with 6k on my 2018 JLU the tab came off my defroster. The dealer reattached it and now it has failed again less than 500 miles later. Funniest thing is I didn't even open the hatch. Awaiting a call back to see when I can drop it off for them to look at. Dumb problem, now a hassle during the winter with no defroster.
I had the detached tab which the dealership fixed a couple of months ago and so far it has not detached again. However, it doesn't seem to me that the rear window defroster is actually doing anything. On the one occasion I had a slight frosting, or fogging, it did not seem like the defroster did anything as I saw no "lines" as the back window very slowly cleared. I think it was just clearing as the cabin warmed.

However, not that it excuses the debacle that is the rear window defrost detachment issue but I have found my rear window has not really been frosting over this winter so I haven't missed it that much. I am not sure if it's the nature of the windshield being very vertical but in my previous cars I would get at least some decently thick frosting almost every morning during the winter and I am just not getting that this year.
 

Advertisement




Superchips Flashcal Programmer out for JL Wrangler
 



Advertisement
Top