Rear defrost burnt/discolored

Notviper

Member
First Name
Ben
Joined
Jun 21, 2019
Messages
14
Reaction score
6
Location
Los Angeles, CA
Vehicle(s)
2018 JLU Moab Edition
Hi all,

*Sorry for the double post about this in the General discussion (https://www.jlwranglerforums.com/forum/threads/rear-defrost-burnt-discolored.40797/#post-901942). Realized I couldn't delete a thread once it's created. Not exactly a forum power user here :facepalm:

I noticed that the defrost on my back glass has recently become discolored. I'm not sure exactly how this happened since I've also never turned on the rear defrost.

It seems like most others have experienced issues with the contact becoming disconnected, but my issue looks like it had overheated at some point. Could this be an electrical issue?

Scheduled a visit to the dealer, but wanted to reach out to the community to see if anyone else has experienced this.

IMG_4282.jpg


IMG_4280.jpg


IMG_4278.jpg





Advertisement

 
Last edited:

xeon

Well-Known Member
First Name
John
Joined
Jan 18, 2018
Messages
311
Reaction score
227
Location
California
Vehicle(s)
JLU Rubicon
Have the same exact issue....watching this thread
 

chris4prez

Well-Known Member
First Name
Chris
Joined
Sep 14, 2019
Messages
130
Reaction score
53
Location
Tampa
Vehicle(s)
'20 JLUR
What was the outcome. Having similar issue here
 

Twilly35

New Member
First Name
Tim
Joined
Jun 12, 2020
Messages
2
Reaction score
2
Location
Oregon
Vehicle(s)
2018 Rubicon JL
I have the same issue. Took it into dealer because one of the connectors for the defrost came off. They tried to tell me that it’s normal and that most keeps do it. After the repair the connector came off again. I reached out to Jeep customer care. They contacted dealer and are making arrangements to have the rear glass replaced. We shall see if this truly happens or not.
 

BernJLUR

Well-Known Member
First Name
Bern
Joined
May 9, 2019
Messages
324
Reaction score
811
Location
Bradenton FL
Vehicle(s)
2019 Ocean Blue JLUR (on order), 2015 Anvil JKU, 1995 4.0L YJ
Mine looks like that too. I’ve never used the function either. Following this one.
 

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,412
Reaction score
2,136
Location
Auburn Hills, MI
Vehicle(s)
JL
What was the outcome. Having similar issue here
Same here.
Mine looks like that too. I’ve never used the function either. Following this one.
Hi all,
Thank you for sharing your concerns here. Please know that our team is here to assist you alongside your dealer, and would be happy to connect you with a specialist during your servicing visit. If you find that you would like our additional support or have any future questions, feel free to send our team a private message. We are happy to help!

Kathryn
JeepCares
 

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,412
Reaction score
2,136
Location
Auburn Hills, MI
Vehicle(s)
JL
I have the same issue. Took it into dealer because one of the connectors for the defrost came off. They tried to tell me that it’s normal and that most keeps do it. After the repair the connector came off again. I reached out to Jeep customer care. They contacted dealer and are making arrangements to have the rear glass replaced. We shall see if this truly happens or not.
Hi @Twilly35
We are glad to see that you are currently working with a case specialist to resolve this concern. If you have any questions regarding your case or are having trouble connecting with your specialist, feel free to send us a private message here.

Kathryn
JeepCares
 

MikeJLURubi

Well-Known Member
First Name
Mike
Joined
Apr 26, 2018
Messages
357
Reaction score
291
Location
Chillicothe, Ohio
Vehicle(s)
2018 Jeep Wrangler JLU Rubicon
Occupation
Medicolegal Death Investigator
Hi all,
Thank you for sharing your concerns here. Please know that our team is here to assist you alongside your dealer, and would be happy to connect you with a specialist during your servicing visit. If you find that you would like our additional support or have any future questions, feel free to send our team a private message. We are happy to help!

Kathryn
JeepCares
I just sent @JeepCares a PM reference a on going issue but no response
 

Advertisement




Quake LED
 



Advertisement
Top