No Power to Dash

rwperez

Member
First Name
Robert
Joined
Oct 27, 2018
Messages
20
Reaction score
21
Location
Cartersville, GA
Vehicle(s)
2018 Wrangler JL Sport, 2015 Sahara Unlimited
I have a "no power to dash" problem with my 2019 JL Sport S. I have exhausted the list of things I know to do to get past it (disconnected both batteries for four hours, made sure they were charged, replaced Fuse Array 68368853AA, fuse jumped positions 1&2 on the array to bypass the start/stop battery, etc.) Has anyone else had this problem? I am out of warranty and would like to exhaust my DIY options.
Advertisement

 

Jebiruph

Well-Known Member
First Name
Jerry
Joined
Feb 18, 2018
Messages
1,524
Reaction score
1,909
Location
Iowa
Vehicle(s)
2018 JLU, 2019 KL, 2020 JT
Check for power at N1 and if that's good start checking the regular fuses. The underside of the PDC cover identifies the fuses. What led up to the "no power to dash"?
 
OP
OP

rwperez

Member
First Name
Robert
Joined
Oct 27, 2018
Messages
20
Reaction score
21
Location
Cartersville, GA
Vehicle(s)
2018 Wrangler JL Sport, 2015 Sahara Unlimited
Check for power at N1 and if that's good start checking the regular fuses. The underside of the PDC cover identifies the fuses. What led up to the "no power to dash"?
A few instances of power steering loss & really odd dash behavior. I remedied them previously by disconnecting N1 and the batteries for 30 minutes. This no longer works.
 

four low

Well-Known Member
Joined
Feb 1, 2017
Messages
2,506
Reaction score
2,833
Location
central New York
Vehicle(s)
2018 JL
And the grounds, harness connections are good ? Intermittent failures leading up to this might indicate a bad ground , harness connection. Wasn't there a TSB for this ?
 
OP
OP

rwperez

Member
First Name
Robert
Joined
Oct 27, 2018
Messages
20
Reaction score
21
Location
Cartersville, GA
Vehicle(s)
2018 Wrangler JL Sport, 2015 Sahara Unlimited
And the grounds, harness connections are good ? Intermittent failures leading up to this might indicate a bad ground , harness connection. Wasn't there a TSB for this ?
Yes, grounds & connections are good, fuses checked out. There were a couple of TSBs, both for firmware updates that predate my instrument cluster. I think I am just going to replace it and see what happens.
 
Advertisement

Winjet
 
Advertisement
Top