No Dealer Service support because I have a Mopar 82215382AB harness installed?

MaxD

Member
First Name
Rob
Joined
Jun 8, 2020
Messages
10
Reaction score
8
Location
Eagleville TN
Vehicle(s)
2019 Wrangler Sport S
Occupation
Maintenance Manager
I have been having issues since new that the "aux switches unavailable, battery charging" displays every morning leaving the house and every evening when leaving work.
They even had to install a new battery the day I went to look at it.
The Engine Stop/Start NEVER stops the engine anymore.
The R/R LED tail light has been delayed turning on in the morning or not lighting up at all.
I dropped it off at Beaman Dodge In Murfreesboro, TN and they are telling me that they will not look at any of these issues because of the Mopar 82215382AB Towed Vehicle harness being installed.
They are saying that the system isn't programmed for this and it's putting too much load on the system.
I explained to them that this system does nothing more than disconnect power from the tail lights while hooked up to a motorhome for towing.
They still refuse to even look at it.
They also told me that this isn't a factory towing package so they can't fix anything under warranty. It IS a factory towing package but I installed a longer receiver hitch to clear my spare tire.
Their reasoning is that I've modified the vehicle.

What are my options here?
Are we not allowed to change anything on our Wranglers because it's now modified and they won't fix anything under warranty?
Anybody else having issues like this? Do I have to remove everything that was changed or added back to stock just for them to look at it?
I'm not sure what I'm supposed to do now if I get a ticket for the tail light?

Any advice?
Advertisement

 

TheRaven

Well-Known Member
First Name
Kevin
Joined
Oct 22, 2020
Messages
551
Reaction score
697
Location
Reading, Pennsylvania
Vehicle(s)
2021 JLU 80th, 2020 Challenger Scat Pack, 2010 Tahoe Z71
I have been having issues since new that the "aux switches unavailable, battery charging" displays every morning leaving the house and every evening when leaving work.
They even had to install a new battery the day I went to look at it.
The Engine Stop/Start NEVER stops the engine anymore.
The R/R LED tail light has been delayed turning on in the morning or not lighting up at all.
I dropped it off at Beaman Dodge In Murfreesboro, TN and they are telling me that they will not look at any of these issues because of the Mopar 82215382AB Towed Vehicle harness being installed.
They are saying that the system isn't programmed for this and it's putting too much load on the system.
I explained to them that this system does nothing more than disconnect power from the tail lights while hooked up to a motorhome for towing.
They still refuse to even look at it.
They also told me that this isn't a factory towing package so they can't fix anything under warranty. It IS a factory towing package but I installed a longer receiver hitch to clear my spare tire.
Their reasoning is that I've modified the vehicle.

What are my options here?
Are we not allowed to change anything on our Wranglers because it's now modified and they won't fix anything under warranty?
Anybody else having issues like this? Do I have to remove everything that was changed or added back to stock just for them to look at it?
I'm not sure what I'm supposed to do now if I get a ticket for the tail light?

Any advice?
Ok maybe i'm misreading this...but it sounds like you or some third party installed a factory towing package...is that correct? Because if so, you are going to be given a hard time about it since there's a good bet it is causing your tail-light issue. So if that's the case, i'd remove it and go to a different dealer. Get everything fixed and working correctly, then have the dealer install the same towing package. This way the proper codes (if there are any) are added to the system and your vehicle, and the install is documented in the FCA system.
 

ECP

Well-Known Member
First Name
Peter
Joined
Sep 30, 2021
Messages
187
Reaction score
151
Location
FL, NC, or out of the country
Vehicle(s)
21 JLURD
I dropped it off at Beaman Dodge In Murfreesboro, TN and they are telling me that they will not look at any of these issues because of the Mopar 82215382AB Towed Vehicle harness being installed.
They are saying that the system isn't programmed for this and it's putting too much load on the system.
I explained to them that this system does nothing more than disconnect power from the tail lights while hooked up to a motorhome for towing.
I looked up the PN. two notes;
1) it says: This product has been replaced by:

WIRING KIT. Trailer Tow.
Part Number: 82216358AB

2) I was ready to call BS on the tech, but then I read this in the description:
This wiring harness connects the vehicle to the towing vehicles 7 way trailer connector. Includes a under hood wiring disconnect and is engineered to work with your vehicle's body computer and operates the taillights..

SO you need to play with underhood wiring and it works with the computer?

Starting to sound like this thing may be responsible for your issues.

First thing I would do is remove everything and see if the troubles continue. If it does, then you know it was something with the part or installation. If it does not continue, I'd take it back to the dealer (or a different one) and tell explain the issue. No need to mention the wiring kit.

Who did the install?
 

Doubleaaron

Well-Known Member
Joined
Apr 18, 2019
Messages
56
Reaction score
39
Location
New Mexico
Vehicle(s)
2019 Rubicon JLU
I have been having issues since new that the "aux switches unavailable, battery charging" displays every morning leaving the house and every evening when leaving work.
They even had to install a new battery the day I went to look at it.
The Engine Stop/Start NEVER stops the engine anymore.
The R/R LED tail light has been delayed turning on in the morning or not lighting up at all.
I dropped it off at Beaman Dodge In Murfreesboro, TN and they are telling me that they will not look at any of these issues because of the Mopar 82215382AB Towed Vehicle harness being installed.
They are saying that the system isn't programmed for this and it's putting too much load on the system.
I explained to them that this system does nothing more than disconnect power from the tail lights while hooked up to a motorhome for towing.
They still refuse to even look at it.
They also told me that this isn't a factory towing package so they can't fix anything under warranty. It IS a factory towing package but I installed a longer receiver hitch to clear my spare tire.
Their reasoning is that I've modified the vehicle.

What are my options here?
Are we not allowed to change anything on our Wranglers because it's now modified and they won't fix anything under warranty?
Anybody else having issues like this? Do I have to remove everything that was changed or added back to stock just for them to look at it?
I'm not sure what I'm supposed to do now if I get a ticket for the tail light?

Any advice?
I also added the mopar hitch and wiring, and had dealer install aux switch package. Dealer had to reflash the computer for both instances so the computer would recognize the add ons.
I am getting similar issues, but my light is ok. Been putting my battery on a charger for now, fixes the problem for a few days. Eventually will need to replace the battery.
 

missionale

Well-Known Member
First Name
Ron
Joined
Nov 19, 2020
Messages
84
Reaction score
128
Location
San Jose, CA
Vehicle(s)
2020 JLU
agreed that, although it is a factory tow kit, it was purchased and installed separately and was not part of the OEM delivery. The dealer cannot address issues if a customer has installed the kit themselves so best to uninstall, check, then reinstall.
 

brennaman

Well-Known Member
First Name
Phil
Joined
Jul 5, 2021
Messages
153
Reaction score
240
Location
MO
Vehicle(s)
2009 WK 2014 JK, 2021 JLR snazzberry
Occupation
damn near retired
Wow, curious how this turns out. That was going to be one of my winter projects on the Jeep. I don't mind having it reflashed if I install it, but I sure hope it does not screw it up by installing.
 
OP
OP
MaxD

MaxD

Member
First Name
Rob
Joined
Jun 8, 2020
Messages
10
Reaction score
8
Location
Eagleville TN
Vehicle(s)
2019 Wrangler Sport S
Occupation
Maintenance Manager
Let me clear some things up on this.
Factory Tow Package (from the factory) was in when I bought it (aux switches and all).

Mopar "Towed Vehicle" harness installed. this disconnects the tail lights via relays to prevent any voltage back feed into the factory control system when flat towing behind a motorhome.

There are NO electronics hookups into the body harness except for plugging into the tail lights themselves.
The NEW part number sounds like a completely different hook up with the disconnect under the hood.
They had to tear out half of the interior to run all of the wiring for the P/N I purchased (only one available at the time).

So, NO relays with 12 volts on them from a Motorhome, would send a normal signal (normally closed relay) back to the tail lights.

I explained to them that when the Mopar harness was disconnected, the tail light still did not light.
They don't care.
 

TheRaven

Well-Known Member
First Name
Kevin
Joined
Oct 22, 2020
Messages
551
Reaction score
697
Location
Reading, Pennsylvania
Vehicle(s)
2021 JLU 80th, 2020 Challenger Scat Pack, 2010 Tahoe Z71
Let me clear some things up on this.
Factory Tow Package (from the factory) was in when I bought it (aux switches and all).

Mopar "Towed Vehicle" harness installed. this disconnects the tail lights via relays to prevent any voltage back feed into the factory control system when flat towing behind a motorhome.

There are NO electronics hookups into the body harness except for plugging into the tail lights themselves.
The NEW part number sounds like a completely different hook up with the disconnect under the hood.
They had to tear out half of the interior to run all of the wiring for the P/N I purchased (only one available at the time).

So, NO relays with 12 volts on them from a Motorhome, would send a normal signal (normally closed relay) back to the tail lights.

I explained to them that when the Mopar harness was disconnected, the tail light still did not light.
They don't care.
Go to a different dealer.

And thanks for clarifying.
 

JLUW75

Well-Known Member
First Name
Eddie
Joined
Aug 26, 2021
Messages
339
Reaction score
362
Location
Tucson
Vehicle(s)
2021 JLUW
Occupation
Engineer
I have been having issues since new that the "aux switches unavailable, battery charging" displays every morning leaving the house and every evening when leaving work.
They even had to install a new battery the day I went to look at it.
The Engine Stop/Start NEVER stops the engine anymore.
The R/R LED tail light has been delayed turning on in the morning or not lighting up at all.
I dropped it off at Beaman Dodge In Murfreesboro, TN and they are telling me that they will not look at any of these issues because of the Mopar 82215382AB Towed Vehicle harness being installed.
They are saying that the system isn't programmed for this and it's putting too much load on the system.
I explained to them that this system does nothing more than disconnect power from the tail lights while hooked up to a motorhome for towing.
They still refuse to even look at it.
They also told me that this isn't a factory towing package so they can't fix anything under warranty. It IS a factory towing package but I installed a longer receiver hitch to clear my spare tire.
Their reasoning is that I've modified the vehicle.

What are my options here?
Are we not allowed to change anything on our Wranglers because it's now modified and they won't fix anything under warranty?
Anybody else having issues like this? Do I have to remove everything that was changed or added back to stock just for them to look at it?
I'm not sure what I'm supposed to do now if I get a ticket for the tail light?

Any advice?
seems to me that they are trying to cover for their ineptness by making up excuses. If you installed factory OEM parts then there should be no issues. If the installation was done by a professional then that is fine. Maybe if you want to remove the harness to see if the issue will still be there, then that is one way to rule out the towing harness being the culprit.
 

old mike

Well-Known Member
First Name
mike
Joined
Jan 13, 2021
Messages
134
Reaction score
271
Location
in the west
Vehicle(s)
little red 2021 JLR (Ruby J. L. Tudor)
I'd think about moving out of Tennessee. Things have been going a little strange there and it may be impacting the Jeep dealers.
 

ECP

Well-Known Member
First Name
Peter
Joined
Sep 30, 2021
Messages
187
Reaction score
151
Location
FL, NC, or out of the country
Vehicle(s)
21 JLURD
Let me clear some things up on this.

There are NO electronics hookups into the body harness except for plugging into the tail lights themselves.
The NEW part number sounds like a completely different hook up with the disconnect under the hood.
They had to tear out half of the interior to run all of the wiring for the P/N I purchased (only one available at the time).
I'm confused. If it only plugs into the tail lights, why did they need to tear out half the interior? Who is 'they'? If the install is that complex, then the chances of something going wrong on install is higher.

Here is the link I was using: https://www.factorychryslerparts.com/products/WIRING-TOWING/13332030/82215382AB.html
 

CMTAZ

Well-Known Member
Joined
Oct 9, 2021
Messages
92
Reaction score
53
Location
Phoenix
Vehicle(s)
2020 JLU Willy's
What are my options here?
Are we not allowed to change anything on our Wranglers because it's now modified and they won't fix anything under warranty?
Anybody else having issues like this? Do I have to remove everything that was changed or added back to stock just for them to look at it?
I'm not sure what I'm supposed to do now if I get a ticket for the tail light?

Any advice?
Also, try opening a case with Jeep.

My 2020 JLU willy's had a start/stop issue. Dealer #1 replaced Aux Battery & IBS sensor (1st visit). It worked for 1 day. Dealer #1 charged primary battery, it worked for 1 day (2nd visit). Dealer #1 would NOT replace the primary battery as they said it tested normal.

Lost confidence in Dealer #1, opened case with Jeep.

Dealer #2 replaced the IBS sensor (again) (1st visit) and again it worked for 1 day. Jeep spoke with Dealer #2, primary battery replaced (2nd visit)- been working ever since.
 

four low

Well-Known Member
Joined
Feb 1, 2017
Messages
2,506
Reaction score
2,831
Location
central New York
Vehicle(s)
2018 JL
If you can contact "Jeep Cares" on this, maybe they can help.
There's a " Special" number, maybe Rhinebeck will chime in on this, thinking 1-800-992-1997 , or 1-866-362-2146. Nothing to lose at this point
 

brennaman

Well-Known Member
First Name
Phil
Joined
Jul 5, 2021
Messages
153
Reaction score
240
Location
MO
Vehicle(s)
2009 WK 2014 JK, 2021 JLR snazzberry
Occupation
damn near retired
I'd think about moving out of Tennessee. Things have been going a little strange there and it may be impacting the Jeep dealers.
Kinda curious, what are you talking about? The damn world is pretty strange right now, what have you seen that is more so in TN?
 

mwilk012

Well-Known Member
Joined
Mar 10, 2018
Messages
5,125
Reaction score
4,757
Location
Oklahoma
Vehicle(s)
2018 Ocean Blue JLU Rubicon
Also, try opening a case with Jeep.

My 2020 JLU willy's had a start/stop issue. Dealer #1 replaced Aux Battery & IBS sensor (1st visit). It worked for 1 day. Dealer #1 charged primary battery, it worked for 1 day (2nd visit). Dealer #1 would NOT replace the primary battery as they said it tested normal.

Lost confidence in Dealer #1, opened case with Jeep.

Dealer #2 replaced the IBS sensor (again) (1st visit) and again it worked for 1 day. Jeep spoke with Dealer #2, primary battery replaced (2nd visit)- been working ever since.
This doesn’t sound like it was worth the headache, would have been rather simple to fix at home.
 
Advertisement

Icon Vehicle Dynamics
 
Advertisement
Top