Music Skips When Connected via USB?

Cwd651

Member
Joined
Jul 23, 2021
Messages
7
Reaction score
5
Location
Wisconsin
Vehicle(s)
2021 Willys
Occupation
Technical Service
I just picked up a brand new ‘21 Willys 4 days ago that was made earlier this month (7/21) with the upgraded Alpine premium audio system and 7” uconnect 4. Noticed this same issue already, drives me crazy, tried all different high quality cords in every plug and skips on them all. Have tried it with iPhone 6s, 11, & 8 plus, all do it. I saw a post from user Brian417 on July 3rd that had uconnect customer service told him there’s a new software update that didn’t show on uconnect website under his vin number, I replied to that post waiting to hear if that resolved the issue and what version number they gave him.
Advertisement

 

thinarrow

Member
Joined
May 25, 2021
Messages
8
Reaction score
3
Location
New Jersey
Vehicle(s)
Jeep Wrangler Sport
I've gone to the dealer for my 2021 JL 7 inch (who said it was a uConnect/Carplay/iPhone IOS compatibility issue and to wait for the next update) - still waiting. I've spoken with Jeep and they also said there's nothing more they can do except wait for the next software update. Everything from replacing cables to disconnecting fuses and resetting the phone and settings were done. For me, it does seem that the CarPlay music skipping starts around 15-20 minutes in and tends to go away after 10 minutes of skipping though.

It's definitely a CarPlay issue - I connected my iPad (which doesn't go through CarPlay) to the dash USB , and the music played fine through the Media app in uConnect did not skip.
 

KevinR

Member
First Name
Kevin
Joined
Dec 7, 2020
Messages
7
Reaction score
18
Location
Central Florida
Vehicle(s)
JL Rubicon
I had a similar problem, try this: when you have a skip or fade out of source, turn the volume up During the pause. In my case it was the navigation app giving turn directions at a ”0” volume level. For some reason my phone always kicked into Waze and would give warning messages, even if no destination was selected. Just a shot at your problem. Good luck.
 

Cwd651

Member
Joined
Jul 23, 2021
Messages
7
Reaction score
5
Location
Wisconsin
Vehicle(s)
2021 Willys
Occupation
Technical Service
I've gone to the dealer for my 2021 JL 7 inch (who said it was a uConnect/Carplay/iPhone IOS compatibility issue and to wait for the next update) - still waiting. I've spoken with Jeep and they also said there's nothing more they can do except wait for the next software update. Everything from replacing cables to disconnecting fuses and resetting the phone and settings were done. For me, it does seem that the CarPlay music skipping starts around 15-20 minutes in and tends to go away after 10 minutes of skipping though.

It's definitely a CarPlay issue - I connected my iPad (which doesn't go through CarPlay) to the dash USB , and the music played fine through the Media app in uConnect did not skip.
Thanks, at least not being alone with the problem offers some sanity. Mine also starts 20 minutes in or so, haven’t noticed if it stops after a bit because my OCD kicks in and I futz with it immediately. I’ll post back if I get any updates.
 

TravisRogers

Well-Known Member
First Name
Dan
Joined
Jun 19, 2018
Messages
209
Reaction score
363
Location
Annapolis, MD
Vehicle(s)
2018 Jeep Wrangler JL Sahara
Here’s the fix. Make sure you get the one with electronic shock protection. Also, use the tape adaptor instead of the FM transmitter. It sounds better. Should fix most of your skipping.
49E9B3B3-72C1-4BD4-BBFF-BB40D9142177.jpeg
 
Advertisement

PSC Motorsports
 
Advertisement
Top