Metalcloak Drag link and Tie rod installation questions

hardrock_sea

Active Member
First Name
John
Joined
Jun 22, 2020
Messages
25
Reaction score
34
Location
WA
Vehicle(s)
JKUR
I installed the Metalcloak drag link and tie rod over the weekend, and had to say their instructions are not the best...
After installation, they are way too close to each other. When turning all the way to the driver side, they are touching each other!
I have torqued down the two ends already. Now do I need to loosen the nut, replace the rubber boots, and rotate the bend to make it face more forward? The stock drag link seems to bend more than Metalcloak.

Thanks a bunch!

1627873181457.png

1627873246988.png

1627873279519.png
Advertisement

 
OP
OP

hardrock_sea

Active Member
First Name
John
Joined
Jun 22, 2020
Messages
25
Reaction score
34
Location
WA
Vehicle(s)
JKUR
Thank you!

I was able to loosen the jam nuts and reposition the bend. I ran into more problems though and just reached out the Metalcloak customer support. Maybe someone here had some experience and can help answer too.

1. When turning the steering wheel all the way to the passenger side, there is loud squeaking noise. I suspect it is coming from the tie rod. It is in the video here: At the end of the video, you can hear when I twist the tie rod, there was some metal noise. I have already pumped more grease into it, but the joint felt very dry.

2. What is the proper length for the sections on the drag link? After straightening the steering wheel, below is what it looks like. The drag link is about 1.5" longer than the stock Rubicon drag link it replaced.

3. Jam nuts are so hard to work with and how do you properly tighten them?

1627966435153.png
 
Advertisement

Next Venture Motorsports
 
Advertisement
Top