Loss of power steering and all warning lights cycle through

cjtexas

New Member
First Name
Chuck
Joined
Aug 14, 2020
Messages
1
Reaction score
0
Location
Texas
Vehicle(s)
2019 JLU Rubicon
Hi, have been experiencing same issue, now in the shop for the third time. Long story short--it happened first time on the highway--loosing power steering and throttle power is not fun at 60mph. That was around 2000 miles. Dealer service said there was a connector that had loose pins behind the firewall passenger side but i could not get any more details. It happened again around 12,000 miles, now just happened at 16,000. Fortunately this time i was only reversing out of my garage. I took a video of the dash while it was happening. My dealer has it now but of course never seen/heard anything like it. So if anyone has had this issue and found any fixes, would appreciate to hear about it. I will ask the service guys to check the CAN connector behind the A-pillar as mentioned in Albertabackroad's reply.
Advertisement

 

CRZYCDN

Well-Known Member
First Name
Matthew
Joined
Dec 14, 2018
Messages
97
Reaction score
18
Location
St-Lazare
Vehicle(s)
2018 JL Rubicon
The truck spent a couple weeks at the dealer... they replace the main wire harness across the firewall, ABS module, security gateway (it locked them out after the harness change), power steering pump, then finally the AUX battery (they said they loaded tested early in the process with no failure...but then I urged them to test again and it failed...)

Unfortunately they also broke a couple clips on the dash panel under the steering wheel... and the clip on the glove box that attaches the "soft open" feature.

I will need to call them back as I just discovered this when installing the break controller.

Wish Canada had @JeepCares
 

J63mcn

New Member
First Name
John
Joined
May 2, 2021
Messages
3
Reaction score
0
Location
Illinois
Vehicle(s)
2018 Jeep Wrangler JL
My 2018 jl is back at the dealer for the third time with this issue. The first time the technician told me it was a low voltage condition and I should trickle charge my battery. The next day I lost power steer while driving and having most of the dashboard lights illuminate. This time I took pictures of the dash messages and brought them to the dealer, I was told probably corrosion on a ground wire after having the car over a week. When I returned this time telling them about the harness rub everyone is talking about, I was told I don’t have that harness? They replaced the abs module, when I asked if it was the problem they wouldn’t say yes. Before I could get the car out of there it acted up locking the shifter, now they think there might be a short, frustrating!!!!
 

Anieves72

Active Member
First Name
Angel
Joined
Jun 14, 2019
Messages
36
Reaction score
0
Location
Streamwood, Illinois
Vehicle(s)
2018 Jeep Wrangler Sahara JL
Occupation
Contractor
Hi, have been experiencing same issue, now in the shop for the third time. Long story short--it happened first time on the highway--loosing power steering and throttle power is not fun at 60mph. That was around 2000 miles. Dealer service said there was a connector that had loose pins behind the firewall passenger side but i could not get any more details. It happened again around 12,000 miles, now just happened at 16,000. Fortunately this time i was only reversing out of my garage. I took a video of the dash while it was happening. My dealer has it now but of course never seen/heard anything like it. So if anyone has had this issue and found any fixes, would appreciate to hear about it. I will ask the service guys to check the CAN connector behind the A-pillar as mentioned in Albertabackroad's reply.
I'm having this issue now 3rd time going to dealer, did you ever get yours fixed
 

Anieves72

Active Member
First Name
Angel
Joined
Jun 14, 2019
Messages
36
Reaction score
0
Location
Streamwood, Illinois
Vehicle(s)
2018 Jeep Wrangler Sahara JL
Occupation
Contractor
My 2018 jl is back at the dealer for the third time with this issue. The first time the technician told me it was a low voltage condition and I should trickle charge my battery. The next day I lost power steer while driving and having most of the dashboard lights illuminate. This time I took pictures of the dash messages and brought them to the dealer, I was told probably corrosion on a ground wire after having the car over a week. When I returned this time telling them about the harness rub everyone is talking about, I was told I don’t have that harness? They replaced the abs module, when I asked if it was the problem they wouldn’t say yes. Before I could get the car out of there it acted up locking the shifter, now they think there might be a short, frustrating!!!!
I'm having this issue now 3rd time going to dealer, did you get yours fixed.
 

bam9382

Well-Known Member
Joined
Jan 4, 2019
Messages
75
Reaction score
20
Location
Texas
Vehicle(s)
2018 Jeep Wrangler Rubicon
A "short" = wiring harness / wiring issue... Try a different dealer, sounds like they are incompetent
 
Advertisement

PSC Motorsports
 
Advertisement
Top