lagging acceleration and major mpg loss

  1. redelses

    redelses Well-Known Member

    Vehicle(s):
    2018 wrangler JL sport S
    Joined:
    May 29, 2018
    Location:
    UT
    Posts:
    120
    Liked:
    85
    Have a sport s, manual 6sp, and notice sometimes that the acceleration gets really sluggish to the point that I have to double check that the e-brake is off. I can usually climb hills on a highway in 4th or 5th when above 50mph, but this time had to go to 3rd most of the time to climb even the slightest hills. Pick up from a stop was also clearly impacted. No lights on the dash came on.
    Happened this weekend on a road trip we do frequently. Usually get 23-24mpg on that trip (all 55-65mph), and this time when I noticed the sluggish acceleration, I only got 19mpg fuel efficiency. As it was going along, I checked the other stats I have access too. Tire pressure same as always (around 37psi cold), engine temps etc seemed fine. I did notice that my battery usually shows 13.9-14.2 V, and this time it was jumping around a lot from 13.7-13.9V. It's been 100 degrees for a few months, so no change in temp from other days/trips. It is intermittent, though, and the next day I was back at the 23-24mpg area and acceleration seemed fine. Can't tell if this is a mechanical or electrical issue.
    Just wanted to see if anyone else has experience this? I know there is a post on a JLUR essentially losing all power for a minute but then kicks back in, but haven't seen any resolution to that.
    Any thoughts? I will be bringing it to the dealer soon, but as it is intermittent, and our dealer service is so overcrowded, I don't anticipate anything besides "we couldn't repeat the problem".
    Thanks!
     
  2. OldGuyNewJeep

    OldGuyNewJeep Well-Known Member

    Vehicle(s):
    2018 Wrangler JL, 2016 Yukon XL
    Joined:
    Sep 21, 2017
    Location:
    CT
    Posts:
    2,084
    Liked:
    3,185
    Sounds like the engine can’t breathe - clogged exhaust? Failed sensor? Take it in ASAP.
     
  3. OP
    OP
    redelses

    redelses Well-Known Member

    Vehicle(s):
    2018 wrangler JL sport S
    Joined:
    May 29, 2018
    Location:
    UT
    Posts:
    120
    Liked:
    85
    that's kind of how it feels, but would have expected the engine light to come on if oxygen or exhaust weren't running correctly. but that might imply a sensor isn't working. will be replacing the air filter today too. thanks!
     
  4. OP
    OP
    redelses

    redelses Well-Known Member

    Vehicle(s):
    2018 wrangler JL sport S
    Joined:
    May 29, 2018
    Location:
    UT
    Posts:
    120
    Liked:
    85
    UPDATE - replaced air filter, completely new car! acceleration is what I would expect, mpg back to normal. I did replace with a K&N and expect a different with that alone, but it's a completely different engine compared to a week ago. The stock filter had lots of junk it in - dirt, possibly paint particles, and who knows what else. But so far it feels like it might be back!
     
    ArmorAPLarry, mer43 and ChattVol like this.
Loading...

Share This Page