JL Sport Apple CarPlay connection issue

nositting

Well-Known Member
Joined
Nov 17, 2018
Messages
128
Reaction score
42
Location
PA
Vehicle(s)
19 JLUS
Don't know if it's been said here yet but I was having an issue with Carplay when I was using the USB port in center console. I now use the one under the radio and do not have any more issues with Carplay disconnecting.
Same.
sometimes my center console works just fine. Other times it'll charge but I can't get Carplay to work. I must admit, I haven't really done anything about it because it's not a huge concern for me.





Advertisement

 

Grooster

Well-Known Member
First Name
Greg
Joined
Aug 23, 2019
Messages
62
Reaction score
59
Location
Wichita, Kansas
Vehicle(s)
2019 Jeep Wrangler Unlimited Sahara, 2016 Jeep Cherokee Latitude
It seems to me that when a notification comes through on my phone that isn’t CarPlay related/supported, I get kicked out. I noted which apps were the cause and dialed back their notification privileges. That seems to help as the interrupts have lessened greatly.

While the dash USB connection seems to work better than the console, I have left my cable plugged into the console port as a matter of convenience. Not a fan of leaving a cable plugged into the dash.
 

NeoMaximuz

Well-Known Member
First Name
Abraham
Joined
Sep 21, 2018
Messages
87
Reaction score
108
Location
Brownsville, TX
Vehicle(s)
2019 Sting Gray Unlimited Rubicon JL
Same.
sometimes my center console works just fine. Other times it'll charge but I can't get Carplay to work. I must admit, I haven't really done anything about it because it's not a huge concern for me.
I have the exact same problem, and feel the same way. It's a bit inconvenient to be putting my phone in the center console every time I get in, but for long trips, I'd rather have it out of the way. However, it won't stay connected. It works just fine under the dash though.
 

Du0377

Well-Known Member
First Name
Bobby
Joined
Oct 13, 2019
Messages
193
Reaction score
42
Location
Phoenix, Arizona
Vehicle(s)
2019 Jeep Wrangler JLU Sport S
Occupation
Medical Student
So mine was acting up so i turned off the jeep, pull the fuse to the usb port and let it sit for 20 min. Plugged the fuse back in and it has worked fine. Maybe coincidence I don’t know but it worked.
 

Hkyjeeper88

Member
Joined
Sep 2, 2019
Messages
12
Reaction score
2
Location
Illinois
Vehicle(s)
2020 JLUS
I've been having issues with mine lately as well. The screen glitches/shakes at times when I have the Car Play screen up. Yesterday the screen was completely black for about 2 minutes before it finally came on. I am using the original iphone cord too
 

K-nuk

Well-Known Member
First Name
Scott
Joined
Jun 30, 2019
Messages
67
Reaction score
23
Location
Florida
Vehicle(s)
JLUR, CJ7
So mine was acting up so i turned off the jeep, pull the fuse to the usb port and let it sit for 20 min. Plugged the fuse back in and it has worked fine. Maybe coincidence I don’t know but it worked.
That’s interesting. Can you tell me which fuse? I’m approaching 1 year with my JLUR now and I’m still having issues. My situation:
- using genuine Apple cables (both old style USB and new type C)
- iPhone 8+ (tried 3 different iPhones)
What happens:
- intermittently Apple CarPlay disappears as if no phone is plugged it. Sometimes it returns after a few seconds, other times it is gone for days.

Dealer was no help; said “worked fine when I tried my phone” (... yes that is the behavior of an intermittent problem and does not prove that the problem doesn’t exist!)

#Jeepcare was no help either, they wanted me to find alternative phones, Apple and android, and use them in place of my own to see if the problem showed up there too. Really? Really?

i’ve now bought a 67 designs phone mount as my back up for the times that CarPlay shuts off — which is weekly...

sooooooooo frustrating!
 

EugeneTheJeep

Well-Known Member
First Name
Mike
Joined
Jul 13, 2019
Messages
105
Reaction score
135
Location
MN
Vehicle(s)
2019 JL Rubicon
That’s interesting. Can you tell me which fuse? I’m approaching 1 year with my JLUR now and I’m still having issues. My situation:
- using genuine Apple cables (both old style USB and new type C)
- iPhone 8+ (tried 3 different iPhones)
What happens:
- intermittently Apple CarPlay disappears as if no phone is plugged it. Sometimes it returns after a few seconds, other times it is gone for days.

Dealer was no help; said “worked fine when I tried my phone” (... yes that is the behavior of an intermittent problem and does not prove that the problem doesn’t exist!)

#Jeepcare was no help either, they wanted me to find alternative phones, Apple and android, and use them in place of my own to see if the problem showed up there too. Really? Really?

i’ve now bought a 67 designs phone mount as my back up for the times that CarPlay shuts off — which is weekly...

sooooooooo frustrating!
Exact same thing here. Tried different phones and cables. Dealer tried a software update that didn’t work and says they can’t do anything more. I’ve been considering the 67d mount as well...

CarPlay work perfectly in my Ford. What a shame especially with such an expensive system.
 

oceanblue2019

Well-Known Member
First Name
John
Joined
Apr 13, 2019
Messages
2,394
Reaction score
3,299
Location
Maryland
Vehicle(s)
2019 JLUR 2.0L Auto
Same.
sometimes my center console works just fine. Other times it'll charge but I can't get Carplay to work. I must admit, I haven't really done anything about it because it's not a huge concern for me.
Same problem.

Today was lucky as had kids with me so a total of 3 iPhones. Mine was connected to center console, and suddenly CarPlay disconnected. Unplugged and re-plugged and it came back for maybe 60 seconds and disconnected again. The CarPlay icon in the lower right of the screen goes away when this happens.

So I plugged in my daughters phone and same thing - no connection. Tried my sons - no connection.

Then moved the cable from center console to dash USB and worked fine, no issues.

Moved cable back to center console and none would work.

Now home and after jeep being off for several hours the central console connection works again....
 

Du0377

Well-Known Member
First Name
Bobby
Joined
Oct 13, 2019
Messages
193
Reaction score
42
Location
Phoenix, Arizona
Vehicle(s)
2019 Jeep Wrangler JLU Sport S
Occupation
Medical Student
If you pop the fuse box cover off there is a diagram I cant remember the exact fuse number but I think in was in the 60’s not positive though. It is the fuse to the usb port not the radio fuse itself. It will say right on the diagram which fuse it is.
 

nositting

Well-Known Member
Joined
Nov 17, 2018
Messages
128
Reaction score
42
Location
PA
Vehicle(s)
19 JLUS
I was having trouble with USB #2 so I pulled fuse #11 for a few minutes and everything works great now. I'm pleased and relieved.
 

K-nuk

Well-Known Member
First Name
Scott
Joined
Jun 30, 2019
Messages
67
Reaction score
23
Location
Florida
Vehicle(s)
JLUR, CJ7
Exact same thing here. Tried different phones and cables. Dealer tried a software update that didn’t work and says they can’t do anything more. I’ve been considering the 67d mount as well...

CarPlay work perfectly in my Ford. What a shame especially with such an expensive system.

So what next @JeepCares ? I just got back from a trip to 3 cities, rented Fords and Nissans and CarPlay worked perfectly with my OEM Apple cable and my amazon aftermarket cable. CLEARLY THIS IS AN ISSUE WITH MY JEEP!

I am going to bring it in for service in 2 weeks. @JeepCares can you assist and get dealer to go beyond just having one of their guys plug in his own phone and proclaim it “works”? That is what happened last time.
 

K-nuk

Well-Known Member
First Name
Scott
Joined
Jun 30, 2019
Messages
67
Reaction score
23
Location
Florida
Vehicle(s)
JLUR, CJ7
So what next @JeepCares ? I just got back from a trip to 3 cities, rented Fords and Nissans and CarPlay worked perfectly with my OEM Apple cable and my amazon aftermarket cable. CLEARLY THIS IS AN ISSUE WITH MY JEEP!

I am going to bring it in for service in 2 weeks. @JeepCares can you assist and get dealer to go beyond just having one of their guys plug in his own phone and proclaim it “works”? That is what happened last time.
So what next @JeepCares ? I just got back from a trip to 3 cities, rented Fords and Nissans and CarPlay worked perfectly with my OEM Apple cable and my amazon aftermarket cable. CLEARLY THIS IS AN ISSUE WITH MY JEEP!

I am going to bring it in for service in 2 weeks. @JeepCares can you assist and get dealer to go beyond just having one of their guys plug in his own phone and proclaim it “works”? That is what happened last time.
Oh, btw, when I got back to the airport guess what... CarPlay didn’t work. Then, 15 minutes into my drive it came on! Hurray! Then 2 minutes later it went off. It continued to flicker on and of for a while longer. Talk about distracted driving! Even when I give up on CarPlay and use Bluetooth, if I’m charging my phone it will randomly activate CarPlay and cut off my audio and my GPS map (Waze) on the phone screen turns off. Sooo distracting!

If I crash because of this I’m sure some clever lawyer will figure out how to sue FCA over their defective Uconnect (not that an outcome like that is what I want...)

I just want my CarPlay to work @JeepCares !
 

K-nuk

Well-Known Member
First Name
Scott
Joined
Jun 30, 2019
Messages
67
Reaction score
23
Location
Florida
Vehicle(s)
JLUR, CJ7
Oh, btw, when I got back to the airport guess what... CarPlay didn’t work. Then, 15 minutes into my drive it came on! Hurray! Then 2 minutes later it went off. It continued to flicker on and of for a while longer. Talk about distracted driving! Even when I give up on CarPlay and use Bluetooth, if I’m charging my phone it will randomly activate CarPlay and cut off my audio and my GPS map (Waze) on the phone screen turns off. Sooo distracting!

If I crash because of this I’m sure some clever lawyer will figure out how to sue FCA over their defective Uconnect (not that an outcome like that is what I want...)

I just want my CarPlay to work @JeepCares !
Well CarPlay failed AGAIN so I drove straight to the dealer and had them check and document it. I have their report in hand now saying CarPlay not working.

@JeepCares what can we do now? I need your help. The dealer told me that uconnect only guarantees compatibility with IOS 11.3 which is 2 years old.

HELP!!!
 

Advertisement




Mac Haik CDJR Georgetown
 



Advertisement
Top