Issues installing Tazer JL Mini

alexccs

Member
First Name
Alex
Joined
Sep 9, 2021
Messages
15
Reaction score
4
Location
Tampa, FL
Vehicle(s)
2021 Unlimited Rubicon
All,

I need some help installing the Tazer JL Mini on 2021 JL Rubicon.
This are the steps I’ve taken and it’s not working…..


1. Install Z Automotive Programmer
2. Update firmware to the the latest one, 11.13.1
3. Unplugged the 2 connectors behind the knee panel
4. Connect the 2 connectors to the Tazer JL Mini. (FYI - The Tazer JL Mini doesn’t light up when plugging the 2 connectors)
5. Turn ignition to Run position, but the radio nor the 8.4 screen lights up
6. I was able to go to the Audio menu on the dashboard, but nothing works, when pressing the 2 buttons on the wheel.
Has anybody experienced any of this issues?

Thanks in advanced.
Advertisement

 

JasonInDLH

Well-Known Member
First Name
Jason
Joined
Jan 4, 2021
Messages
575
Reaction score
529
Location
MN
Vehicle(s)
21 JLUR, 15 Yukon Denali
Occupation
I’d Rather Talk Jeep’s!
All,

I need some help installing the Tazer JL Mini on 2021 JL Rubicon.
This are the steps I’ve taken and it’s not working…..


1. Install Z Automotive Programmer
2. Update firmware to the the latest one, 11.13.1
3. Unplugged the 2 connectors behind the knee panel
4. Connect the 2 connectors to the Tazer JL Mini. (FYI - The Tazer JL Mini doesn’t light up when plugging the 2 connectors)
5. Turn ignition to Run position, but the radio nor the 8.4 screen lights up
6. I was able to go to the Audio menu on the dashboard, but nothing works, when pressing the 2 buttons on the wheel.
Has anybody experienced any of this issues?

Thanks in advanced.
The Tazer should blink as soon as you hook it up (even with ignition in the off position). Try unplugging it and plug it back in firmly and see if the Tazer starts blinking.
 
OP
OP
alexccs

alexccs

Member
First Name
Alex
Joined
Sep 9, 2021
Messages
15
Reaction score
4
Location
Tampa, FL
Vehicle(s)
2021 Unlimited Rubicon
The Tazer should blink as soon as you hook it up (even with ignition in the off position). Try unplugging it and plug it back in firmly and see if the Tazer starts blinking.
Honestly, I’ve tried about 4 times and it never blinked.
it did blinked though when i hooked it to my laptop via USB cable.
 

Rhinebeck01

Well-Known Member
Joined
May 9, 2018
Messages
7,989
Reaction score
10,204
Location
.
Vehicle(s)
2018 2dr. Rubi
Honestly, I’ve tried about 4 times and it never blinked.
it did blinked though when i hooked it to my laptop via USB cable.
@alexccs

Did you hook the Tazer JL Mini up to the correct connection points on your 2021 JL?

Perhaps you hooked the Tazer JL Mini up to the connectors for the amp that are similar and that reside just ahead of the security gateway connectors you need to use for the Tazer JL Mini.

If that is not the issue....

You are going to have to contact ZAutomotive in regard to this issue.

You can text Joe @ ZAutomotive and ask him for assistance.... TEXT, Joe at 631-533-3363
He'll get back at you...... usually takes a few hrs. for his reply. Do NOT call this number.

From Z's website.... you can also Form message them there ..
https://www.zautomotive.com/contact-us/

You can also go to the ZAutomotive Facebook page and message them from there.

.
 

Rhinebeck01

Well-Known Member
Joined
May 9, 2018
Messages
7,989
Reaction score
10,204
Location
.
Vehicle(s)
2018 2dr. Rubi
@alexccs

Here is a video that very clearly points out the amplifier connect points and also points out the security gateway and it's connect points that you use with the Tazer JL Mini. As I mentioned I think you may have attached your Tazer JL Mini to the wrong connectors.... you probably attached to the connectors for the amp.

Anyway watch the first few minutes of this video.. NO, I do not recommend the AutoStop Eliminator shown in the video that is used to deal with ESS. For working with ESS, I always recommend the SmartStopStart unit or a Tazer JL Mini.

 
OP
OP
alexccs

alexccs

Member
First Name
Alex
Joined
Sep 9, 2021
Messages
15
Reaction score
4
Location
Tampa, FL
Vehicle(s)
2021 Unlimited Rubicon
@alexccs

Did you hook the Tazer JL Mini up to the correct connection points on your 2021 JL?

Perhaps you hooked the Tazer JL Mini up to the connectors for the amp that are similar and that reside just ahead of the security gateway connectors you need to use for the Tazer JL Mini.

If that is not the issue....

You are going to have to contact ZAutomotive in regard to this issue.

You can text Joe @ ZAutomotive and ask him for assistance.... TEXT, Joe at 631-533-3363
He'll get back at you...... usually takes a few hrs. for his reply. Do NOT call this number.

From Z's website.... you can also Form message them there ..
https://www.zautomotive.com/contact-us/

You can also go to the ZAutomotive Facebook page and message them from there.

.
Thanks for getting back to me. I did already sent them
@alexccs

Did you hook the Tazer JL Mini up to the correct connection points on your 2021 JL?

Perhaps you hooked the Tazer JL Mini up to the connectors for the amp that are similar and that reside just ahead of the security gateway connectors you need to use for the Tazer JL Mini.

If that is not the issue....

You are going to have to contact ZAutomotive in regard to this issue.

You can text Joe @ ZAutomotive and ask him for assistance.... TEXT, Joe at 631-533-3363
He'll get back at you...... usually takes a few hrs. for his reply. Do NOT call this number.

From Z's website.... you can also Form message them there ..
https://www.zautomotive.com/contact-us/

You can also go to the ZAutomotive Facebook page and message them from there.

.
I’ll contact Joe.But I’m pretty sure I’m connecting it to the right place.
55BD59D2-1685-4D4C-B99F-0F2413408D92.jpeg
 

JLPilot

Member
First Name
Chris
Joined
Oct 6, 2021
Messages
10
Reaction score
4
Location
Comifornia
Vehicle(s)
2021 JLUR
Looks like you have the cables installed in the right place. I just went through something similiar. It was entirely aggravating, as I used a Mac and it didn’t work- couldn't/wouldn’t recognize the Taser.. It wasn’t until I switched to a Windows machine that the Windows version of the utility recognized the Taser and updated it, but only to 11.3.0, not the latest, 11.3.1, even though I tried to update it to the latest version 4-5 times. Anyhow, the Taser is awesome and I’ll never drive the Jeep again without it- too many goodies you’re gonna love… I just wish they’d make the programming utility a little less buggy 😊
 
OP
OP
alexccs

alexccs

Member
First Name
Alex
Joined
Sep 9, 2021
Messages
15
Reaction score
4
Location
Tampa, FL
Vehicle(s)
2021 Unlimited Rubicon
Looks like you have the cables installed in the right place. I just went through something similiar. It was entirely aggravating, as I used a Mac and it didn’t work- couldn't/wouldn’t recognize the Taser.. It wasn’t until I switched to a Windows machine that the Windows version of the utility recognized the Taser and updated it, but only to 11.3.0, not the latest, 11.3.1, even though I tried to update it to the latest version 4-5 times. Anyhow, the Taser is awesome and I’ll never drive the Jeep again without it- too many goodies you’re gonna love… I just wish they’d make the programming utility a little less buggy 😊
Thanks for your input. On my side, I’m using a windows machine and it actually took the 11.3.1. When it wasn’t working, i plugged it back in to the windows machine using the USB cable and tried to update to 11.3.1, and it show me that it had the latest firmware already updated.
 

JLPilot

Member
First Name
Chris
Joined
Oct 6, 2021
Messages
10
Reaction score
4
Location
Comifornia
Vehicle(s)
2021 JLUR
Almost sounding like a hardware issue with the Taser if it’s not lit/blinking. I used the recovery portion of the programmer utility and that worked, however my lights were already on/blinking. I’d wait to hear back from ZAutomotive for your next steps.
 
Advertisement

Winjet
 
Advertisement
Top