Is my Tazer JL toast?

BobK

Well-Known Member
First Name
Bob
Joined
May 24, 2018
Messages
388
Reaction score
179
Location
Parker, TX
Vehicle(s)
2018 JL Rubicon Unlimited
Occupation
Semi-Retired
Vehicle Showcase
1
I've had my Tazer in the Jeep for a couple of months now (ver 11.0.3) and was satisfied. But always eager to get more mileage out of my devices, I tired flashing the firmware to 11.0.6 and its been a bit of a disaster.

My first attempt was with my laptop in the Jeep. The Z-Automotive app seemed to recognize the device and I had already downloaded the 11.0.6 firmware file. All seemed to go well and the app screen (using the manual update mode) seemed to process the update. When I went to try and use the device through the usual process, all my existing setting seemed to be gone and there was no menuing through the drivers screen as usual.

Next I removed the device and sme in the house with it. This time the app doesn't actually recognize the device as it no longer shows the version in the area below the Device Connection portion of the screen. Regardless, it does allow me to Flash the device and shows the progress bar. But when I reinstall the Tazer in the Jeep, it is non bueno, no menu, no settings, no nothing.

How can I recover the device from this situation? I have even tried going back to ver 11.0.3 with the same outcome.

Here is step by step, what I'm doing.

Open up the Z app
Plug the Tazer into the USB plug
Click Find on the USB port Device Connection area (Mac version)
It finds the device on usbserial
Nothing changes under Device, Version, Vehicle Identification, and Marriage State
Switch app to Manual Update.
Click "read" - no change
click "select" and choose 11.0.3 or 11.0.6
Click on "Flash"
Says it's installing and then Preparing Update, where it just sits until I click on Connect again.
Then it runs for a few minute 0% - 100%
But when I install back in the Jeep, nothing......
 

DavidArmen

Well-Known Member
First Name
David
Joined
Sep 19, 2020
Messages
784
Reaction score
669
Location
Hollywood, CA
Vehicle(s)
2021 Red JLUR
I just had this happen to me as well. I removed the tazer to update it without first unmarrying. During the update it froze. Now ZPU will not even see the tazer at all and putting it back into my jeep doesn’t work either, I can’t open up the menu in the EVIC, it’s as if it’s not connected to the jeep at all. I can recover it but I’m worried about my marriage status and how that will affect the recovery
 
Advertisement

Next Venture Motorsports
 
Advertisement
Top