Is anyone still having Carplay issues?

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,635
Reaction score
2,283
Location
Auburn Hills, MI
Vehicle(s)
JL
My JL is nearly 2 years old now. Carplay (8.4 inch screen) has cut in and out frequently since I purchased it. I like to use it for WAZE but with it disconnecting and reconnecting every few minutes, it's nearly impossible to use. About 30% of the time, I plug my phone in to the USB (and the phone is unlocked) and the car doesn't even recognize it... nothing happens, even after 10 or 20 minutes. I have changed cables, using an official apple cable made no difference. My fuses are pushed in.

Just wondering if anyone else is having these issues rendering Carplay almost useless or I am in the room alone here?
I have my Jeep for ~4 months. Just started having CarPlay problems. Same issues as yours. Was just about to change the cable to OEM.
Yup same boat....I just use the bluetooth now The carplay is a major letdown!
Hi all,

Same issues from the Android side of the world and I'll tell you it's not related to the cable in many cases. Like the OP said, 10% of the times I start the car it doesn't recognize the phone and will not do so unless I let the car sit off for a while, I don't know why it locks itself out like that.

Also, I have used a ton of cables, from super cheap ones (USB 2.0) to super expensive ones (USB 3.0 and 3.1) and none change the frequency of this happening fyi...
Hi Everyone,
We regret to hear about the infotainment concerns you have been experiencing. If you decide to visit your dealers, please send us a PM. We would be happy to connect you with a Case Specialist to assist.
Alex
JeepCares
Advertisement

 
OP
OP
Chemy350

Chemy350

Well-Known Member
First Name
David
Joined
Feb 7, 2018
Messages
304
Reaction score
398
Location
Atlanta GA
Vehicle(s)
2018 JLUR
Occupation
Mortgage Loan Officer
Hi Everyone,
We regret to hear about the infotainment concerns you have been experiencing. If you decide to visit your dealers, please send us a PM. We would be happy to connect you with a Case Specialist to assist.
Alex
JeepCares

@JeepCares, that's all well and good but I have already visited the dealer several times. They said there is nothing they can do. The software on the Jeep is up to date and everything checks on their end. What are my options at this point?
 

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,635
Reaction score
2,283
Location
Auburn Hills, MI
Vehicle(s)
JL
@JeepCares, that's all well and good but I have already visited the dealer several times. They said there is nothing they can do. The software on the Jeep is up to date and everything checks on their end. What are my options at this point?
Hi David,
Working with a Case Specialist would allow your concern to be documented in our corporate system. Your Case Specialist will also ensure that all available resources are being used to address this. Should you return to your dealer, please let me know.
Alex
JeepCares
 
OP
OP
Chemy350

Chemy350

Well-Known Member
First Name
David
Joined
Feb 7, 2018
Messages
304
Reaction score
398
Location
Atlanta GA
Vehicle(s)
2018 JLUR
Occupation
Mortgage Loan Officer
Update for everyone here. I ordered the USB-C to Lightning cable from Apple and plugged it into my dash under the nav screen. I have used Carplay for about an hour so far with no disconnects!! Sound quality seems to be better as well!! Problem seems to be fixed.
 

jmcdtucson

Well-Known Member
First Name
Jerel
Joined
Jun 17, 2018
Messages
698
Reaction score
652
Location
Tucson, AZ
Vehicle(s)
2018 JLU Sport S
Vehicle Showcase
1
My Android (pixel 2) worked great for a few months. Then it stopped working completely. Now lately it started connecting about 25% of the time. Total crap.
Every teen who rides in my car goes to charge and their iPhone connects every time. Had to buy a data blocking USB connection to stop their phones from taking over the Jeep.
 

Village Idiot

Well-Known Member
First Name
Matthew
Joined
Dec 22, 2019
Messages
48
Reaction score
28
Location
SoCAL
Vehicle(s)
2019 JLUR
I just got back from the dealer with my 3 week old 19 jlur with the 7” standard infotainment touchscreen, not the larger 8.4”. My apple car play has had issues as well. The music cuts out momentarily after music starts and sometimes in the middle of songs. The dealer said they found an update for the uconnect and applied it. Still cuts out while listening to music using a brand new apple standard usb to lightning cable. I guess I can try the usb c to lightning cable. This seems to be a known issue. It is too bad there is not an affordable aftermarket alternative. I would note that music playback is fine using Bluetooth. This is not ideal as navigation and other apps use CarPlay. My iPhone is a new 11 and the CarPlay has no issues in my wife’s vw Tiguan.
 

Iamconstantino

New Member
First Name
Cristian
Joined
Jan 18, 2020
Messages
3
Reaction score
0
Location
El Paso, TX
Vehicle(s)
Jeep Wrangler Sport S 2020
I have a 2 Door JLS that I bought no more than a month ago. A sudden flicker has been bugging me while on CarPlay. Have tried different phones and cables (only apple) already. Has anyone had this problem? Any recommendations?

Thanks.
 

wranglerguyman

Well-Known Member
Joined
Dec 21, 2017
Messages
443
Reaction score
390
Location
Long Island, NY
Vehicle(s)
JLU Rubicon
Update for everyone here. I ordered the USB-C to Lightning cable from Apple and plugged it into my dash under the nav screen. I have used Carplay for about an hour so far with no disconnects!! Sound quality seems to be better as well!! Problem seems to be fixed.

Good to hear. I always find it a superior connection. Type A connectors are old news, unreliable and slow charging. Glad you fixed the problem.

I think others who have similar issues should try this also.
 

Varilux

Well-Known Member
First Name
Pete
Joined
Dec 29, 2018
Messages
299
Reaction score
603
Location
Hickory Creek, TX
Vehicle(s)
2018 Jeep Wrangler Rubicon
Vehicle Showcase
1
I have the 7" system and use an Android (Galaxy S10) connected to the port on the dash. About once per trip to work (a 30 minute drive), the music stops, the screen goes black, then I get a message about the "phone completing its connection." Have waited it out, and that message never resolves itself. The only fix is to unplug and replug the phone (at which point it resumes the music and/or navigation almost immediately). Like others, have tried various cables with no difference. Like others mentioned it to the dealer who checked the software version and said "It's the latest version- should be working fine." It's not related to bumps or anything, because it will often cut off on a perfectly smooth section of road.

Kinda at that "annoying but livable" level right now- if it starts happening multiple times per drive, I'll start connecting with Bluetooth.

The CarPlay feature is awesome when it works- doesn't sound like it works perfectly for very many of us though... Ford's SYNC has gremlins as well (actually even worse than these- one of the main reasons I traded in my Mustang).
 
Advertisement

Done Right LED
 
Advertisement
Top