Insane Audio JL3001 Jeep Head Unit Review

basinite

Well-Known Member
First Name
Chris
Joined
Nov 9, 2019
Messages
179
Reaction score
313
Location
Utah
Vehicle(s)
2020 Willys
That right there would be enough reason for me to not get it...but glad you're liking the unit.

I know what you mean.

Think of all the sales they will miss out on, just due to this one issues. I would think it would be an easy software fix, but they blame iPhone and state iPhones are notorious for this setting dropping off when not in use. Basically, the iPhone turns of wifi-hub when not being used, forcing you to turn it back on manually on your phone.

Might be a b*llshit excuse, but who knows.
Advertisement

 

wolf

Well-Known Member
First Name
Rick
Joined
Oct 17, 2018
Messages
565
Reaction score
558
Location
florida
Vehicle(s)
On my third Rubicon(2dr's 2020, 2015 jetta diesel/2013 mb
Occupation
retired
There is a thing you plug into your



There is a device that plugs into your Jeeps module under the dash, so the Insane Unit and your Jeeps computer talk via Bluetooth. This thing has so much stuff you can display, I've only began to tap the service of its possibilities.

To answer your question; Yes and so much more.

Some examples include;

1. Engine Torque
2. HP at the rear wheels
3. Turbo gauge (if you have the 2.0)
4. Elevation (this is also built into the navigation)
5. Measurements for 0-60 MPH, 1/4, and etc
6. Tons of Temperature readings and engine performance stuff.
7. There is so much you can display, it's almost overwhelming trying to figure out what you need and don't need.

I haven't' counted them, but there are probably 60-70 different things you can display. It's kind of cool because you can customize the gauges, screen layout and etc.

This thing makes the "Off Road" pages on the 8.4 look weak and obsolete.
How about setting a lower threshold for tire pressure?
 

basinite

Well-Known Member
First Name
Chris
Joined
Nov 9, 2019
Messages
179
Reaction score
313
Location
Utah
Vehicle(s)
2020 Willys
How about setting a lower threshold for tire pressure?
It's not like the Tazer, I don't believe you can adjust settings like tire alarm pressures and etc with it.

As far as I can tell, it only monitors parameters coming from the Jeeps computer and displays them for you. Hope that makes sense.
 

Ct_Formula

Well-Known Member
First Name
John
Joined
Feb 9, 2021
Messages
376
Reaction score
395
Location
Orange Ct
Vehicle(s)
2021 Rubicon JL, 2011 JK Sahara
I was seriously looking at the Heigh10 but the lack of running apps on it is a major loss on their part. Being able to run Eq apps, Video playing apps, and pre-amp apps is a big thing for me. In my opinion the Heigh10 looks classier but the apps on the Insane Audio make it more appealing to me. What are the pitfalls on the Insane that I should take into consideration?

So as for storage on it, I know you can do a SD card up to 512gb so do you need the added storage for the $99 that they show on the website as an option? And are their any other options I should look at ordering.

Thanks in advance guys
 

Mendacity

Active Member
First Name
Jim
Joined
Sep 13, 2021
Messages
37
Reaction score
28
Location
Reading, PA
Vehicle(s)
2020 Wrangler Sport
I was seriously looking at the Heigh10 but the lack of running apps on it is a major loss on their part. Being able to run Eq apps, Video playing apps, and pre-amp apps is a big thing for me. In my opinion the Heigh10 looks classier but the apps on the Insane Audio make it more appealing to me. What are the pitfalls on the Insane that I should take into consideration?

So as for storage on it, I know you can do a SD card up to 512gb so do you need the added storage for the $99 that they show on the website as an option? And are their any other options I should look at ordering.

Thanks in advance guys
I will give a rundown of the unit in my limited experience so far in a little bit. I am still changing settings to make the unit run seamlessly at least according to customer service.
 

Ct_Formula

Well-Known Member
First Name
John
Joined
Feb 9, 2021
Messages
376
Reaction score
395
Location
Orange Ct
Vehicle(s)
2021 Rubicon JL, 2011 JK Sahara
I will give a rundown of the unit in my limited experience so far in a little bit. I am still changing settings to make the unit run seamlessly at least according to customer service.
Thanks Jim I also heard that there is "battery drain" issue when installed.

I have that on my JK with the 10" Seicane and I need to but it on a battery charger whenever I lave it in the garage longer than a week. I don't want to recreate that nightmare in the new rig
 

Mendacity

Active Member
First Name
Jim
Joined
Sep 13, 2021
Messages
37
Reaction score
28
Location
Reading, PA
Vehicle(s)
2020 Wrangler Sport
I have a little time so I will give a quick run down as to my process so far.
I have the base trim 2020 wrangler sport with the 5" screen. The wife and I took our old 2001 wrangler sport down to the Outer Banks, NC when she up and died. So we came home with our new girl and bought new and she was the only new vehicle on the lot in Kill Devil Hills. It was a very expensive vacation but that being said we didn't have any choices in trim.
So we were driving with top off and doors off and a great song comes on so I crank the volume and just disappointment. I decide on upgrading the audio right away. I hit up Crutchfield and start looking. I also decide since our girl is new I want something that is OEM compatible. I pull the trigger on a package from MB Quart that replaces all of the speakers and add a few amplifiers and a pre amp. At the same time we also purchased the Insane Audio JL3001.
I pull my baby apart and start swapping speakers/wiring and everything went smoothly until I had no sound. The preamp that comes with the speakers needed to be configured to my jeep by doing sleep cycles since we didn't have the factory OEM amplifier. So we could get tones from the preamp but no music/sound.
As a workaround I used the rca outputs from the head unit to the amps. So the preamp would see output and turn the amps on with remote wire but all sound was coming from the head unit.
At this point if we used bluetooth connection the sound would be really loud and crystal clear, a really nice upgrade. But with carplay the sound just didn't get very loud. I have been in contact with Insane Audio and they have been helpful so far and gave me some settings to switch up to see if I can get the volume out of carplay as well. I have yet to do this but am hoping to fiddle around tonight after work.
I have had issues with locking up/crashing and again I was given a few changes to make to hopefully help me avoid the problems. One of the mentions is to turn off auto updates in playstore. Another is to pay $99 for their module which turns off the ESS start/stop. Honestly that's a little silly as I can just hit the button to turn it off (I just didn't know that I had to).
Yesterday I put the OEM head back in just to do the sleep cycles to configure the preamp so I could have all of the audio processed by that. It came in the speaker package and it's like $280 and I felt like an idiot for paying for it and not using it. So after the sleep cycles it started to work as intended and I moved the rca cables back to that instead of from the Insane head. Carplay is still muted but I am going to make sure that is updated as well as go into settings and make sure it is maxed out (I am thinking it is not by default).
This is way longer than anticipated but if you have any specific questions you can hit me up and I will answer as truthfully as I can.
 

Ct_Formula

Well-Known Member
First Name
John
Joined
Feb 9, 2021
Messages
376
Reaction score
395
Location
Orange Ct
Vehicle(s)
2021 Rubicon JL, 2011 JK Sahara
Yeah let us know how it goes, have you had any battery drain issues?

Android Car is typically a little buggy here and there as I have found out with the Seicane 10" in my JK. But I like how it plays well with Apple products, Google Products and the Play Store Apps. And the video is MUCH clearer / HD compared to the other units on the market.
 

Mendacity

Active Member
First Name
Jim
Joined
Sep 13, 2021
Messages
37
Reaction score
28
Location
Reading, PA
Vehicle(s)
2020 Wrangler Sport
So far the unit seems to shut down properly. I did speak with support about it and put a clamp on ammeter on my main negative cable. There is some small drain but nothing bad. An issue I had honestly I forgot until just now is that with my doors off the unit seemed to not shut down. There is a setting in an app that they use where you choose to shut the unit down when accessory turns off or when doors open as you exit. We put the doors back on after reading their forums and seeing issues before we learned about the actual settings. I am not quite sure why it just doesn't shut down when the accessory power turns off but since making the changes we don't really see a problem.
As since I've been hemmhoraging money on my girl I just forked out another big item which is the Genesis dual battery system with 2 deep cycle batteries so battery drain will no longer be a concern.
 

Ct_Formula

Well-Known Member
First Name
John
Joined
Feb 9, 2021
Messages
376
Reaction score
395
Location
Orange Ct
Vehicle(s)
2021 Rubicon JL, 2011 JK Sahara
So far the unit seems to shut down properly. I did speak with support about it and put a clamp on ammeter on my main negative cable. There is some small drain but nothing bad. An issue I had honestly I forgot until just now is that with my doors off the unit seemed to not shut down. There is a setting in an app that they use where you choose to shut the unit down when accessory turns off or when doors open as you exit. We put the doors back on after reading their forums and seeing issues before we learned about the actual settings. I am not quite sure why it just doesn't shut down when the accessory power turns off but since making the changes we don't really see a problem.
As since I've been hemmhoraging money on my girl I just forked out another big item which is the Genesis dual battery system with 2 deep cycle batteries so battery drain will no longer be a concern.

My JK has the Genesis and I did brand new AGM's in it, a 200 amp alternator and I STILL had the issue.

FYI I went with a NOCO dual bank charger with the quick disconnects to plug her in if it went a week or longer sitting. So freaking annoying.

2021-07-05 12.17.05.jpg


2021-07-05 12.17.13.jpg


2021-07-05 12.17.22.jpg


2021-07-05 13.15.45.jpg


2021-07-05 13.16.36.jpg


2021-07-05 13.16.41.jpg
 

Mendacity

Active Member
First Name
Jim
Joined
Sep 13, 2021
Messages
37
Reaction score
28
Location
Reading, PA
Vehicle(s)
2020 Wrangler Sport
I just about had a heart attack when I saw how much you have on your accessory post. And the need for a 200 amp alternator apart from running a winch what else would you need that for?
 

Ct_Formula

Well-Known Member
First Name
John
Joined
Feb 9, 2021
Messages
376
Reaction score
395
Location
Orange Ct
Vehicle(s)
2021 Rubicon JL, 2011 JK Sahara
I've got a huge Stereo system with 2 10" subwoofers and CB and Ham radios with amplifiers. I made sure everything shuts off when the Jeep is not running, and my draw still goes back to the dang Android head unit.

I never run it all at the same time, its more "toggling" of equipment when running stuff.
 

Mendacity

Active Member
First Name
Jim
Joined
Sep 13, 2021
Messages
37
Reaction score
28
Location
Reading, PA
Vehicle(s)
2020 Wrangler Sport
I don't know if you have found it in the dev settings or not but there's a way to default to either off or on. Mine is set to default off so I have to manually turn my unit on when I start it up.
 

Ct_Formula

Well-Known Member
First Name
John
Joined
Feb 9, 2021
Messages
376
Reaction score
395
Location
Orange Ct
Vehicle(s)
2021 Rubicon JL, 2011 JK Sahara
I don't know if you have found it in the dev settings or not but there's a way to default to either off or on. Mine is set to default off so I have to manually turn my unit on when I start it up.
I'm looking for that in the morning! Thanks
 

Mendacity

Active Member
First Name
Jim
Joined
Sep 13, 2021
Messages
37
Reaction score
28
Location
Reading, PA
Vehicle(s)
2020 Wrangler Sport
I messed with my unit last night for about 3 hours trying to fix the Android Auto carplay sound with no luck. When I'm connected via Bluetooth that audio upgrade I installed from MB Quart sounds awesome. It's loud and crisp when you turn it up. When I'm connected via USB though the sound gets muted and muffled by about 30% roughly.
Insane has been trying to help me out but I am thinking it is an issue with the carplay feature itself. They told me to go into the voice settings in dev settings and "look" for carplay settings. There are no carplay settings. 🤦
20210913_185834.jpg

So as of right now I am just going to run Hotspot and apps on unit with Bluetooth enabled for phone. Or maybe even still run my audio from the phone and just Hotspot for waze alone.
Truly terrible though that it sounds so muffled from carplay as I absolutely love it.
 
Advertisement

Chrysler Factory Warranty
 
Advertisement
Top