Help with the swaybar disconnect warning light please (Pic)

Jeffrey67

Well-Known Member
First Name
Jeff
Joined
Mar 10, 2019
Messages
74
Reaction score
139
Location
Far Hills, NJ
Vehicle(s)
2018 JL Rubicon, 2017 GMC Yukon Denali XL, 1968 Corvette 427, 1967 Corvette 327, 2 Harleys.
Occupation
Dentist
CB7CA536-7FE7-4A00-96E1-F5B5AC3E90FB.jpeg

I called up my dealer to make an appointment for an oil change and to ask about this light. Naturally he says “I don’t know “ ...I’m guessing someone here knows.





Advertisement

 

roaniecowpony

Well-Known Member
Joined
Dec 4, 2018
Messages
2,150
Reaction score
2,254
Location
90505
Vehicle(s)
2018 JLUR, 14 GMC 1500 CC All TERRAIN
Occupation
Retired Engineer
That is the message which should appear when you attempt to disengage the front swaybar (on a Rubicon) anytime you are not in 4 wd Low.

This would seem to indicate that the swaybar disengage is being commanded...or there is a fault in the system.
 

chevymitchell

Well-Known Member
First Name
Shawn
Joined
Feb 18, 2018
Messages
1,835
Reaction score
3,560
Location
K-Vegas, NC
Vehicle(s)
2020 Rubi Recon
Occupation
Nerd
CB7CA536-7FE7-4A00-96E1-F5B5AC3E90FB.jpeg

I called up my dealer to make an appointment for an oil change and to ask about this light. Naturally he says “I don’t know “ ...I’m guessing someone here knows.
That silly thing no one reads will tell you....

Gotta be in 4LO for the sway bar disconnect to work.
 

roaniecowpony

Well-Known Member
Joined
Dec 4, 2018
Messages
2,150
Reaction score
2,254
Location
90505
Vehicle(s)
2018 JLUR, 14 GMC 1500 CC All TERRAIN
Occupation
Retired Engineer
I think it's page 330 something in the owners manual. There's a button on the dash, in front of the shifter for the swaybar disconnect. Try pushing it again. If this doesn't help, try putting the vehicle in 4Low for a minute and cycling the swaybar disconnect switch again.
 

Zandcwhite

Well-Known Member
First Name
Zach
Joined
Sep 4, 2019
Messages
690
Reaction score
862
Location
Patterson, ca
Vehicle(s)
2019 jlur
In the photo, not only is he in 2H, he's at 2k rpms in 8th gear. No the sway bar won't disconnect at 80+mph... The warning with the explanation point is lit because there's an actual problem. Could be a loose connection at the sway bar motor, could be something more.
 
OP
Jeffrey67

Jeffrey67

Well-Known Member
First Name
Jeff
Joined
Mar 10, 2019
Messages
74
Reaction score
139
Location
Far Hills, NJ
Vehicle(s)
2018 JL Rubicon, 2017 GMC Yukon Denali XL, 1968 Corvette 427, 1967 Corvette 327, 2 Harleys.
Occupation
Dentist
  • Thread starter
  • Thread Starter
  • #6
I’m familiar with how the system works. I don’t disconnect the sway bar very often I might have done it a few times while driving in deep snow this winter. (Just to say I did, really wasn’t necessary) The jeep will display this message while driving in 2H. I am not attempting to engage 4H or 4L on the highway.
 

roaniecowpony

Well-Known Member
Joined
Dec 4, 2018
Messages
2,150
Reaction score
2,254
Location
90505
Vehicle(s)
2018 JLUR, 14 GMC 1500 CC All TERRAIN
Occupation
Retired Engineer
If cycling the system doesn't help, crawl under the front and check the connectors. You may have a loose or damaged connector. Then check the fuses.
 
OP
Jeffrey67

Jeffrey67

Well-Known Member
First Name
Jeff
Joined
Mar 10, 2019
Messages
74
Reaction score
139
Location
Far Hills, NJ
Vehicle(s)
2018 JL Rubicon, 2017 GMC Yukon Denali XL, 1968 Corvette 427, 1967 Corvette 327, 2 Harleys.
Occupation
Dentist
  • Thread starter
  • Thread Starter
  • #8
Any chance you can show me a pic of the connectors? I wonder if I damaged them or disconnected one while driving into deep snow.
 

SirMagnus89

Well-Known Member
First Name
Charles
Joined
Jul 26, 2019
Messages
222
Reaction score
251
Location
Massachusetts
Vehicle(s)
2018 Jl Sport 2 Door, Mojito!
Did the message appear when you were driving or has it been on since you started the Jeep? Alittle more info is needed in order for us to break down the issue.
 

roaniecowpony

Well-Known Member
Joined
Dec 4, 2018
Messages
2,150
Reaction score
2,254
Location
90505
Vehicle(s)
2018 JLUR, 14 GMC 1500 CC All TERRAIN
Occupation
Retired Engineer
Any chance you can show me a pic of the connectors? I wonder if I damaged them or disconnected one while driving into deep snow.
It's still dark out on the west coast. But, it's right up front behind the bumper. There is an obvious electric actuator as shown in this parts drawing. Somewhere on the actuator is the connector.

Jeep swaybar parts.png
 

Badweissenbier

Well-Known Member
First Name
Bad
Joined
Aug 6, 2018
Messages
233
Reaction score
183
Location
WV
Vehicle(s)
2018 Billet JLUR
That silly thing no one reads will tell you....

Gotta be in 4LO for the sway bar disconnect to work.
it will work in 4 hi as well. Use it all the time.
 
OP
Jeffrey67

Jeffrey67

Well-Known Member
First Name
Jeff
Joined
Mar 10, 2019
Messages
74
Reaction score
139
Location
Far Hills, NJ
Vehicle(s)
2018 JL Rubicon, 2017 GMC Yukon Denali XL, 1968 Corvette 427, 1967 Corvette 327, 2 Harleys.
Occupation
Dentist
  • Thread starter
  • Thread Starter
  • #12
Wow, thanks. I bet I dinged it. We've head heavy, deep snow in NJ all through February. I once cracked my radiator in deep snow in a JK.
 
OP
Jeffrey67

Jeffrey67

Well-Known Member
First Name
Jeff
Joined
Mar 10, 2019
Messages
74
Reaction score
139
Location
Far Hills, NJ
Vehicle(s)
2018 JL Rubicon, 2017 GMC Yukon Denali XL, 1968 Corvette 427, 1967 Corvette 327, 2 Harleys.
Occupation
Dentist
  • Thread starter
  • Thread Starter
  • #13
Did the message appear when you were driving or has it been on since you started the Jeep? Alittle more info is needed in order for us to break down the issue.
It comes on and off randomly under normal, 2H driving.
 

roaniecowpony

Well-Known Member
Joined
Dec 4, 2018
Messages
2,150
Reaction score
2,254
Location
90505
Vehicle(s)
2018 JLUR, 14 GMC 1500 CC All TERRAIN
Occupation
Retired Engineer
it will work in 4 hi as well. Use it all the time.
You are correct. The manual says 4 Hi or Lo, under 18 mph. It will automatically try to reconnect above 18 mph.
 

aldo98229

Well-Known Member
First Name
Aldo
Joined
Nov 16, 2019
Messages
3,954
Reaction score
7,866
Location
Bellingham, WA
Vehicle(s)
2018 Jeep Wrangler Unlimited Sahara, 2018 Fiat 124 Spider Abarth
Occupation
Market Research
Vehicle Showcase
2
BTW, “I don’t know” is not an acceptable answer by the dealer. It is their job to know. And if they still don’t know, then they better find out.
 

Advertisement




D&C Designs
 



Advertisement
Top