Help Reverse Lights Not Working 2021 JL Wrangler Sport with GTR Ultra LED Reverse Upgrade

JeepfromBMW

Member
First Name
Michael
Joined
Jul 18, 2021
Messages
18
Reaction score
22
Location
ohio
Vehicle(s)
2021 JLU Sport S Billet Silver
Hey all! I just installed the Headlight Revolution GTR Ultra LED reverse lights which are supposed to be plug and play when using the 7440 adapter. I installed them perfectly according to instruction, but they aren’t turning on in reverse. I tried turning one of them around in terms of polarity when plugging in the adapter but I honestly don’t think that matters and it still won’t turn on. I put the halogen bulb back in one of them just now and also not turning on. Any ideas?? I’m stumped now because now the LEDs and the Halogens won’t go on in reverse. Turn signals and brake lights are fine.
 

WranglerMan

Well-Known Member
First Name
Will
Joined
May 8, 2018
Messages
3,257
Reaction score
2,386
Location
Katy Texas
Vehicle(s)
2018 Wrangler JLU Sahara
Occupation
Gas Pipeliner
Vehicle Showcase
1
Hey all! I just installed the Headlight Revolution GTR Ultra LED reverse lights which are supposed to be plug and play when using the 7440 adapter. I installed them perfectly according to instruction, but they aren’t turning on in reverse. I tried turning one of them around in terms of polarity when plugging in the adapter but I honestly don’t think that matters and it still won’t turn on. I put the halogen bulb back in one of them just now and also not turning on. Any ideas?? I’m stumped now because now the LEDs and the Halogens won’t go on in reverse. Turn signals and brake lights are fine.
I had a similar issue with reverse lights, I swapped out the entire halogen light assembly to a LED assembly and started having issues with the new lights and they to were supposed to be plug and play, sometimes they would work and other times they would not so I swapped back to the original halogen light assembly and it did not work and I was like WTH did I do as I had never had issues with the factory lights but after unplugging and plugging back in the original light and cycling the ignition and lights several times they started working and never had any problems, after digging and talking to several bulb makers they told me that the JL has a very picky CANBUS system and does not take much to jam up the software so it takes a reset by cycling it several times to normally correct the problem.

My suggestion is put all the stock bulbs back in and cycle the lights and ignition multiple times to see if the issues are resolved.

In the end I recently went to another maker for LED lights for the rear and have so far had zero issues but it’s an entire fixture replacement that requires no flash but I did use JSCAN to set to LED just to make sure, but before these I was using these bulbs shortly and had zero issue on reverse but wanted the LED halo

I used these and had trouble from day one

https://www.amazon.com/dp/B07YCV9P8Y/ref=cm_sw_em_r_mt_dp_TSQG1DHADK9251356GPG?_encoding=UTF8&psc=1



Swapped to these with no issues

https://www.amazon.com/dp/B06XQWPKKX/ref=cm_sw_em_r_mt_dp_Z2X1K3ZEAXRE9SEZS172?_encoding=UTF8&psc=1


And recently went to these as they have the factory LED look and so far no issues, they have gone up in pricing some but are super bright and seem well built

https://www.extremeterrain.com/raxiom-jeep-wrangler-led-tail-lights-j132754-jl.html

39813549-BADC-4E33-B000-405748D8C5C6.jpeg
0BE9FB28-09EB-4CA8-BB78-401F80C7CB7A.jpeg
40342945-3CBC-417A-9B40-4B5FACAD36EB.jpeg
 
Advertisement

Stinger Off-Road
 
Advertisement
Top