Evaporative Emissions Leak MIL..?

Crusifix

Well-Known Member
First Name
Jeff
Joined
Mar 8, 2019
Messages
653
Reaction score
1,165
Location
West Virginia
Vehicle(s)
2019 JLU Rubicon 2.0T Hurricane
So, another CEL/MIL today. Fuel cap is always tight, I am OCD about that. So, is this an issue anyone else has? It's the weekend, so it will be Monday before I can call the service dept. If this is a known issue, what do I need to "suggest" service look into? Sorry, I tried to search, but kept getting errors.

-Jeff
Advertisement

 

JLRuss

Member
First Name
Russ
Joined
Feb 25, 2019
Messages
24
Reaction score
14
Location
Fort Worth, TX
Vehicle(s)
2019 Unlimited Rubicon
So, another CEL/MIL today. Fuel cap is always tight, I am OCD about that. So, is this an issue anyone else has? It's the weekend, so it will be Monday before I can call the service dept. If this is a known issue, what do I need to "suggest" service look into? Sorry, I tried to search, but kept getting errors.

-Jeff
I had to deal with the P0456 Small Evap Leak code a couple weeks ago. I'll post an image showing their write-up of the fix. Hopefully it will help you. No problems for me since taking it in.
Photo Apr 29, 10 03 27 AM.jpg
 
OP
OP
Crusifix

Crusifix

Well-Known Member
First Name
Jeff
Joined
Mar 8, 2019
Messages
653
Reaction score
1,165
Location
West Virginia
Vehicle(s)
2019 JLU Rubicon 2.0T Hurricane
Interesting. This all started right after I installed a trailer light harness kit. I wonder if during the install that I may have knocked the connector loose. This is a huge help! Thank you very much!
 

Squibbles

Well-Known Member
Joined
Apr 20, 2019
Messages
139
Reaction score
76
Location
Albuquerque
Vehicle(s)
GTI, Ranger
So, another CEL/MIL today. Fuel cap is always tight, I am OCD about that. So, is this an issue anyone else has? It's the weekend, so it will be Monday before I can call the service dept. If this is a known issue, what do I need to "suggest" service look into? Sorry, I tried to search, but kept getting errors.

-Jeff
Just out of curiosity how long does the vehicle take to heat up?
 

BettyBoop

Well-Known Member
First Name
Kevin
Joined
Feb 25, 2019
Messages
71
Reaction score
104
Location
Portland, Oregon
Vehicle(s)
2019 JLR 2dr.
Occupation
Business Owner
I've had this error since new. It's a simple reset, but comes back about every tank, or less. Just lazy and not taking it in to dealership; cause they'll take forever to fix. Too much wasted time. Great information, thank you for posting. I'll check pin myself; looks like quick fix. Thank you again.
 

ayoung

Member
First Name
Andrew
Joined
Mar 15, 2020
Messages
12
Reaction score
8
Location
San Diego, CA
Vehicle(s)
2019 Wrangler JL 3.6L 6MT
Occupation
US Navy
Interesting. This all started right after I installed a trailer light harness kit. I wonder if during the install that I may have knocked the connector loose. This is a huge help! Thank you very much!
@Crusifix how did this all turn out for you? I just had the same code come up this weekend. MY JL 3.6L Manual is at the dealer right now getting looked at. I also recently installed the MOPAR trailer wiring harness and curious if I hit something loose also.
 

DanFelix

Well-Known Member
Joined
Dec 22, 2018
Messages
195
Reaction score
64
Location
Riverside, CA
Vehicle(s)
2018 Wrangler JL Sport S
I've had this error since new. It's a simple reset, but comes back about every tank, or less. Just lazy and not taking it in to dealership; cause they'll take forever to fix. Too much wasted time. Great information, thank you for posting. I'll check pin myself; looks like quick fix. Thank you again.
I have this problem now. How did you reset it?
 

BettyBoop

Well-Known Member
First Name
Kevin
Joined
Feb 25, 2019
Messages
71
Reaction score
104
Location
Portland, Oregon
Vehicle(s)
2019 JLR 2dr.
Occupation
Business Owner
Mine actually went away after about 10k miles. When I needed to reset it, I used a Torque Pro plug in device.
 

Weird Wint

Well-Known Member
First Name
Wint
Joined
Jun 18, 2018
Messages
73
Reaction score
73
Location
Nor Cal
Vehicle(s)
2018 JL Wrangler Sport S 2-Door
Interesting. This all started right after I installed a trailer light harness kit. I wonder if during the install that I may have knocked the connector loose. This is a huge help! Thank you very much!
this just happened to my jeep 5 days after the dearlership installed my tow wiring harness.
 

Weird Wint

Well-Known Member
First Name
Wint
Joined
Jun 18, 2018
Messages
73
Reaction score
73
Location
Nor Cal
Vehicle(s)
2018 JL Wrangler Sport S 2-Door
the dealer said there was an update to the check engine code and fixed for free.
 
Advertisement

Morris 4x4 Center
 
Advertisement
Top