Engine Check Light - Now also Stop/Start System Warning Light

custmfxwg

Member
Joined
Oct 24, 2018
Messages
12
Reaction score
5
Location
Maryland
Vehicle(s)
2019 JL Unlimited Rubicon
Just had this happen to my wife on Saturday; start/stop alert, cel, and very rough idle. Sounds like the same issue the op had as the dealer said they replaced the O2 sensor and valve pan gaskets because they were leaking slightly. Should be ready to pick up tomorrow. The dealer is a good 70 miles from the house so we'll see if it's fixed.

The good news is that we have about 30k miles on the jeep and the dealer seemed to know what it was fairly quickly. Time will tell.
Advertisement

 

Mrcake3014

Well-Known Member
First Name
Paul
Joined
Jan 3, 2019
Messages
152
Reaction score
66
Location
19803
Vehicle(s)
2019 Sahara
My brand new Rubicon JLU (delivered August 6) had the Engine Check Light go on at 117 miles.
Drive it home and the light was off when I turned the Jeep on a few hours later.

At 290 miles it came on again.
Took it to the dealer but couldn't make a service appointment as I was having surgery the next day plus time to recover.Finally took it in Sept 11 and they "fixed" it (apparently a software issue).
Picked it up on the 12th and the light was on again. They reset the system and it seemed fine (off).

Wife is driving it today and the light came on again, AND the Stop/Start System Warning Light has come on. The wife also says it's nor accelerating as smoothly now an there's a slight "tremble" when the engine is running, not smooth like before.

Anybody have any experience with anything like this.Obviously I'm taking it in again, but this is a brand new Jeep and disappointed is an understatement,
I had a problem with the start stop. First they changed the hood sensor. That wasn’t it they had to replace the wiring for the whole system. 2019 with 3000 miles. I was hot!
Also get in touch with Jeep waves. I found them to be very helpful with dealing with the dealership.
 

custmfxwg

Member
Joined
Oct 24, 2018
Messages
12
Reaction score
5
Location
Maryland
Vehicle(s)
2019 JL Unlimited Rubicon
Just had this happen to my wife on Saturday; start/stop alert, cel, and very rough idle. Sounds like the same issue the op had as the dealer said they replaced the O2 sensor and valve pan gaskets because they were leaking slightly. Should be ready to pick up tomorrow. The dealer is a good 70 miles from the house so we'll see if it's fixed.

The good news is that we have about 30k miles on the jeep and the dealer seemed to know what it was fairly quickly. Time will tell.
So I confirmed today that I had the same issue (or very similar) as @Lustmord. Right valve cover found to be leaking on the O2 sensor. Threw codes P2096 and P0171. New O2 sensor and new valve pan cover gaskets and so far so good.
 

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,610
Reaction score
2,277
Location
Auburn Hills, MI
Vehicle(s)
JL
So I confirmed today that I had the same issue (or very similar) as @Lustmord. Right valve cover found to be leaking on the O2 sensor. Threw codes P2096 and P0171. New O2 sensor and new valve pan cover gaskets and so far so good.
Hi custmfxwg,
We are happy to hear that your dealer was able to resolve your concerns for you! In the future, please feel free to send us a private message with any questions you may have. We are happy to help!

Kathryn
JeepCares
 

Dadawada

Well-Known Member
First Name
Barrett
Joined
Jul 10, 2018
Messages
105
Reaction score
70
Location
Raleigh, NC
Vehicle(s)
2018 Rubicon Unlimited, 2020 Honda Goldwing Bagger
Occupation
Network Technology Executive
Vehicle Showcase
1
Reviving an old post...

At 3 years ownership and 37k miles I just got the same exact symptoms you all are experiencing. Luckily I sprung for the Mopar/Jeep Extended Warranty so I at least have that going for me. My symptoms are slightly different but the dealer read the codes today and they were the same...oxygen sensor, misfire code, etc.
CEL came on, then Autostart not ready, then running rough, CEL flashing (which is bad). Can't get into the dealer until the 25th, over a week away...:(
 

mwilk012

Well-Known Member
Joined
Mar 10, 2018
Messages
4,307
Reaction score
3,875
Location
Oklahoma
Vehicle(s)
2018 Ocean Blue JLU Rubicon
Reviving an old post...

At 3 years ownership and 37k miles I just got the same exact symptoms you all are experiencing. Luckily I sprung for the Mopar/Jeep Extended Warranty so I at least have that going for me. My symptoms are slightly different but the dealer read the codes today and they were the same...oxygen sensor, misfire code, etc.
CEL came on, then Autostart not ready, then running rough, CEL flashing (which is bad). Can't get into the dealer until the 25th, over a week away...:(
Go somewhere else. Don't drive it like that.
 

viper88

Well-Known Member
First Name
Nick
Joined
Apr 22, 2018
Messages
4,273
Reaction score
4,095
Location
IL
Vehicle(s)
'19 JLR 2.0T
I saw one 3.6. How about the rest? Which engines and eTorque or ESS?
 
Advertisement

Allmoparparts.com
 
Advertisement
Top