EcoDiesel Surge

AndySilverC

New Member
First Name
Andy
Joined
Jul 19, 2021
Messages
2
Reaction score
0
Location
84009
Vehicle(s)
2021 Jeep Wrangler Islander 3.0l diesel
I have under 1,800 miles on my EcoDiesel and started experiencing a surging issue. It went away and I assumed it was due to the 105 Temps outside. Next day, it did it again, this time, it failed to go over 25 mph and received a message to service electronic throttle control. Had to get it towed to the dealer. Im still waiting on the diag, but curious if anyone else ran into this and if so, what was the resolution.
 

JLURD

Well-Known Member
Joined
Nov 30, 2017
Messages
1,547
Reaction score
2,062
Location
Alaska
Vehicle(s)
2018 Compass Latitude 6MT, 2020 JLUR 3.0
There were a few folks who had throttle controller issues early in the 2020 run of the 3.0. You’d have to look back in those threads to find them because I forget who it was.
 

JamC12H23

Member
First Name
Jeff
Joined
Jun 7, 2021
Messages
6
Reaction score
11
Location
Andover KS
Vehicle(s)
2021 JLU Diesel
I had it on my 2021 JKU. I was pulling a travel trailer back from a trip to CO and I was about 40 minutes from home when the Service Throttle Control came on and speed slowed to about 40 mph If I remember correctly. I didn’t want to stop because it was late in the evening and I didn’t want to get stuck on the side of the road. I played with the throttle getting on and off the pedal a little and I could get it up to 60 mph. I made it home, unloaded the trailer real quick and when I started it back up the Service Throttle Control was gone and the JKU ran fine, Check Engine Light stayed on. I left the CEL, I wanted to see how long it took to clear and if I remember correctly it was 4 starts. I did not take it in and it has run fine since then.
 
OP
OP
AndySilverC

AndySilverC

New Member
First Name
Andy
Joined
Jul 19, 2021
Messages
2
Reaction score
0
Location
84009
Vehicle(s)
2021 Jeep Wrangler Islander 3.0l diesel
I had it on my 2021 JKU. I was pulling a travel trailer back from a trip to CO and I was about 40 minutes from home when the Service Throttle Control came on and speed slowed to about 40 mph If I remember correctly. I didn’t want to stop because it was late in the evening and I didn’t want to get stuck on the side of the road. I played with the throttle getting on and off the pedal a little and I could get it up to 60 mph. I made it home, unloaded the trailer real quick and when I started it back up the Service Throttle Control was gone and the JKU ran fine, Check Engine Light stayed on. I left the CEL, I wanted to see how long it took to clear and if I remember correctly it was 4 starts. I did not take it in and it has run fine since then.
Thanks for the info!
 
Advertisement

Clayton Offroad
 
Advertisement
Top