Carplay2air??? Wireless carplay dongle

WranglerMan

Well-Known Member
First Name
Will
Joined
May 8, 2018
Messages
2,998
Reaction score
2,118
Location
Katy Texas
Vehicle(s)
2018 Wrangler JLU Sahara
Occupation
Gas Pipeliner
Vehicle Showcase
1
Read through this thread and heed the advice of others. If it does not work, it appears to be pretty costly to return.
I know there are issues with the Carplay2air but had not seen much on the Carlinkit 2.0





Advertisement

 

spolo85

Member
Joined
Jan 8, 2021
Messages
9
Reaction score
6
Location
07857
Vehicle(s)
2021 JLU
I know there are issues with the Carplay2air but had not seen much on the Carlinkit 2.0
I'm still in the process of returning this Carplay2air garbage back to China...it is taking forever with these guys..

However I did purchase Carlink 2.0 from Amazon Prime that is coming in tomorrow. If it doesn't work, I can simply return it to Kohls for a full refund. Quick and painless.
 

WranglerMan

Well-Known Member
First Name
Will
Joined
May 8, 2018
Messages
2,998
Reaction score
2,118
Location
Katy Texas
Vehicle(s)
2018 Wrangler JLU Sahara
Occupation
Gas Pipeliner
Vehicle Showcase
1
I'm still in the process of returning this Carplay2air garbage back to China...it is taking forever with these guys..

However I did purchase Carlink 2.0 from Amazon Prime that is coming in tomorrow. If it doesn't work, I can simply return it to Kohls for a full refund. Quick and painless.
Let me know how it works.....I can’t find much info on it as far as reviews
 

Jennalee

Well-Known Member
First Name
Jennalee
Joined
Sep 29, 2019
Messages
514
Reaction score
676
Location
Los Angeles, CA
Vehicle(s)
2020 White 2 door Willys V6 Automatic
Thats the thing if I have to unplug and plug in I might as well just plug in all the time unless it does not happen that often
It only happens when starting up my jeep. Happens about 95% of the time so I just unplug it everytime I shut down. Also, I plug it back in after I’m done reversing the Jeep, the device freezes in reverse if it isn’t done connecting. Once it’s plugged in and connected, reversing isn’t a problem. It worked flawlessly in my Cherokee rentals though. I left it plugged in the whole time without any problems.
 

WranglerMan

Well-Known Member
First Name
Will
Joined
May 8, 2018
Messages
2,998
Reaction score
2,118
Location
Katy Texas
Vehicle(s)
2018 Wrangler JLU Sahara
Occupation
Gas Pipeliner
Vehicle Showcase
1
It only happens when starting up my jeep. Happens about 95% of the time so I just unplug it everytime I shut down. Also, I plug it back in after I’m done reversing the Jeep, the device freezes in reverse if it isn’t done connecting. Once it’s plugged in and connected, reversing isn’t a problem. It worked flawlessly in my Cherokee rentals though. I left it plugged in the whole time without any problems.
I honestly could not be plugging in and unplugging as much as that so maybe the other unit I’m looking at will work better
 

Sierra

Well-Known Member
First Name
Sierra
Joined
Mar 21, 2019
Messages
151
Reaction score
46
Location
Nogales, AZ
Website
link.sierrar.com
Vehicle(s)
2018 JLU Rubicon, 2015 BMW 328i F30
Build Thread
Link
Occupation
eCommerce Developer
Vehicle Showcase
1
Any update? Thinking to buy the Carlinkit 2.0
 

dsgrey

Well-Known Member
First Name
Kevin
Joined
Apr 19, 2019
Messages
566
Reaction score
445
Location
Texas
Vehicle(s)
2019 JLU
Vehicle Showcase
1
It only happens when starting up my jeep. Happens about 95% of the time so I just unplug it everytime I shut down. Also, I plug it back in after I’m done reversing the Jeep, the device freezes in reverse if it isn’t done connecting. Once it’s plugged in and connected, reversing isn’t a problem. It worked flawlessly in my Cherokee rentals though. I left it plugged in the whole time without any problems.
I had a lot of disconnects when I bought mine to the point of not using it. Back in November I installed the latest update and I've waited almost 2 months to report mine no longer has any issues. I haven't had to unplug the device to reset and it connects every time.

Granted, yours may not work the same with the updates and mine may start acting wonky after the next update.
 

ODDs

Well-Known Member
Joined
Mar 19, 2019
Messages
488
Reaction score
861
Location
Phoenix
Vehicle(s)
2019 Hella Yella Sahara
Any update? Thinking to buy the Carlinkit 2.0
Based on the problems people have had here with carplay2air, I instead bought the Carlinkit 2.0 from Amazon on black Friday for $105. My thinking was that if it did have problems I could return it easily to Amazon.

I plugged it in and it connected easily and hasn't had a problem so far in the month and a half it's been installed. The only oddity my wife notices is when she has it connected and then she plugs her phone in also it will get confused.

Hopefully it continues to work well.
 

spolo85

Member
Joined
Jan 8, 2021
Messages
9
Reaction score
6
Location
07857
Vehicle(s)
2021 JLU
I got the Carlink 2.0 today from Amazon. Very easy to install and works as expected (so far). It takes between 5-10 seconds to establish a full wireless connnection (that others have noted here as well) which makes sense since the device is connected two sides together.

The only thing I haven't tested yet that others have addressed is if backing up prior to establishing a full connection will prevent a proper connection because of the backup camera somehow triggering a poor connection. I'll keep testing and report back.

Still waiting to return the other CarPlay2Air junk back to China but I have to a couple of weeks for Paypal to step in and return my money..
 

WranglerMan

Well-Known Member
First Name
Will
Joined
May 8, 2018
Messages
2,998
Reaction score
2,118
Location
Katy Texas
Vehicle(s)
2018 Wrangler JLU Sahara
Occupation
Gas Pipeliner
Vehicle Showcase
1
Based on the problems people have had here with carplay2air, I instead bought the Carlinkit 2.0 from Amazon on black Friday for $105. My thinking was that if it did have problems I could return it easily to Amazon.

I plugged it in and it connected easily and hasn't had a problem so far in the month and a half it's been installed. The only oddity my wife notices is when she has it connected and then she plugs her phone in also it will get confused.

Hopefully it continues to work well.
do you happen to have a link to the one you purchased, they have several listed
 

WranglerMan

Well-Known Member
First Name
Will
Joined
May 8, 2018
Messages
2,998
Reaction score
2,118
Location
Katy Texas
Vehicle(s)
2018 Wrangler JLU Sahara
Occupation
Gas Pipeliner
Vehicle Showcase
1
I got the Carlink 2.0 today from Amazon. Very easy to install and works as expected (so far). It takes between 5-10 seconds to establish a full wireless connnection (that others have noted here as well) which makes sense since the device is connected two sides together.

The only thing I haven't tested yet that others have addressed is if backing up prior to establishing a full connection will prevent a proper connection because of the backup camera somehow triggering a poor connection. I'll keep testing and report back.

Still waiting to return the other CarPlay2Air junk back to China but I have to a couple of weeks for Paypal to step in and return my money..
Have you tested the backup feature ?
 

spolo85

Member
Joined
Jan 8, 2021
Messages
9
Reaction score
6
Location
07857
Vehicle(s)
2021 JLU
Have you tested the backup feature ?
I tested the backup feature and it doesn't seem to interfer with the connection. However after driving a while, the connection did randomly drop which I believe has been mentioned here as something that happens. I simply disconnected and reconnected and it came back.

Have to keep testing it more to see how pervasive that ends up being. If it's pretty random, I'll take it over having to hard-wire because I even have the same exact problem with hard-wiring.
 

WranglerMan

Well-Known Member
First Name
Will
Joined
May 8, 2018
Messages
2,998
Reaction score
2,118
Location
Katy Texas
Vehicle(s)
2018 Wrangler JLU Sahara
Occupation
Gas Pipeliner
Vehicle Showcase
1
I tested the backup feature and it doesn't seem to interfer with the connection. However after driving a while, the connection did randomly drop which I believe has been mentioned here as something that happens. I simply disconnected and reconnected and it came back.

Have to keep testing it more to see how pervasive that ends up being. If it's pretty random, I'll take it over having to hard-wire because I even have the same exact problem with hard-wiring.
oh...I’ve never had an issue when it’s plugged in
 

dsgrey

Well-Known Member
First Name
Kevin
Joined
Apr 19, 2019
Messages
566
Reaction score
445
Location
Texas
Vehicle(s)
2019 JLU
Vehicle Showcase
1
I plugged it in and it connected easily and hasn't had a problem so far in the month and a half it's been installed. The only oddity my wife notices is when she has it connected and then she plugs her phone in also it will get confused.
Mine does that too when she connects to a cable for charging but so does the stock connectivity on her Mazda when we are both in the vehicle with our phones.
 

Advertisement




Morris 4x4 Center
 



Advertisement
Top