CarPlay problems

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,610
Reaction score
2,277
Location
Auburn Hills, MI
Vehicle(s)
JL
JDP seems to be on to something. I did unpair, reset...forget...etc....but nothing worked. However, just waiting did. When I got back into the Jeep 3 hours later...CarPlay functioned normally.

What I also did...and not sure if it was any help or not yet was locate the other iphones that had been connected to the UConnect. Within the settings, I was able to de-select "CarPlay" for those devices. Apparently Uconnect things anything you plugin that has car play ability should over-ride the first. Not that I don't love my son or wife...but ... no.... dont mess with my CarPlay... LOL. PIcked up the family later in the day .... they all plugged in and no problems.

Stay tuned as I imagine this issue is not over yet.
Hi xeon,

We're sorry to hear that you had this experience. If it occurs again, please send us a message so that we can assist further.

Darlene
Jeep Social Care Specialist
Advertisement

 

Kirasdad

Active Member
First Name
Rick
Joined
May 2, 2018
Messages
29
Reaction score
6
Location
Colorado
Vehicle(s)
‘18 Rubicon
‘18 Rubicon. On Day #2, CarPlay quit working for me. It occasionally recognized my iPhone, would randomly select FM, satellite, UBS or songs from my iPhone as a source. Voice control for changing stations doesn’t work. Lousy system. Have been to two Jeep dealers, neither have a clue. Both say they can’t duplicate the problem, but a “Star’ report with engineers at FCA is active. I don’t think the service technicians have been trained for the newer vehicles.
I asked how many iPhones they connected to my system to duplicate the problem - none, they just plugged my iPod in. I asked why they didn’t connect an iPhone, but couldn’t get a straight answer. I went to pick up the car and showed the tech the problems I’m having. He had no idea what CarPlay even was, and didn’t even know to plug in an iPhone. WTF.
 

Kirasdad

Active Member
First Name
Rick
Joined
May 2, 2018
Messages
29
Reaction score
6
Location
Colorado
Vehicle(s)
‘18 Rubicon
Had this exact issue with my wife’s Subaru, obviously not UConnect. Either way, I took it to the dealership and they had to reinstall the OS on the head unit. Been working great ever since.

When you removed it as a projection device from the radio did you also tell the iPhone to forget the car as a known CarPlay device?

I would try this:
1. Remove it from the UConnect system
2. Forget the UConnect system on the iPhone.
3. Restart the iPhone
4. Plug in

If it doesn’t work, take it in!
What dealer do you go to in CO? I’ve been to two and no one has a clue.

I don’t think the service technicians have been trained for the newer vehicles.
I asked how many iPhones they connected to my system to try to duplicate the problem - none, they just plugged my iPod in. I asked why they didn’t connect an iPhone, but couldn’t get a straight answer. I went to pick up the car and showed the tech the problems I’m having. He had no idea what CarPlay even was, and didn’t even know to pair an iPhone. then, he said I would be getting a customer service survey, and nothing but the best score was acceptable. WTH.
 

SixteenPaws

Well-Known Member
Joined
Feb 18, 2018
Messages
338
Reaction score
373
Location
Colorado
Vehicle(s)
2018 JLUR
What dealer do you go to in CO? I’ve been to two and no one has a clue.

I don’t think the service technicians have been trained for the newer vehicles.
I asked how many iPhones they connected to my system to try to duplicate the problem - none, they just plugged my iPod in. I asked why they didn’t connect an iPhone, but couldn’t get a straight answer. I went to pick up the car and showed the tech the problems I’m having. He had no idea what CarPlay even was, and didn’t even know to pair an iPhone. then, he said I would be getting a customer service survey, and nothing but the best score was acceptable. WTH.
That’s ridiculous. I definitely wouldn’t be giving them a good score on their survey.

I haven’t been to the dealer for the Jeep yet, but I bought from Faricy Boys in the Springs.

If you don’t want to post who your dealer is I get that, but would you mind PMing me it? I don’t live near the springs, and I want to know who to avoid if/when I need to take it in.
 

WranglerMan

Well-Known Member
First Name
Will
Joined
May 8, 2018
Messages
3,283
Reaction score
2,413
Location
Katy Texas
Vehicle(s)
2018 Wrangler JLU Sahara
Occupation
Gas Pipeliner
Vehicle Showcase
1
Have not used CarPlay much but the few times I have there have been no issues, the only issue with Uconnect so far is it won’t remember that my iPhone was the last source for music and it defaults to the radio all the time, kind of annoying but gives me a chance to enjoy the 1year of free SAT radio
 

SixteenPaws

Well-Known Member
Joined
Feb 18, 2018
Messages
338
Reaction score
373
Location
Colorado
Vehicle(s)
2018 JLUR
Have not used CarPlay much but the few times I have there have been no issues, the only issue with Uconnect so far is it won’t remember that my iPhone was the last source for music and it defaults to the radio all the time, kind of annoying but gives me a chance to enjoy the 1year of free SAT radio
Not sure if it will help you, but there are settings in UConnect that relate to what it should do when you first start the system up.
 

WranglerMan

Well-Known Member
First Name
Will
Joined
May 8, 2018
Messages
3,283
Reaction score
2,413
Location
Katy Texas
Vehicle(s)
2018 Wrangler JLU Sahara
Occupation
Gas Pipeliner
Vehicle Showcase
1
Not sure if it will help you, but there are settings in UConnect that relate to what it should do when you first start the system up.
How does one access those settings, I have gone thru the settings button on the Uconnect screen and went thru each sceen but did not see anything as far as having it default tommy Bluetooth device under media for its source for music it always defaults to the SAT radio
 

SixteenPaws

Well-Known Member
Joined
Feb 18, 2018
Messages
338
Reaction score
373
Location
Colorado
Vehicle(s)
2018 JLUR
How does one access those settings, I have gone thru the settings button on the Uconnect screen and went thru each sceen but did not see anything as far as having it default tommy Bluetooth device under media for its source for music it always defaults to the SAT radio
So I slightly remembered the settings wrong, or can’t find it again. The only option I found was related to whether or not USB devices will automatically play when connected. That setting is under Settings > Audio > Auto Play.

If I happen to figure out what I was talking about previously I’ll update.
 

WranglerMan

Well-Known Member
First Name
Will
Joined
May 8, 2018
Messages
3,283
Reaction score
2,413
Location
Katy Texas
Vehicle(s)
2018 Wrangler JLU Sahara
Occupation
Gas Pipeliner
Vehicle Showcase
1
So I slightly remembered the settings wrong, or can’t find it again. The only option I found was related to whether or not USB devices will automatically play when connected. That setting is under Settings > Audio > Auto Play.

If I happen to figure out what I was talking about previously I’ll update.
I found that setting and that only applies to when you use a USB cable, the issue I have is when I get in it and then select media as the source then Bluetooth from that submenu it starts playing music from my phone automatically but if I shut it off and then come back a restart it defaults to the SAT radio and I have to go thru it again as it does not remember that was the last source, the Uconnect 4C that was installed on my 2018 Comppass remembered it, it actually did remember it once and only once so it’s gotta be a possible issue between Uconnect and Apple but if you find a setting that I have overlooked please let me know.
 

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,610
Reaction score
2,277
Location
Auburn Hills, MI
Vehicle(s)
JL
‘18 Rubicon. On Day #2, CarPlay quit working for me. It occasionally recognized my iPhone, would randomly select FM, satellite, UBS or songs from my iPhone as a source. Voice control for changing stations doesn’t work. Lousy system. Have been to two Jeep dealers, neither have a clue. Both say they can’t duplicate the problem, but a “Star’ report with engineers at FCA is active. I don’t think the service technicians have been trained for the newer vehicles.
I asked how many iPhones they connected to my system to duplicate the problem - none, they just plugged my iPod in. I asked why they didn’t connect an iPhone, but couldn’t get a straight answer. I went to pick up the car and showed the tech the problems I’m having. He had no idea what CarPlay even was, and didn’t even know to plug in an iPhone. WTF.
Hi Kirasdad,

I'm sorry to hear about your dealer experience. Feel free to send us a direct message with your VIN as we'd be glad to locate another dealer and forward your inquiry for review.

Jasmine
Jeep Social Care Specialist
 

NOVAJL

Active Member
Joined
Mar 11, 2018
Messages
32
Reaction score
11
Location
Virginia
Vehicle(s)
2017 WK2 Trailhawk and ordered 2018 JLUR
My recommendation would be to unpair your phone from the jeep(delete). Go to your iPhone Bluetooth settings and select forget this device for uconnect. Then go to CarPlay settings and forget the device there as well. Restart your phone. Go to settings on uconnect (on Jeep screen) and reset to factory defaults. Wait overnight and then plug your phone back in. If your CarPlay does not come back up after all that then I think you will be making a trip to the dealer! Hope this helps
So I am having the same problem as others listed here where the USB ports have power and will charge but will not recognize phones for Carplay or just as an iPod. I have to do the above steps and wait a few hours EVERY TIME I plug my phone in.

I have tried different cables and different iPhones (6, 6s and 8).

I do the complete reset and it will work. As soon as I stop/start the car, I will have to reset (as above) and wait a few hours to connect.

Enough people are having this problem that it has to be a programming issue with UConnect.
 

avei5150

Well-Known Member
First Name
Andy
Joined
Jan 20, 2018
Messages
93
Reaction score
57
Location
VA
Vehicle(s)
2018 JLUR Ocean Blue
Vehicle Showcase
1
So, I can throw myself into the group of having this problem. I just got my JLUR yesterday, worked fined. Today, worked fine in the AM, this afternoon on the way home, no dice. It does seem like the system is always on when I turn on the jeep it goes into "Apps" already, and doesn't look like the system is starting up. I tried resetting in the menu, that didn't work.

I tried my phone in my wife's car and CarPlay worked fine (2017 Honda CRV), tried my cord and her's, worked fine in her car, no dice in mine. I'm hoping this is some sort of update that is going on.

***Update an hour or two later
Going out to the Jeep after updating the phone to 11.4, when I turned the Jeep on the Jeep logo and uConnect screen posted. I believe my uConnect was in some unshutdown state, and it rebooted itself. I had tried turning the Jeep off and on again (guess what I do for a living...). No luck, but it's better now.

If I had to guess maybe the uConnect system is updating throughout the first day or two of ownership? Would be nice if they could explain this. Maybe I should read the manual.
 
Last edited:

Kirasdad

Active Member
First Name
Rick
Joined
May 2, 2018
Messages
29
Reaction score
6
Location
Colorado
Vehicle(s)
‘18 Rubicon
I have the 7’ screen. Anything you would expect a smartphone or app to be able to control, this system fails at. Every time I start the car, it’s a 50/50 chance that CarPlay launches. It won’t even recognize an iPod plugged into the center console. I also have to plug it in every time I start the Jeep.

I’ve had this Jeep for 2.5 months, and am waiting to go to the dealer for the 4th time to see if someone has a clue. I’ve been to two dealers, and no one seems to care, and definitely no one has a clue. The last technician actually asked me, “what is CarPlay?’

Jeep likes to sell Jeeps, they don’t like to service them. it’s a Jeep thing.
 

Sgt Beavis

Well-Known Member
First Name
Rick and Miyako
Joined
Apr 16, 2018
Messages
1,050
Reaction score
1,292
Location
Colorado
Vehicle(s)
Wrangler JL Unlimited Sport S
Occupation
The Man, The Myth, The Legend. In my own mind.
Vehicle Showcase
4
There is a new software update for the 5 and 7" uConnect systems.
https://www.driveuconnect.com/support/software-update.html

I did try to check the VINs for both mine and my wife's Wranglers. Mine gave a VIN error and her's showed is as being up to date. I suspect their website is having issues right now.
 

smithrd65

Well-Known Member
First Name
David
Joined
May 11, 2018
Messages
811
Reaction score
676
Location
San Antonio
Vehicle(s)
2018 Jeep Wrangler Rubicon Unlimited JL. BMW Z4 35is, Tesla Model X90D, Chevy 2500 LTZ
Again take a pole the Unconnected system is only having issues with APPLE PHONES. Apple is all garbage just saying don't PUT THE BLAME ON UNCONNECT SYSTEM.
 
Advertisement

Bestop
 
Advertisement
Top