Backup Camera issues

themattparty

Member
First Name
Matt
Joined
Mar 5, 2018
Messages
16
Reaction score
6
Location
Houston
Vehicle(s)
2018 JLU Rubicon
Another day, another issue with my JLU. This time my backup camera doesn’t work at all. I have turned my car off and on multiple times and still no luck. I figured this would be like when the back up lines disappear, they tend to go away and come back whenever they feel like it.

Anyone else have either of these issues?

my biggest fear is that my vehicle is approaching the end of its warranty and my vehicle is still plagued by issues.

52F2F540-55DE-401B-9FCC-D4D33BE4CDDB.jpeg





Advertisement

 

Rubicon_LA

Well-Known Member
Joined
Aug 15, 2018
Messages
85
Reaction score
54
Location
Los Angeles
Vehicle(s)
2018 JLU Rubicon, 2018 BMW X5 Xdrive35d (diesel)
Vehicle Showcase
1
I just had this happened to me yesterday. Turned out some harder slam of the back door caused it. I opened the back trunk door and slammed it again, and camera started working. Guess some wire contact or something.
 

Arkewn

Well-Known Member
First Name
Kevin
Joined
Dec 15, 2017
Messages
220
Reaction score
308
Location
CO
Vehicle(s)
2018 JLU Rubicon
Record video on your phone of the issues so you can share with your dealer service team since they want to 'see' the issue before they can open a claim with Chrysler. It may not be enough but for these intermittent issues that's all you can do to show the dealer the issue.

What year is your rig? Mines June 2018 and I'm dealing with my stereo skipping when it gets cold out (sub 30F). During those events the lines on the backup camera cut out. Tons of threads here for similar issues and all indications are that the camera or the wiring is at fault. You are in houston? I doubt it gets cold enough there for the audio cut outs but it doesn't mean you aren't suffering from the same camera issue numerous 2018 builds seem to have.
 

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,284
Reaction score
2,062
Location
Auburn Hills, MI
Vehicle(s)
JL
Another day, another issue with my JLU. This time my backup camera doesn’t work at all. I have turned my car off and on multiple times and still no luck. I figured this would be like when the back up lines disappear, they tend to go away and come back whenever they feel like it.

Anyone else have either of these issues?

my biggest fear is that my vehicle is approaching the end of its warranty and my vehicle is still plagued by issues.

52F2F540-55DE-401B-9FCC-D4D33BE4CDDB.jpeg
@themattparty,
We certainly understand why this may be frustrating. We do recommend bringing this into your dealer for a diagnosis- feel free to send our team a private message with your VIN for additional support. We would be happy to assist.

Kathryn
JeepCares

I just had this happened to me yesterday. Turned out some harder slam of the back door caused it. I opened the back trunk door and slammed it again, and camera started working. Guess some wire contact or something.
@Rubicon_LA,
If you see that you continue to have trouble with this feature, please let us know. We would be happy to assist you alongside your dealer toward a lasting resolution.

Kathryn
JeepCares
 

JL LOL

New Member
First Name
Randy
Joined
Feb 20, 2020
Messages
2
Reaction score
0
Location
Kansas City
Vehicle(s)
2019 JLUR
All is it is the plug for the backup camera. Pop the cover off of the tailgate, and undo the grey wire connector. (Optional, add solvent or blow out with air). Plug it back in and everything should be good to go. That grey plug connection apparently doesn't work well in that environment. Please post back and let us know if that worked for you.

There was alot of chatter about having to replace the radio, replace the camera, etc, etc, etc. and I'm fairly confident that it's simply a poor connection.
 

Advertisement




Smart Stop Start
 



Advertisement
Top