Anyone running Hutchinson Rock Monster rims with 38's

  1. OP
    OP
    TDS

    TDS Well-Known Member

    First Name:
    Travis
    Vehicle(s):
    2019 Rubicon
    Joined:
    Sep 29, 2018
    Location:
    Milwaukie OR
    Posts:
    138
    Liked:
    53
    Occupation:
    Commercial Project Superintendent
    Me too!
     
  2. LunchBoxFab

    LunchBoxFab Well-Known Member

    Vehicle(s):
    19 JLUR
    Joined:
    Jan 7, 2019
    Location:
    NOLA
    Posts:
    265
    Liked:
    197
    Garage Profiles:
    1
    thanks yall

    the fender LED kit is from American Adventure Lab. they have a very cool offering with these and their removable inner fenders. they also have a very cool rear cargo management system.

    to run these lights though, you have to strip (rip) out the inner fenders and the inner structure to the outer fenders. its all plastic welded together, so a quick rip and it comes apart. there are tabs on the fenders that are easily cut off with a razor knife and cleaned up with a couple passes of some sand paper. the kit came with a nice factory connector and work as expected. the jeep doesnt like non factory LEDs and has a warning message, but the lights function as intended, even the sequential blink works. alegedly, the Tazer will allow you to clear this warning message, but i dont have one to verify.

    all in all VERY happy with the kit and love the look of stock height on 37s. AAL has been VERY easy to work with and stands behind their product.

    Edit: here is the “kit”

    1AF7AE6D-23DA-4584-B4A2-B32B88550806.jpeg

    0BBC73A3-E0D8-42BC-B637-4CFE03039172.jpeg
     
  3. OP
    OP
    TDS

    TDS Well-Known Member

    First Name:
    Travis
    Vehicle(s):
    2019 Rubicon
    Joined:
    Sep 29, 2018
    Location:
    Milwaukie OR
    Posts:
    138
    Liked:
    53
    Occupation:
    Commercial Project Superintendent
    I am assuming you need to have factory LED to run those, or is that flat plug found deeper in the factory wire harness under the inner fender.
     
  4. LunchBoxFab

    LunchBoxFab Well-Known Member

    Vehicle(s):
    19 JLUR
    Joined:
    Jan 7, 2019
    Location:
    NOLA
    Posts:
    265
    Liked:
    197
    Garage Profiles:
    1
    i dont know that. i havent see a non LED fender close enough to know. but if you look at the length of the wire in that picture, it will give you an idea on where the female version is. my LED plug was pretty far rearward from the fender light. it was as far back as the brake booster on the driver side.
     
  5. OP
    OP
    TDS

    TDS Well-Known Member

    First Name:
    Travis
    Vehicle(s):
    2019 Rubicon
    Joined:
    Sep 29, 2018
    Location:
    Milwaukie OR
    Posts:
    138
    Liked:
    53
    Occupation:
    Commercial Project Superintendent
    I will have to look and see if it is there
     
  6. CHINAMANJLUR

    CHINAMANJLUR Active Member

    First Name:
    Mike
    Vehicle(s):
    2019 JLUR
    Joined:
    Apr 10, 2019
    Location:
    Oakland Ca
    Posts:
    43
    Liked:
    42
    Looks good @Jeepney209
     
  7. CJ7nvrstk

    CJ7nvrstk Member

    First Name:
    Glenn
    Vehicle(s):
    85 CJ, 11 JKU
    Joined:
    Apr 18, 2019
    Location:
    Texas
    Posts:
    14
    Liked:
    7
    The Patagonia website shows a 10" wheel for the 38x13.50-17. That doesn't mean it can't be done but you're likely to experience more crowning of the tire and have to run a much lower pressure to get a full contact patch on the road. I just mounted a set of 38s on 17x9 wheels and at 17/15 f/r still don't have a full contact patch. Seeing how Patagonia recommends a 10" wheel for that tire would explain the crowning I'm, and others, are getting.

    Good luck and keep us posted with whatever direction you take.
     
  8. RubiRob

    RubiRob Well-Known Member

    First Name:
    Rob
    Vehicle(s):
    Jeep
    Joined:
    Feb 14, 2018
    Location:
    Hampshire, IL
    Posts:
    1,199
    Liked:
    1,032
    Garage Profiles:
    1
    Anyone running these wheels on a graphite JL by chance?
     
  9. chris4prez

    chris4prez Member

    First Name:
    Chris
    Vehicle(s):
    A4
    Joined:
    Sep 14, 2019
    Location:
    Tampa
    Posts:
    12
    Liked:
    4
    Silly question all. Any issue fitting the backup camera on the Hutchinson or any modifications required?
     
  10. LunchBoxFab

    LunchBoxFab Well-Known Member

    Vehicle(s):
    19 JLUR
    Joined:
    Jan 7, 2019
    Location:
    NOLA
    Posts:
    265
    Liked:
    197
    Garage Profiles:
    1
    i got nothing, i used the evo tailgate bracket kit, so i dont know how the factory unit fit up. that being said, the hub bore should be the same as factory, so it should fit fine. "Should"
     
Loading...

Share This Page