Android Auto and Uconnect issue

Punk'n Willy

Well-Known Member
First Name
Steve
Joined
Feb 24, 2020
Messages
223
Reaction score
443
Location
Harrisburg, PA
Vehicle(s)
2020 Jeep JLU 3.6L Punk'n Willys
Occupation
Video Editor
Vehicle Showcase
1
I checked before posting this and didn't find anything so here we go.

Has anyone had the issue with their phone being removed from Uconnect when they plug in to use Android Auto? I have the 7" so I usually plugin if I need to use Google Maps. I have set up my phone more times than I can remember and set up all my favorites but the second I plug in the phone it all goes away. I'm beginning to think the Uconnect software for the 7" is more than just a flickering screen issue.
Advertisement

 

DanFelix

Well-Known Member
Joined
Dec 22, 2018
Messages
204
Reaction score
76
Location
Riverside, CA
Vehicle(s)
2018 Wrangler JL Sport S
I checked before posting this and didn't find anything so here we go.

Has anyone had the issue with their phone being removed from Uconnect when they plug in to use Android Auto? I have the 7" so I usually plugin if I need to use Google Maps. I have set up my phone more times than I can remember and set up all my favorites but the second I plug in the phone it all goes away. I'm beginning to think the Uconnect software for the 7" is more than just a flickering screen issue.
My experience was similar. I found AA finicky. My conclusion was that Google AA was updating without regard to systems like UConnect. My resolution was to abandon AA. That is a rather nuclear solution. UConnect has very few updates. AA has a lot. I can only suggest playing with the order of events. Plug first then start UConnect (Jeep) or other sequences. Keep us posted.
 

Jehovasfitness

Well-Known Member
Joined
Apr 7, 2018
Messages
210
Reaction score
109
Location
Maryland
Vehicle(s)
JLUR and '04 Z06
Have you tried what happens if you use Waze? that's what I use, no issues like that
 

BRuby

Well-Known Member
Joined
Nov 28, 2019
Messages
285
Reaction score
285
Location
Backcountry Mtns
Vehicle(s)
JLUR Benz Porsche Subie +
I checked before posting this and didn't find anything so here we go.

Has anyone had the issue with their phone being removed from Uconnect when they plug in to use Android Auto? I have the 7" so I usually plugin if I need to use Google Maps. I have set up my phone more times than I can remember and set up all my favorites but the second I plug in the phone it all goes away. I'm beginning to think the Uconnect software for the 7" is more than just a flickering screen issue.
Maybe try this. Contact your dealer and ask them to check if the latest firmware is installed. We had an intermittent connection problem because our firmware updates “just disappeared”. So try that.

We also notice that the same phones with the same latest Android 10 OS may interact differently using AA. GM works fine and phone favourites remain in place though. Our screen does not flicker however.
 
OP
OP
Punk'n Willy

Punk'n Willy

Well-Known Member
First Name
Steve
Joined
Feb 24, 2020
Messages
223
Reaction score
443
Location
Harrisburg, PA
Vehicle(s)
2020 Jeep JLU 3.6L Punk'n Willys
Occupation
Video Editor
Vehicle Showcase
1
Have you tried what happens if you use Waze? that's what I use, no issues like that
Waze isn't working at all for me when plugged in.
Maybe try this. Contact your dealer and ask them to check if the latest firmware is installed. We had an intermittent connection problem because our firmware updates “just disappeared”. So try that.

We also notice that the same phones with the same latest Android 10 OS may interact differently using AA. GM works fine and phone favourites remain in place though. Our screen does not flicker however.
Yeah dealer is my next step because it's been crazy since I got my Jeep. I'll be moving back to Apple soon as I know my wife hasn't had any issues that I noticed with her iPhone.
 

Joe98

Well-Known Member
First Name
Joe
Joined
Aug 23, 2018
Messages
779
Reaction score
911
Location
Sydney
Vehicle(s)
2019, 2 door Sport S, Mojito!
I have a JL Wrangler with the 7" screen and a Samsung phone.

To use Uconnect, the phone is linked to the Jeep via Bluetooth.
To use Android Auto, I must plug in the phone with a cable.

I use Android Auto for the 2 things that Uconnect doesn't do.
- Google maps
- If I receive a TXT, Google will read it to me.

I have had my Jeep for about 15 months. Once every 2 or 3 months, the Bluetooth will disconnect. It is easy to pull over and re-connect.

Yesterday I could not re-connect. Then I stopped at a destination. As I drove away, I noted the Bluetooth was reconnected! Mysterious.


PS:
I don't see any link between using Google maps and losing the Uconnect-Bluetooth connection.
 
OP
OP
Punk'n Willy

Punk'n Willy

Well-Known Member
First Name
Steve
Joined
Feb 24, 2020
Messages
223
Reaction score
443
Location
Harrisburg, PA
Vehicle(s)
2020 Jeep JLU 3.6L Punk'n Willys
Occupation
Video Editor
Vehicle Showcase
1
PS:
I don't see any link between using Google maps and losing the Uconnect-Bluetooth connection.
I don't so much blame Google Maps as much as I blame Android Auto and Uconnect for not getting along properly.
 

DanFelix

Well-Known Member
Joined
Dec 22, 2018
Messages
204
Reaction score
76
Location
Riverside, CA
Vehicle(s)
2018 Wrangler JL Sport S
I have a JL Wrangler with the 7" screen and a Samsung phone.

To use Uconnect, the phone is linked to the Jeep via Bluetooth.
To use Android Auto, I must plug in the phone with a cable.

I use Android Auto for the 2 things that Uconnect doesn't do.
- Google maps
- If I receive a TXT, Google will read it to me.

I have had my Jeep for about 15 months. Once every 2 or 3 months, the Bluetooth will disconnect. It is easy to pull over and re-connect.

Yesterday I could not re-connect. Then I stopped at a destination. As I drove away, I noted the Bluetooth was reconnected! Mysterious.


PS:
I don't see any link between using Google maps and losing the Uconnect-Bluetooth connection.
JL Wrangler, Sport, 7" UConnect. My system reads text messages just fine. I opted for a Garmin for maps as I wanted a map screen more fully in my line of site with the road. Just a preference.
 
Advertisement

Done Right LED
 
Advertisement
Top