7" Uconnect Software Updated by Dealer - Have you experienced this???

SRQgunner

Well-Known Member
First Name
Russ
Joined
Oct 29, 2019
Messages
207
Reaction score
128
Location
Sarasota FL
Vehicle(s)
2018 Jeep Wrangler JL Unlimted Sport S
Vehicle Showcase
1
Have you experienced where it would take a couple of days for a dealer installed Uconnect update to totally update? Heres my story, Keep in mind the iPod work perfectly fine (all functions) before this update.

Had my 2018 Sport S at the dealer today. They performed a software update on my 7" Uconnect.

Before leaving the dealership I notice my iPod was not working correctly - The album cover and artist did not display, when you selected tracks nothing came up, when you selected song info it said this feature is not available on this device. Also nothing happened when I tried to select the repeat song or shuffle buttons.

The service dept disconnect the battery for 10 minutes and we tried the iPod again - same results. They could not figure it out, only saying that "well sometimes when the make these upgrades things don't work like they use too!"

At this point I was frustrated. On the way home I call Uconnect support. The specialist said "well this is a new software release and it may take a couple of days for everything to update."

Have you ever experienced this?
Advertisement

 

noswttea4u

Well-Known Member
First Name
Seth
Joined
Sep 5, 2019
Messages
70
Reaction score
24
Location
Marietta, GA
Vehicle(s)
2020 JLR
I can't help, but I didn't know people still used iPods. Good times.
 
OP
OP
SRQgunner

SRQgunner

Well-Known Member
First Name
Russ
Joined
Oct 29, 2019
Messages
207
Reaction score
128
Location
Sarasota FL
Vehicle(s)
2018 Jeep Wrangler JL Unlimted Sport S
Vehicle Showcase
1
I can't help, but I didn't know people still used iPods. Good times.
Personal pref is all - Its for music only and. I can leave it plugged in 24/7. I don't like having to plug my iPhone in evertime I get into the Jeep.

But lets say I did use iPhone and  car play and something didn't work correctly. Does it still take a couple of days for an update to totally update?
 

johnparjr

Well-Known Member
First Name
John
Joined
Jan 7, 2019
Messages
529
Reaction score
510
Location
Roseville
Vehicle(s)
2018 Sahara unlimited JL
What they where trying to say its a glitch and probably will go away after a few days when it works itself out
 
OP
OP
SRQgunner

SRQgunner

Well-Known Member
First Name
Russ
Joined
Oct 29, 2019
Messages
207
Reaction score
128
Location
Sarasota FL
Vehicle(s)
2018 Jeep Wrangler JL Unlimted Sport S
Vehicle Showcase
1
What they where trying to say its a glitch and probably will go away after a few days when it works itself out
my thoughts also. There’s a problem with the new update and there hoping it will eventually fix itself!
 

willcasp

Well-Known Member
First Name
William
Joined
Jun 23, 2019
Messages
290
Reaction score
169
Location
Bothell, WA
Vehicle(s)
2018 JLU Sport S
Have you experienced where it would take a couple of days for a dealer installed Uconnect update to totally update? Heres my story, Keep in mind the iPod work perfectly fine (all functions) before this update.

Had my 2018 Sport S at the dealer today. They performed a software update on my 7" Uconnect.

Before leaving the dealership I notice my iPod was not working correctly - The album cover and artist did not display, when you selected tracks nothing came up, when you selected song info it said this feature is not available on this device. Also nothing happened when I tried to select the repeat song or shuffle buttons.

The service dept disconnect the battery for 10 minutes and we tried the iPod again - same results. They could not figure it out, only saying that "well sometimes when the make these upgrades things don't work like they use too!"

At this point I was frustrated. On the way home I call Uconnect support. The specialist said "well this is a new software release and it may take a couple of days for everything to update."

Have you ever experienced this?
Sounds like you are dealing a with folks that have no clue what they are talking about.

If your ipod is not working properly with the new update, and it used to work properly.. it is a bug in the update. The clowns that wrote the new software need to fix it. There is no excuse for "upgrades" to work any worse than what they replace. They should work better.

The uconnect person you spoke with is clueless. I don't know much about the specifics of uconnect. I do understand embedded systems well, which the uconnect is one of.

The dealer flashes the software image. Once that image boots up, that is it. There is no more unpacking. The 7" is a closed system, with no remote update facility like the 8.4". There is no "couple of days for everything to update" on the 7". Once the image is flashed and it boots.. that is what you have. Baring some config file getting trashed, and other entropy related items like that.. it either works or it does not work. If it does not work, the software engineers need to look up the problem and code a fix.
 
OP
OP
SRQgunner

SRQgunner

Well-Known Member
First Name
Russ
Joined
Oct 29, 2019
Messages
207
Reaction score
128
Location
Sarasota FL
Vehicle(s)
2018 Jeep Wrangler JL Unlimted Sport S
Vehicle Showcase
1
Sounds like you are dealing a with folks that have no clue what they are talking about.

If your ipod is not working properly with the new update, and it used to work properly.. it is a bug in the update. The clowns that wrote the new software need to fix it. There is no excuse for "upgrades" to work any worse than what they replace. They should work better.

The uconnect person you spoke with is clueless. I don't know much about the specifics of uconnect. I do understand embedded systems well, which the uconnect is one of.

The dealer flashes the software image. Once that image boots up, that is it. There is no more unpacking. The 7" is a closed system, with no remote update facility like the 8.4". There is no "couple of days for everything to update" on the 7". Once the image is flashed and it boots.. that is what you have. Baring some config file getting trashed, and other entropy related items like that.. it either works or it does not work. If it does not work, the software engineers need to look up the problem and code a fix.

@willcasp thanks for helping me make sense of this situation. I'm pretty goo with computers and when she told me to give it a couple of days I said "really?"

I'm going to reset the Uconnect through the settings this morning and see if that does anything. Interesting enough I tried the smaller iPod Nano and poof! it worked. The only problem with the Nanos is that when you restart the vehicle after like 10 minutes it doesn't recognize it and you have to unplug and plug it back in.

Really frustrated with the dealership as they acted like hmm we tried everything we could sorry. Just like asking them to assist in getting the sales code to add factory LED / DRL fender lights to my Sport S there like mmmm we don't know how.
 

willcasp

Well-Known Member
First Name
William
Joined
Jun 23, 2019
Messages
290
Reaction score
169
Location
Bothell, WA
Vehicle(s)
2018 JLU Sport S
@willcasp thanks for helping me make sense of this situation. I'm pretty goo with computers and when she told me to give it a couple of days I said "really?"

I'm going to reset the Uconnect through the settings this morning and see if that does anything. Interesting enough I tried the smaller iPod Nano and poof! it worked. The only problem with the Nanos is that when you restart the vehicle after like 10 minutes it doesn't recognize it and you have to unplug and plug it back in.

Really frustrated with the dealership as they acted like hmm we tried everything we could sorry. Just like asking them to assist in getting the sales code to add factory LED / DRL fender lights to my Sport S there like mmmm we don't know how.
It is a sad state of affairs, really. So long as customers excuse this incompetence and bad behavior, it will continue.
 

timn1984

Well-Known Member
First Name
Tim
Joined
Oct 12, 2018
Messages
793
Reaction score
779
Location
Louisville, KY
Vehicle(s)
Jeep Wrangler Unlimited 2018 JL Sahara,Dodge Journey 2012, Toyota Camry 2015
Occupation
Yes
Vehicle Showcase
1
I know I'm a little late to the party, but the software update explicitly says

SYMPTOM/CONDITION:


Customers may experience one or more of the following:

• Radio may reset, turn off and then back on.

• Audio distortion heard during phone calls and CarPlayT.

• Rear View Camera (RVC) display screen turns blue or green.

• Off Road App is missing.

DIAGNOSIS:

Using a Scan Tool (wiTECH) with the appropriate Diagnostic Procedures available in Service

Library/TechCONNECT, verify all related systems are functioning as designed. If Diagnostic Trouble

Codes (DTCs) or symptom conditions, other than the ones listed above are present, record the

issues on the repair order and repair as necessary before proceeding further with this bulletin.

NOTE: Under no circumstances should this procedure be performed WITHOUT a customer


concern that matches the symptoms listed above. All vehicles will receive the FOTA



update when the proper conditions have been met

 

Grooster

Well-Known Member
First Name
Greg
Joined
Aug 23, 2019
Messages
83
Reaction score
96
Location
Wichita, Kansas
Vehicle(s)
2019 Jeep Wrangler Unlimited Sahara, 2016 Jeep Cherokee Latitude
I had the dealer update applied at my first oil change/tire rotation. I was having some wonky connection problems with Car Play. While the wonkiness didn't completely go away, over time the experience improved. Occasionally, I do have to disconnect/connect the iPhone and then life gets better.

I have tried two iPod Nanos of different generations, leaving them plugged in. Same deal, sometimes the iPod works great, other times not so much. Not a big deal to me as I take the age of the iPods into consideration. They are 10 years old connecting to a new device. The iPhone is really an iPod so just running music from the iPhone has been a better experience.
 
Advertisement

Motor City Aftermarket
 
Advertisement
Top