3.6l Engine Skipping?

HeavyUser

Well-Known Member
Joined
Jun 17, 2019
Messages
525
Reaction score
411
Location
CO
Vehicle(s)
JL
Ever since I bought the Jeep I get this intermittent issue where I am holding the gas pedal steady cruising then out of no where it feels like the engine skips a beat. The engine is humming along and then for a brief second it almost feels like a pause in the rhythm of the engine. It happens extremely fast, no loss of power from what I can tell. It's a hard feeling to accurately describe.

Anyone else experiencing anything like this?





Advertisement

 

ChimpanZed

Well-Known Member
First Name
Aaron
Joined
Sep 19, 2019
Messages
224
Reaction score
377
Location
Colorado
Vehicle(s)
2020 Unlimited Rubicon
Try tightening your battery clamps. My jk did the exact same thing and was cured by simply making the battery clamps snug on the terminals.
 
OP

HeavyUser

Well-Known Member
Joined
Jun 17, 2019
Messages
525
Reaction score
411
Location
CO
Vehicle(s)
JL
  • Thread starter
  • Thread Starter
  • #3
Also, this doesn't happen when I apply the gas heavily, it only happens when I'm at cruising speeds, usually in 4th gear.

I'll check the battery terminals, thank you.
 

maguro

Well-Known Member
First Name
Ken
Joined
Nov 25, 2017
Messages
441
Reaction score
539
Location
Canadian Rockies
Vehicle(s)
Punk'n JLUR
Engine skipping? As in a misfire?

Are you driving a 6spd? If so, what happens if you gear down and maintain the same speed as before?
 

dsgrey

Well-Known Member
First Name
Kevin
Joined
Apr 19, 2019
Messages
554
Reaction score
439
Location
Texas
Vehicle(s)
2019 JLU
Vehicle Showcase
1
Seems like the engine skipping/misfire would quickly throw a code. My other vehicles would and most before it got that bad.
 
OP

HeavyUser

Well-Known Member
Joined
Jun 17, 2019
Messages
525
Reaction score
411
Location
CO
Vehicle(s)
JL
  • Thread starter
  • Thread Starter
  • #6
Engine skipping? As in a misfire?

Are you driving a 6spd? If so, what happens if you gear down and maintain the same speed as before?
Yes, six speed. No, not a misfire. I had those already with this engine. The misfires pretty much instantly felt like loss of power and rough idle. This feels like a hiccup, almost like the tires lost traction for a brief second. I don't think it has to do what gear I am in, but I don't remember specifically changing gears and it going away. The "skipping" is so random and happens so quickly that if it happened once and I changed gears it probably wouldn't happen again.
 

Advertisement




Allmoparparts.com
 



Advertisement
Top