2019 JL Unlimited suspension issue

Jpspaz

Member
Joined
Jan 22, 2019
Messages
14
Reaction score
0
Location
CT
Vehicle(s)
2019 Sahara Unlimited
I have a 2019 Sahara Unlimited I ordered early December and picked up about two weeks ago. On Monday here in the northeast we had temps below zero along with a snow/ice storm. While driving to work over snow packed frozen roads I noticed what sounded and felt like a loose suspension component underneath the driver’s footwell area. Two days later the temps warmed up and road conditions improved. It seems to have gone away but I’m not convinced. I am aware of the previous weld issues and mine appear to be good. I also looked underneath and there is nothing obvious. I thought that maybe the extreme cold caused the components and bushings to stiffen up but I don’t want to ignore it.

I know I can bring it to the dealer but I absolutely despise dealer service departments. I could write a book on all of the issues I’ve had over the years. When I can do repairs myself, I always will. If I can’t, I watch them like a hawk and inspect their work. I’d like to know if anyone has had a similar issue or can offer some advice on what the problem might be. Thanks.
 

cns721

Well-Known Member
First Name
Chris
Joined
Sep 10, 2018
Messages
219
Reaction score
142
Location
Rochester NY
Vehicle(s)
'04 WJ, '13 JKU Sahara, '18 WK2 High Altitude, '19 JLUR
Occupation
Software Developer
It could have been ice trapped somewhere.
 
OP

Jpspaz

Member
Joined
Jan 22, 2019
Messages
14
Reaction score
0
Location
CT
Vehicle(s)
2019 Sahara Unlimited
  • Thread starter
  • Thread Starter
  • #3
It went away when things warmed up but we are back in a deep freeze and the sound has returned.
 

Advertisement




WheelsASAP
 



Advertisement
Top