“Service Axle Locker System” Light On

danotje

Well-Known Member
First Name
Dan
Joined
Nov 9, 2018
Messages
141
Reaction score
490
Location
Alaska
Vehicle(s)
2018 Jeep Wrangler Unlimited Rubicon
Vehicle Showcase
1
Just developed this problem, too, after 12K miles, Aug 2018 build. I’m going to take a look at the wiring this weekend as that seems the likely culprit, but found some interesting things in diagnosing it. First, warning light comes on and has stayed on. Next, it seems the lockers are working, but difficult to tell. Also, when looking at the small display, it shows what I select accurately (lockers on/off). The OR pages show both ends locked regardless of config and does not change. When selecting both lockers, the switch’s top light comes on and goes steady, but the bottom light also comes on and blinks. Finally, after shifting out of 4wd and deselecting the lockers, the warning went out. After cycling the ignition, the warning is back, switch lights out, small display in 2wd and no lockers, OR pages show locked.

I’m guessing either wiring issue or the DCU. Anyone have any ideas?

92A7BF55-730F-4743-BF3E-6D25C2FB6413.jpeg


14841CFD-FFEB-433E-8F52-64B684E08BD8.jpeg


04A52EC0-55B8-498F-BFCD-355D0C65C4E8.jpeg
Advertisement

 

Jeepgirl73

Member
Joined
Aug 3, 2018
Messages
12
Reaction score
3
Location
Texas
Vehicle(s)
2006 TJ, 2018 JL Rubicon
Mine is back in the shop and been there 3 weeks. Already had the drive train control module replaced and the rear axle for the locker system and the warning came back on within 2 weeks of having that all completed. Now it has an open circuit and they can't find it. Just waiting to see what happens. Been almost a year since this all started.
 

danotje

Well-Known Member
First Name
Dan
Joined
Nov 9, 2018
Messages
141
Reaction score
490
Location
Alaska
Vehicle(s)
2018 Jeep Wrangler Unlimited Rubicon
Vehicle Showcase
1
Mine is back in the shop and been there 3 weeks. Already had the drive train control module replaced and the rear axle for the locker system and the warning came back on within 2 weeks of having that all completed. Now it has an open circuit and they can't find it. Just waiting to see what happens. Been almost a year since this all started.
Wow! That’s not encouraging news. On the positive side, it does seem to back up a wiring issue. I’m curious about the DCU, but sounds like it didn’t do anything for you. I wish you luck and hopefully we’ll both get it fixed.
 

Jeepgirl73

Member
Joined
Aug 3, 2018
Messages
12
Reaction score
3
Location
Texas
Vehicle(s)
2006 TJ, 2018 JL Rubicon
Newest update - they have my rear diff torn apart (again) and tech is calling Star Line for further instructions on what to do because everything is connected correctly. Now just more waiting.
 

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,638
Reaction score
2,292
Location
Auburn Hills, MI
Vehicle(s)
JL
Newest update - they have my rear diff torn apart (again) and tech is calling Star Line for further instructions on what to do because everything is connected correctly. Now just more waiting.
We're sorry to hear about your continued concern. If you would like, we would be happy to connect you with a Case Specialist to work with you and your dealer. Our team is available via PM.
Alex
Jeep Cares
 

Jeepgirl73

Member
Joined
Aug 3, 2018
Messages
12
Reaction score
3
Location
Texas
Vehicle(s)
2006 TJ, 2018 JL Rubicon
We're sorry to hear about your continued concern. If you would like, we would be happy to connect you with a Case Specialist to work with you and your dealer. Our team is available via PM.
Alex
Jeep Cares
Sent you a message
 

Mixedup4x4

Member
Joined
Mar 20, 2019
Messages
16
Reaction score
9
Location
Cary, nc
Vehicle(s)
2018 rubicon
Vehicle Showcase
1
Took my JLUR in today for Service Axle Locker System light and they wouldn't touch it. I have gear oil leaking into the plug assembly from within the differential. NOT a happy camper right now. I didn't buy a $55k jeep to NOT have lockers. @JeepCares I have set you a message already.
 

jonskijeep

New Member
First Name
Jon
Joined
Jan 25, 2020
Messages
1
Reaction score
0
Location
Charleston
Vehicle(s)
2019 JLUR
I have the same light for service on mine. Bringing it in to dealer on Wed 5/20. Will share what I find out. @JeepCares i will send you a PM.
 

mgroeger

Well-Known Member
First Name
Mike
Joined
Feb 1, 2018
Messages
4,587
Reaction score
6,060
Location
Hurricane, UT
Vehicle(s)
2018 JLUR, 2020 Acura RDX A-Spec
Occupation
I make microchips for a living.
Vehicle Showcase
1
Took my JLUR in today for Service Axle Locker System light and they wouldn't touch it. I have gear oil leaking into the plug assembly from within the differential. NOT a happy camper right now. I didn't buy a $55k jeep to NOT have lockers. @JeepCares I have set you a message already.
I have this same problem. Took mine to the dealer, they pulled the code and the protocol is to replace the entire axle. Talked to head tech and he said FCA wants the entire axle assembly back for diagnostics. They told me since I re-geared I'm screwed, they won't touch it since I was in the diff. What a bunch of BS.
On top of it they never did ANYTHING... didn't pull the connector, not a thing. They saw the code and saw that it was the actuator and that was it. I took the Jeep home, pulled my wife's locker harness and connected it to my Jeep and could hear the actuator working, thereby proving the actuator works. I cleaned the connector plug and put it back together but can't get the stupid code off the dash so the lockers still won't engage.
@JeepCares could you please contact me so I can talk to someone because at this point the dealer is saying there is nothing they can do because I touched the differential.
 

JeepCares

Well-Known Member
Joined
Feb 1, 2018
Messages
4,638
Reaction score
2,292
Location
Auburn Hills, MI
Vehicle(s)
JL
I have this same problem. Took mine to the dealer, they pulled the code and the protocol is to replace the entire axle. Talked to head tech and he said FCA wants the entire axle assembly back for diagnostics. They told me since I re-geared I'm screwed, they won't touch it since I was in the diff. What a bunch of BS.
On top of it they never did ANYTHING... didn't pull the connector, not a thing. They saw the code and saw that it was the actuator and that was it. I took the Jeep home, pulled my wife's locker harness and connected it to my Jeep and could hear the actuator working, thereby proving the actuator works. I cleaned the connector plug and put it back together but can't get the stupid code off the dash so the lockers still won't engage.
@JeepCares could you please contact me so I can talk to someone because at this point the dealer is saying there is nothing they can do because I touched the differential.
Hi Mike,
We're sorry to hear about your experience. I would be happy to connect you with a Case Specialist to work with you and your dealer to see if there is anything we can do on our end to assist. Please send our team a private message.
Alex
Jeep Cares
 

mgroeger

Well-Known Member
First Name
Mike
Joined
Feb 1, 2018
Messages
4,587
Reaction score
6,060
Location
Hurricane, UT
Vehicle(s)
2018 JLUR, 2020 Acura RDX A-Spec
Occupation
I make microchips for a living.
Vehicle Showcase
1
Here's the latest...
I am able to take the simple two wire locker harness off of my wife's Jeep and connect it to my lockers and actuate them thereby showing the locker works.
Based on that the dealer decided to do a deeper dive and found my harness to be OK. The tech OCD'd the situation and keeps coming back to the locker being bad OR the ever so slight possibility that the DCM for the lockers is bad.
FCA's solution is a new $2k axle under warranty BUT since I re-geared, and thereby touched the locker, I have voided that warranty.
FCA procedure states to replace axle first and if that does not work THEN replace the $300 DCM for the lockers. Unreal... do the procedure that is 7X more expensive first.
The dealer said they can replace the DCM and if it fixes it I would be covered under warranty since that was the problem but if it doesn't fix it I would be on the hook for the bill because they are going out of the FCA recommended steps. So the dealer has done all they can do at this point from a warranty perspective.
My buddy and I are going to nerd out on it this weekend and check the resistance across the solenoid and some other stuff and see what we can come up with. What a CF.
If that doesn't work there is a highly reputable gear shop near the dealer I will take it to and have them diagnose it. Depending on what they find and do I might be able to still get it covered under warranty, who knows. The dealer is pretty cool about trying to work with me but at the end of teh day they have to follow the FCA crap guidelines no matter how stupid they are. You know they are bad when the tech and service advisor read them and laugh at the order of protocol.
 

Jolonghorn

Well-Known Member
First Name
James
Joined
Dec 14, 2017
Messages
252
Reaction score
284
Location
Houston
Vehicle(s)
2018 JLUR
Ok, my check engine light came on last week and the Service Axle Locker system light has been coming on for about 1.5 months. Have an appointment with me dealer tomorrow to get it all looked at. Let’s hope they can diagnose and repair the problem.
 

mgroeger

Well-Known Member
First Name
Mike
Joined
Feb 1, 2018
Messages
4,587
Reaction score
6,060
Location
Hurricane, UT
Vehicle(s)
2018 JLUR, 2020 Acura RDX A-Spec
Occupation
I make microchips for a living.
Vehicle Showcase
1
Ok, my check engine light came on last week and the Service Axle Locker system light has been coming on for about 1.5 months. Have an appointment with me dealer tomorrow to get it all looked at. Let’s hope they can diagnose and repair the problem.
Their solution is going to be to replace the axle which may or may not fix the problem.

Since I re-geared I no longer have the axle covered under warranty. We opened the diff and took the locker out and ran some tests and we think we may have found the problem but I can't fully test it because we also found that the axle shafts were slightly twisted at the splines and there was a "human error" on re-install and the outer seal and ring got jacked up so... time to upgrade to chromoly shafts!!!
Once they get here I can fully test the locker.
I'm going to do a write up in hopes it will help others but I might as well get that ball rolling here.

Inside the diff is your locker and on that locker is a solenoid which activates the locker. It really is that simple. Attached to that solenoid is another switch that straddles a magnet. That switch is what tells the control system in the Jeep if the locker is engaged or not so all the pretty lights on the dash tell you what is going on. That magnet is attached to the locker plate and moves up and down in a channel in the switch housing.
If that switch can't figure out the state of the locker it tells the computer to throw a code and disable the locker system. From the beginning we suspected this switch might be the culprit since I could activate the locker using my wife's Jeep's locker harness and we found no problems with my harness.
Remember I said that switch straddles a magnet? Well just like the drain plug magnet any metal "dust" which comes from the gears as they wear will be attracted to any magnet it can find. Enough "dust" accumulated on that switch magnet to actually bridged the channel the magnet sits in thereby creating an electrical reading on the control wiring thinking the locker is on.
We put an ohm meter across the two leads on the switch, with the locker not engaged it read 37.5 ohms, then we manually engaged the locker it still read 37.5 ohms. We cleaned all of the "dust" off the magnet and took another reading and low and behold it was 37.5 ohms with the locker open and infinity ohms with it closed. We re-installed the locker and did a quick test and even with the error code still present I was able to engage and disengage the locker once but you could tell the system was fighting me since it kept flashing the code and I couldn't do it again.
We figure at this point getting it out for a spin might clear the code but I have the axle issue to contend with before I can do that.
I did talk to Joe at Tazer and he wrote me some software to clear the code and it does work but the error comes right back so if a trip around the block and another clear with the Tazer doesn't work I'll have to hit the dealer to clear the code.
I should be getting the axles Thursday and installing them Friday and will post back.

EDIT:
Here are some pics to go with the write up:

20200531_123158.jpg


20200531_123151.jpg

20200531_122944.jpg
 
Last edited:

mgroeger

Well-Known Member
First Name
Mike
Joined
Feb 1, 2018
Messages
4,587
Reaction score
6,060
Location
Hurricane, UT
Vehicle(s)
2018 JLUR, 2020 Acura RDX A-Spec
Occupation
I make microchips for a living.
Vehicle Showcase
1
I'll post pics when i get them off my friend's phone.
 
Advertisement

ATO4x4
 
Advertisement
Top