Search results

  1. Mopar Steel Rear Bumper help

    Thinking the same, I was about to put on the steel rear bumper until I heard about these issues. Wondering if there is any way to avoid making any damage to the body with the steel rear bumper. This video does a good job illustrating at least one of the reasons damage is caused (after he...
  2. Mopar Steel Rear Bumper help

    Thanks @stallbrk! Thats going to be super helpful. Have you had any issues with the steel bumper rubbing against the body?
  3. Mopar Steel Rear Bumper help

    Are there any issues with the holes lining up? This is for the plastic panel closeouts for the steel bumper?
  4. Low Voltage Issue on the 2.0L - Turbo Boost Lag

    Darn, for some reason my dealer didn't do the PCM update you got. Wonder why that's the case. I havent had a chance to test the jeep off road yet either, so I'm unsure if my issue is resolved. I had my battery tested before I got the software updates, dealer didn't find any issues there. To me...
  5. Mopar Steel Rear Bumper help

    @LoganDzwon did you have any luck figuring out what part numbers those panel close outs were? Running into the same problem here. Thanks!
  6. TFLcar has issues with their Rubicon 2.0

    Getting the TSB's done today, will have to do some harder high elevation trails to see if I run into any issues but I'll definitely let you know!
  7. TFLcar has issues with their Rubicon 2.0

    Yep, I've had an issue and the video was actually pretty helpful with confirming the TSB's that are needed. Here's a related thread where owners have been talking about the same issue: https://www.jlwranglerforums.com/forum/threads/low-voltage-issue-on-the-2-0l-turbo-boost-lag.33154/
  8. Low Voltage Issue on the 2.0L - Turbo Boost Lag

    Thanks @DexterJeeper , that's super helpful. My Jeep support contact actually mentioned one of those TSB's but wanted to have the dealer see some error codes before they made any fixes. However, when I did go to the dealership my error codes had already cleared from the system since it seems...
  9. Low Voltage Issue on the 2.0L - Turbo Boost Lag

    I haven't had any luck with finding a solution with FCA/Jeep support yet, does anyone here have anything I could work off of? Any help would be awesome
  10. Low Voltage Issue on the 2.0L - Turbo Boost Lag

    @Prowlers were you able to find the cause of your battery issue?
  11. Low Voltage Issue on the 2.0L - Turbo Boost Lag

    @H-Poverty have you had any luck resolving your issue? I've had a similar one with my 2019 2.0L JLUR ~7000k miles. Recently went off-roading in 4L up a steep road in high altitude (8000+ft) and my Wrangler showed a battery warning light some 20mi into the trail. I then noticed the battery...
Advertisement
Top