Search results

  1. USB port was working now it isn’t sorta...

    update to this saga. It’s been one year and they turned off the free SXM. My Carplay starting working flawlessly!
  2. CarPlay problems

    It’s been one year to the day since I brought my new jeep home. CarPlay has only worked with a fuse game. They turned off the free SXM service. My CarPlay starting working flawlessly!
  3. Premium Softtop Rear Window Issue

    I suspect every JL will have this problem. If you take too long to get in it fills the mud Matts I spent extra to get. Bad design and manufacturing.
  4. Premium soft top melting in this heatwave.

    I just picked my jeep up from dealer .... they just looked at me and said nothing we can do about that. Also, CarPlay still doesn’t not work even after software update. During my last trip I piled my Topo maps in the passenger seat..... the extremely thin leather material that is used tore from...
  5. Premium Softtop Rear Window Issue

    I took my new JL on a two month trip to NC. It rained damn near every day. The rear window flaps never stayed secure but worse than that is the top interferes with the rain gutters! Water pours off the soft top and right into the jeep floor through every door when you open them to get in or out...
  6. Premium soft top melting in this heatwave.

    Yes, I am in Florida,We are ok with this Verbiage. they sag and look bad all during the day. But my biggest complaint is the the top does not fit well and funnels all water straight into the vehicle through ever door when it is raining. No way to get in and out without a puddle of water in...
  7. Received Free Mopar Jeep JL Touch Up Paint

    Yes, it was the wrong color for my jeep. They sent Black. My jeep is Crystal Granite.
  8. USB port was working now it isn’t sorta...

    Just got off the phone with Jeep. They confirmed a verity of problems with the 7” radios and CarPlay. No solutions have been identified. I was told that the dealership would be paid under warranty to replace the 7” with the 8” display that don’t seem to have the CarPlay problem (couple hours...
  9. USB port was working now it isn’t sorta...

    Frustrated, My jeep has been back to the dealership twice for this problem for a total of 14 days with no resolve. I came to look at this thread and found this new entry. So I went out to see if I could get mine to work. It has not worked since the day I picked it up three months ago. This trick...



Advertisement
Top